Jump to content
Johnbee58

Is There A Problem With Focusrite Drivers

Recommended Posts

Posted (edited)

I posted this a few months ago when I had my Windows 8.1 PC running my Focusrite 6i6 interface.  It would occasionally go into a BSOD with different error messages ranging from "System Exception" to "Bad Pool Caller" and IRQL errors.  I asked Focusrite tech support for help.  They linked me to beta drivers to try.  I tried them.  Problem persisted.  Their final recommendation: Upgrade to Windows 10.

Last week I bought a brand new Dell Core I5 running none other than Windows 10!!  Twice this week I got the damned error again on the new PC!!  I contacted Focusrite tech support and they linked me to beta drivers, which they asked me to try again.  I don't know if I want to.  My Firefox browser will not allow me to access the site the beta is on because of security (certificate) reasons.

Does anybody else have a Focusrite interface that is presenting these problems?

🤨John B

Edited by Johnbee58

Share this post


Link to post
Share on other sites
9 hours ago, AndyB01 said:

@Johnbee58 did you not see this thread?

I have posted a link to a new beta release - might help

Andy

If you already read the thread - you might want to revisit it again - I added info related to using the 3.0 USB ports for your Focusrite . . .

Syphus

Share this post


Link to post
Share on other sites

2nd gen 18i20 here, now purring along on the beta site drivers after a few BSOD with the Bad Pool Calling message leading to he usb driver from Focusrite in WhoCrashed.

One thing to note, do NOT install both USB and Thunderbolt drivers, only the one or the other. I suspect installing both leads to BSOD, but i’ve no input from Focusrite on this.

J

Share this post


Link to post
Share on other sites
On 8/8/2021 at 10:57 AM, Johnbee58 said:

I posted this a few months ago when I had my Windows 8.1 PC running my Focusrite 6i6 interface.  It would occasionally go into a BSOD with different error messages ranging from "System Exception" to "Bad Pool Caller" and IRQL errors.  I asked Focusrite tech support for help.  They linked me to beta drivers to try.  I tried them.  Problem persisted.  Their final recommendation: Upgrade to Windows 10.

Last week I bought a brand new Dell Core I5 running none other than Windows 10!!  Twice this week I got the damned error again on the new PC!!  I contacted Focusrite tech support and they linked me to beta drivers, which they asked me to try again.  I don't know if I want to.  My Firefox browser will not allow me to access the site the beta is on because of security (certificate) reasons.

Does anybody else have a Focusrite interface that is presenting these problems?

🤨John B

My PC is configured as per my signature and I have yet to have any issues with the BETA drivers.  I use a non Firefox browser to access the Focusrite BETA site.

Here is a direct link to the BETA driver (Use a non Firefox to download)

http://beta.focusrite.com/file.php?id=1377

Share this post


Link to post
Share on other sites

FWIW I too started getting BSOD on boot up with the Focusrite drivers (almost certainly down to a Windows update). 

I upgraded to the latest beta driver, and everything is fine now.

 

Share this post


Link to post
Share on other sites
Posted (edited)

All seems well right now with mine.  Don't remember last time I saw a BSOD.  Drivers I have on now are 4.87.4-709.  Security settings on my above mentioned new music PC wouldn't allow me to DL from Firefox, so I took a memory stick over to my laptop, which did allow access and transferred the file to my new PC and installed it.

🙂John B

Edited by Johnbee58

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...