Jump to content
Moving Air Productions

Issue with Export>Audio

Recommended Posts

This is an issue I've had with Cakewalk forever. Might as well work it out.

Why, when you go to "File>Export>Audio" and even though you have "Entire Mix" selected as your audio source, if you happen to accidently have a clip selected, THAT is the only thing that gets mixed down? I would really like to see this get changed. Because I don't know how many times I've worked on a song, exported it, and closed out to polish the song in another piece of software, only to find out that only clip three of the trumpet sample actually got exported. So I have to re-open Cakewalk, then re-open the project, then re-export the song, making sure I haven't clicked on a track before doing it. It's just a frustrating and unnecessary waste of time.

I would like it so when you export via the File menu, and it says "Entire Mix," then you should get the entire mix, REGARDLESS of if a clip is selected or not. If I wanted ONLY that clip, then I would select "Tracks" as my source.

I really like the fact that the Export module in the control panel will give you everything, regardless of if something is highlighted or not, but then you get none of the advanced options, like dither, fast bounce/real time, etc.

So can this issue be fixed please? Just make it so "Entire Mix" gives you everything, regardless of if a clip happens to be selected. Maybe add a "Selected Clip(s) Only" source option for when you only want a specific clip or clips to be exported. And/or add all of the advanced bouncedown features to the Export module of the control panel. I would actually love it if the Export module had all the Export pane features anyway.  But either way.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Or have it tell you the selection is empty (or words to that effect.) I figure that if I select Entire Mix, I mean all of it track-wise. I can see where highlighting a specific section of time would be appropriate and there should still be a mechanism for exports down to a clip.

"The specified selection did not contain any audio data. Please ensure the selection contains audio data you wish to bounce." I clicked on File/Export/Audio.

 

Edited by Terry Kelley

Share this post


Link to post
Share on other sites

maybe an export option "Selected Clips Only" and the "Entire Mix" would automatically assume All Clips to be exported.

Share this post


Link to post
Share on other sites
Posted (edited)

Isn't that what "Clips" is in the Source Category? That's how it seems to work to me. But hey ...

Edited by Terry Kelley

Share this post


Link to post
Share on other sites

The export dialog is selection sensitive, and the source category specifies where it captures the source.

Selecting a source category of "Entire mix" with a single clip or track selected, means put that single clip or track through the entire mix - i.e. through all the buses etc, and capture it after the master bus.

Selecting a source category of "clips" will capture the selected clips as individual files before it hits the track - i.e. there will be no track fx,  no pro channel, and no track volume or panning.

Selecting a source category of "tracks" will capture the selected tracks as individual files before it hits any buses or the master bus.

I quite often want to capture my tracks as it sounds through the master bus - not how it sounds before it hits any buses.  In this case I'll select the track prior to opening the export dialog, and select "Entire Mix".    Alternatively, I'll not select anything, but solo the track and select "Entire Mix"

  • Thanks 1

Share this post


Link to post
Share on other sites

A lot of interesting options here. And while they all have their place, I just want a "What you hear is what you get" option, where I don't have to worry about "did I leave a track highlighted accidentally?" or anything like that. While there are plenty of uses and situations where you could want ONLY that section run thru the meat grinder, for me, those times are much fewer and farther between than just "mix is done. squash it out."

Share this post


Link to post
Share on other sites
8 minutes ago, Moving Air Productions said:

I just want a "What you hear is what you get" option, where I don't have to worry about "did I leave a track highlighted accidentally?" or anything like that.

Try using the Export module instead of the Export dialog.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Moving Air Productions said:

A lot of interesting options here. And while they all have their place, I just want a "What you hear is what you get" option, where I don't have to worry about "did I leave a track highlighted accidentally?" or anything like that. While there are plenty of uses and situations where you could want ONLY that section run thru the meat grinder, for me, those times are much fewer and farther between than just "mix is done. squash it out."

I agree with you , it's a strange way to export a whole track although I've gotten used to it over the years. My process is now to use the Arranger and drag it from the starting point to the end point of the track , then click it once to select everything to export.

Edited by Mark Morgon-Shaw
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, scook said:

Try using the Export module instead of the Export dialog.

I use that for straight two channel mixes. Works well. It's when you must wade into Files/Export/Audio that you need deep insight.

Share this post


Link to post
Share on other sites

As a habit, when planning to Export to Audio, I go to Track 1 and double-click on the Track number, which selects all tracks and the Length Marker(s) to the whole song. Then I do a Save, as a precaution, and use the Control panel Export option. Always captures both the entire mix and the full song length.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...