Jump to content

Recommended Posts

  I have a Soundcraft Signature 22 MTK that I previously used with GarageBand no problem.  Now im on a PC and I wanted to try out CakeWalk but am having some issues.  Originally I was able to get a signal from the board into DAW, record and play back.  On playback there was a clicking noise on the recording (wasn't same tempo as metronome) that I couldn't get rid of.  I swapped Driver Mode from MME to ASIO, got rid of clicking but cant get signal into DAW now.  I have install/swapped driver modes/reinstalled drivers and cant get signal.  Not even a blip on the meter on any configuration.  I've enabled record/echo and still nothing.  Playing back sound from youtube and demo tracks is no problem. 

Any help would be greatly appreciated. 

Share this post


Link to post
Share on other sites
8 hours ago, Luke Wells said:

  I have a Soundcraft Signature 22 MTK that I previously used with GarageBand no problem.  Now im on a PC and I wanted to try out CakeWalk but am having some issues.  Originally I was able to get a signal from the board into DAW, record and play back.  On playback there was a clicking noise on the recording (wasn't same tempo as metronome) that I couldn't get rid of.  I swapped Driver Mode from MME to ASIO, got rid of clicking but cant get signal into DAW now.  I have install/swapped driver modes/reinstalled drivers and cant get signal.  Not even a blip on the meter on any configuration.  I've enabled record/echo and still nothing.  Playing back sound from youtube and demo tracks is no problem. 

Any help would be greatly appreciated. 

They are a little fiddly to set up sometimes.

Only use the Asio drivers, whilst they are rock solid, its an idea to re-install them only after a major W10 update.

i have a Cakewalk 16 track template set up with EACH input AND output assigned to a specific channel eg : track 9 will have as input (click on the input downward arrow to select) “Left Soundcraft USB Audio Asio Analogue 9” and as output (click on the output downward arrow) set to “Left Soundcraft USB Audio Asio Analogue 9.”. 
Note  1 if you don’t set the output to a specific channel it will default to master = slider 1. Note 2 : as another eg, to set up Cakewalk track 10 for both input and output select “Right …….. Analogue 9” - Left is for the odd numbered track numbers, Right for the even numbered tracks. Do NOT chose Stereo ……. !

Once  you have assigned an input and output to each track in Cakewalk, save and name as a template. If you don’t you’ll have to go through the above set up again. Its a hassle, i know ……..

Once you’ve armed your template in Cakewalk, on the MTK 22 set up each channel you’re going to use as follows : push down the (grey) button MST to send the signal to the onboard master slider. Set your pan, effects’ EQ and gain levels. For recording make sure the small USB switch to the right and underneath of each (purple) input gain knob is NOT pressed down. (For playback make sure each button IS pressed down. If they are not in the down position for layback you’ll not have sound - this setting sends each track from Cakewalk through the desk and out into your amplified speakers so make sure for each track you recorded said button is down).

The MTK is not a control surface. When you change the volume by moving a slider, that action will not be echoed in Cakewalk. Use the Cakewalk sliders for that.

when i record our group (7 drum mics, bass & 2 guitars DI’d, 3 vocal mics) my i5 laptop plus the MTK  can handle an hour or more long set without sweating.

Hope the above helps, the manual sets it out pretty well.

J
 

 

Edited by Jeremy Oakes
  • Like 1

Share this post


Link to post
Share on other sites

  Thank you for responding.  I've seen your responses helping other people so I have hope now lol.

So, I was going to take it step by step as you laid it out.  Swapped to ASIO drivers, still able to play back from PC so that's good but when I try to change my track input to one of the Soundcraft channels I am unable to select them.  It shows the "Soundcraft USB Audio ASIO Analogue" options but they are all greyed out.  On the playback and recording masters I don't have the option to choose anything from Soundcraft.  If I go into my computer settings the Soundcraft is selected for input and output device.  I have no idea what  I'm doing wrong here.

 

Cakewalk input and out put options 1.PNG

Capture 1.PNG

Capture.PNG

Share this post


Link to post
Share on other sites

Only one ASIO driver may be used at a time.

Deselect both the input and output drivers before making a new selection.

  • Great Idea 2

Share this post


Link to post
Share on other sites
27 minutes ago, scook said:

Only one ASIO driver may be used at a time.

Deselect both the input and output drivers before making a new selection.

Yep, that helps lol.  I figured that out a week ago and forgot since then.   I'm getting signal in and able to record but after I record, when I hit "play" to stop the recording, it freezes the program.   I have 16 gigs of DDR4 ram and a 12 core 3.79 processor.  Shouldn't have any issue running the software.  
  Should I go ahead and do the Cakewalk update from just a few days ago?  I'm not sure how big it is and I have limited data on my internet.

At least this time I saved all the track input settings for each track before trying to record.  Now I don't have to set all that up again.

Share this post


Link to post
Share on other sites

May want to uninstall ASIO4All since you have a manufacturer supplied ASIO driver.

If it still hangs, capture a hang dump.

Here are the instructions

I doubt the update will make a difference.

The size of the update depends on whether you are updating from the previous version or several versions back.

The DAW will download the update installer (which is much smaller than the full installer) if possible otherwise it will download the full installer.

 

  • Like 2

Share this post


Link to post
Share on other sites

Ok.   It didn't hang up this time.  I pressed the record button to deactivate then pressed the play button to stop instead of the other way around.  

I just installed Cakewalk about 2 weeks ago.  I'm on the version that was release June 2021.  Maybe it wont be a huge update.

Share this post


Link to post
Share on other sites
5 minutes ago, bdickens said:

Yes. GET RID OF THAT GARBAGE ASIO4All DRIVER!

Now that I have selected the "Soundcraft USB Audio ASIO Analogue" driver within Cakewalk the "ASIO4All" should be moot correct?  Or should I still uninstall it anyway?

Share this post


Link to post
Share on other sites
4 minutes ago, Luke Wells said:

Now that I have selected the "Soundcraft USB Audio ASIO Analogue" driver within Cakewalk the "ASIO4All" should be moot correct?  Or should I still uninstall it anyway?

Personally i only have the Soundcraft Asio drivers installed. At some point something you installed may have also installed the Asio4All wrapper. You do not need it for the Soundcraft unit. Your call, but i would get rid of it.

J

Edited by Jeremy Oakes
  • Like 2

Share this post


Link to post
Share on other sites
10 minutes ago, Luke Wells said:

Or should I still uninstall it anyway?

yes, uninstall it.

 

Since you are already on 2021.06, it's a good idea to run the update

  • Like 1

Share this post


Link to post
Share on other sites

ASIO4All uninstalled.  Made a crash dmp. file that's currently uploading to drop box.  It was 810mb.  which is taking a while to upload on rural internet.  Going to have to look into the "Microsoft Procdump tool" next time.  
Now maybe I can actually follow along with the "Creative Sauce" youtube channel and learn some stuff from his "Cakewalk" playlist.

I'm still interested to know if anyone knows the size of the most recent update if anyone has that info.  Still waiting on Starlink so I can have decent internet access.

Thank all of you for the help so far, you are a great resource.  I'm sure there will be more questions to come. 

Share this post


Link to post
Share on other sites

Dumps usually compress a lot.

Kill the upload and zip it first.

I'll get a copy of the update installer in a minute.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, scook said:

Kill the upload and zip it first.

Tried zipped and its 100+ mb  and times out before it finishes uploading.  I made a text file to upload with link to dmp. file on dropbox.

1 hour ago, scook said:

Cakewalk_by_BandLab_Update_Setup_27.06.0.057.exe is ~50MB

Sweet thanks.  I can do 50 MB no problem.  10gig or something would be pretty taxing.

 

Share this post


Link to post
Share on other sites

@Luke Wells       just to make sure that all traces of Asio4all are gone go and check your reg edit app and look there. look at my screen shot to follow the pathway.  You should only see your Soundcraft driver which you see I have installed along with my other 3 interfaces. Asio4all can still lurk in the background along with another one called Generic asio driver from Steinberg. In my case they would show up under sync sand caching so check there as well and make sure your Soundcraft driver is the only one in all dialog boxes under audio settings. 

Screenshot (104).png

Screenshot (105).png

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, John Vere said:

make sure that all traces of Asio4all are gone

Ok, I have now removed all ASIO4All from my PC.

I updated to newest version of Cakewalk and the freezing issues have resolved.......  that is until coming back from a break.
  I was sitting here watching some videos on youtube and all is well.  I opened Cakewalk and as soon as I opened a project my youtube video stops and I cant get anything to play regardless of what the video is.  I go to my project and it plays fine, until I try to stop it then the freezing up is back Ahhhhh..... 

I'm going to have to change the title of this TOPIC to something more encompassing.  I'm thinking something  like "The Cakewalk Chronicles". lol

Share this post


Link to post
Share on other sites

That’s normal to not be able to do both at same time. It’s sort of the down side to ASIO

 

 

 

  • Like 2

Share this post


Link to post
Share on other sites
2 minutes ago, John Vere said:

That’s normal to not be able to do both at same time. It’s sort of the down side to ASIO

Any way I can swap back and forth without having to reboot my PC?  Meaning alternating them but not playing them at the same time.

Edited by Luke Wells

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...