Jump to content
Dave Oliffe

Connecting Presonus Audio Interface to Cakewalk - Problem

Recommended Posts

Hi folks,

So I've just upgraded to a new Windows 10 PC, 64 bit (Dr Mix system from Scan.co.uk). It's a very capable machine, so I'm not expecting any issues with regards to power/RAM etc.

I'm brand new to using external audio interfaces and have got myself a Presonus Studio 1824c. My old machine had an internal audio interface so I'm going to have to get used to some differences.

I have followed the instructions for setting up the 1824c, installed the 'Universal Control' application which installs all the drivers and firmware. I've triple-checked all of this is up to date and it is. Everything seems to be working - the interface is working, Universal Control is working, Windows recognises the device etc.

The trouble I'm having is in Cakewalk. Operation is sluggish, there is a constant loading circle. This happens when I have set driver mode to ASIO. My understanding was that this would be the correct driver mode for this interface. However, when I change it to WASAPI (Shared), operation improves a lot. However, I cannot work out what In/Out settings to choose on an audio track. When I select the correct one (I have a hardware synth going into channel 1 on the interface for eg), Cakewalk mis behaves again, becomes sluggish. Once or twice I managed to record audio, but then I can't play it back. It's all very messy.

What am I missing? Is there a setting I've over-looked? 

In addition, attempting to play YouTube results in stuttered playback, of BOTH audio and visuals.

Any help HUGELY appreciated.

Best wishes,

Dave

Share this post


Link to post
Share on other sites

Is Presonus the only entry in HKEY_LOCAL_MACHINE\SOFTWARE\ASIO?

Share this post


Link to post
Share on other sites
6 minutes ago, scook said:

Is Presonus the only entry in HKEY_LOCAL_MACHINE\SOFTWARE\ASIO?

Hi, thank you. There are lots of entries in there, one is called 'Quantum ASIO Driver'

Share this post


Link to post
Share on other sites

The Presonus driver may be the only one needed.

What are the other entries?

Share this post


Link to post
Share on other sites

It may be helpful to know a little more about the other entries.

Even though they may be for other devices (such as the ASIO driver from RealTek or a Generic ASIO driver) does not mean they are harmless.

 

Share this post


Link to post
Share on other sites

Ok, here are all of them, in order...

AudioBox ASIO Driver / ioStation ASIO Driver / PaeFireStudio / Quantum ASIO driver / Realtek ASIO / Revelator ASIO / Studio 192 ASIO / Studio USB ASIO Driver / StudioLive AR ASIO / StudioLive Classic USB / StudioLive Series III ASIO

 

Share this post


Link to post
Share on other sites
Posted (edited)

Oh my that’s not going to be fun at all   That’s terrible. This computer was built for using a daw?  
You want zero bloat ware when optimized for audio. And you interface is all you need 

One ASIO driver. 

Edited by John Vere

Share this post


Link to post
Share on other sites
12 minutes ago, Dave Oliffe said:

Ok, here are all of them, in order...

AudioBox ASIO Driver / ioStation ASIO Driver / PaeFireStudio / Quantum ASIO driver / Realtek ASIO / Revelator ASIO / Studio 192 ASIO / Studio USB ASIO Driver / StudioLive AR ASIO / StudioLive Classic USB / StudioLive Series III ASIO

 

I believe all of those except for the RealTek were installed by Presonus.

The RealTek should be removed. It is a problem driver.

Of the Presonus drivers, the Studio 1824c only uses one of them. The rest serve no purpose but the DAW has to check them every time it starts to see if something is connected to the driver.

Share this post


Link to post
Share on other sites

I am not sure, have not used a Presonus interface in some time.

Presonus support should be able to provide the definitive answer.

If I had to guess... Studio USB ASIO Driver

Export the ASIO entire entry

Delete the entire ASIO entry from the registry

Create a copy of the export, remove all but the Studio USB ASIO Driver and import it then start up the DAW.

Share this post


Link to post
Share on other sites
Posted (edited)

I’m using an 1824

 

Their' driver install defaults to installing all if the drivers. I would recommend uninstalling and re-installing making certain only the Audiobox ASIO driver us selected. That will clean it up fast.

 

Edit

-------

Big Oops! I'm using an 1818VSL

 

Sorry 'bout that!

 

Edited by Keni

Share this post


Link to post
Share on other sites

Hi folks, uninstalled all drivers and reinstalled only the 'Studio USB Driver'. 

I also did a fresh re install of Cakewalk.

The problem still continues I'm afraid. 

1 hour ago, Craig Anderton said:

Studio USB driver is correct. I use the 1824c with Cakewalk, and it works fine.

Craig, what settings do you have as your Input/Output devices in Sound Centre and Cakewalk? I want to make sure I have the right things selected. Also, if you create an audio track in Cakewalk, what are your ins and outs there? 

Using ASIO literally crashes Cakewalk every time - I have to use Task Manager to close it.

 

Share this post


Link to post
Share on other sites

Hope this helps...

pnzTZ5I.jpg

20QO9Zw.jpg

Could Sound Centre be the problem? I never use it, so I don't remember if it has some constraint, like 32-bit only or something like that.

Share this post


Link to post
Share on other sites

Only one ASIO driver may be selected at a time.

To change ASIO preferences, deselect both Input and Output settings first.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

1. De-Select Realtec Asio Driver in Cakewalk audio prefs. Then select Audiobox drivers.

2. Uninstall Realtek Asio driver from your system

Unless you really need it, disable Realtek Audio device in Windows Sound settings and just use the Audiobox for all audio ie make that your default audio device in Windows settings - make sure sample rates in windows match the sample sate in Cakewalk and any other audio apps.  

Edited by Steve_B
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...