Jump to content
  • 0
mdiemer

Is There A Master Setting For This?

Question

I do midi only (not GM but with sound libraries). I use various vstis, like GPO, EW etc. Some of the instruments have a delay in starting, or latency. Especially happens with strings. Until recently I didn't know how to deal with this except by using the slide function, which didn't work very well, and caused the notes in staff view to display incorrectly. So, scook told me I could adjust the timing feature on the track inspector. Indeed, that works. However, it is hard to get right, and with an orchestral piece very tedious. 

Someone on the Vienna Inst. forum said most DAWS have a way to compensate for this latency, usually just a single setting. Well, I've looked around, and I see things like clocks and SMTPE and time stamping, all of which are completely mysterious to me. So, is there such a setting on Cakewalk?

Thanks,

Mike

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0
11 hours ago, mdiemer said:

I do midi only (not GM but with sound libraries). I use various vstis, like GPO, EW etc. Some of the instruments have a delay in starting, or latency. Especially happens with strings. Until recently I didn't know how to deal with this except by using the slide function, which didn't work very well, and caused the notes in staff view to display incorrectly. So, scook told me I could adjust the timing feature on the track inspector. Indeed, that works. However, it is hard to get right, and with an orchestral piece very tedious. 

Someone on the Vienna Inst. forum said most DAWS have a way to compensate for this latency, usually just a single setting. Well, I've looked around, and I see things like clocks and SMTPE and time stamping, all of which are completely mysterious to me. So, is there such a setting on Cakewalk?

Thanks,

Mike

Plugin delay compensation has always been automatic in Cakewalk/SONAR. This is true for both VST and VSTi's.  I've never had an issue with it not working as it should.

You can manually adjust the overall latency if your sound device is incorrectly reporting latency here...

image.png.c028b093195da1e74e16b83e28afa255.png

... but you shouldn't really need to.

What audio interface are you using, and what driver mode (ASIO, WASAPI, MME etc) ?

If it's a latency issue, is it possible your ASIO buffer size set to high? I've found anything over 256 is noticeable.  You should be aiming for the lowest buffer size possible that doesn't introduce pops/clicks or audio dropouts. A buffer size of 64 or 128 is desirable.

It can be changed by pressing the ASIO panel button here (assuming you're using ASIO):

image.png.37989122e75d646d1e7d51073444d4d4.png

Share this post


Link to post
Share on other sites
  • 0

Thanks Mark, I am using the Steinberg UR-22 USB interface. Using ASIO drivers. Currently have latency at 256. 

What 's interesting is that when I was using Reaper I didn't seem to have this problem. So it does appear to be a Cakewalk problem, but just what  is a mystery. I'll go lower on the latency, but with so many plugins I may not be able to get away with it.

Share this post


Link to post
Share on other sites
  • 0

I may be completely wrong here, but as you’re talking about GPO and EW, aren’t you simply talking about instrument articulations with a very long attack time, such as legato strings? If so, that has absolutely nothing to do with latency. The way I try to deal with it is to have those MIDI clips start slightly ahead of the measure so the instruments “sound right” in the context.

If this indeed is the issue, why you wouldn’t have similar problems with Reaper is beyond me.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Canopus said:

I may be completely wrong here, but as you’re talking about GPO and EW, aren’t you simply talking about instrument articulations with a very long attack time, such as legato strings? If so, that has absolutely nothing to do with latency. The way I try to deal with it is to have those MIDI clips start slightly ahead of the measure so the instruments “sound right” in the context.

If this indeed is the issue, why you wouldn’t have similar problems with Reaper is beyond me.

Yeah, that thought has crossed my mind. The fact that it was less of a problem in Reaper was why I thought it was a Cakewalk problem. But you may be right. Maybe Reaper has some way of adjusting for this. If so, I doubt that Cakewalk has, or someone would have told me about it by now. Looks like I'm stuck doing those fine time adjustments. 

Share this post


Link to post
Share on other sites
  • 0

The only reason I can think of that would render different results in Cakewalk and Reason would be if you haven’t compared the exact same articulations and/or not used the exact same velocity. That Reason somehow would compensate for the attack times in different sound libraries different articulations is really hard for me to believe.

Share this post


Link to post
Share on other sites
  • 0

You may be correct Canopus, it doesn't make sense to me either. Not sure what was going on there. Anyway, I guess I am resigned to working with the time thing. It's a pain though, because, say you are working on measure 20. you do something and rewind to ms. 20. But there is no sound. You have to go ms. 19 and go from there, because you altered the starting time, and it now really starts in ms. 19. Another workflow blocker. Oh well...Cakewalk is still the best for me, I'll just have to put up with it. but you are right, it's the strings that are the biggest offenders. It's the bow thing. A case where making the sampled inst. so realistic, it screws up your workflow...

Share this post


Link to post
Share on other sites
  • 0

Might be worth sending a sample project to support with a detailed explanation of the problem. I don't use the plug-ins mentioned in this thread so, have no way to test. Does the problem persist if the project is saved and re-opened? Does the delay vary based on the library loaded or is it constant for the plug-in?

Share this post


Link to post
Share on other sites
  • 0

Hi scook, thanks for responding. The delay does vary within libraries based on the inst. Strings in Vienna are bad; Cinematic Strings (which uses Kontakt) also but less; some wind inst's. in East West have it; some don't. Garritan insts. are fine. It's been a problem for a long time, which I have dealt with in various ways. Often I can't use the desired inst. because of it. But your suggestion before, to use the timing feature, at least gives me a work-around.

Incidentally, the folks on the Vienna forum also have suggested to me that it's due to the strings being slow to speak, as they say, because of the bowing. Except for one guy, who said most DAWS have a way of dealing with this, which is why I posted this thread. Most folks probably deal with it in PRV or track view, where it's easier to move stuff around. But I work in staff view, where doing that messes up the note values, which throws me into conniption fits as I am so tied to working with notation.

Finally,  the problem persists after opening a closed project.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
On 4/16/2019 at 9:30 AM, Canopus said:

...aren’t you simply talking about instrument articulations with a very long attack time...[?]

 

22 hours ago, mdiemer said:

...I guess I am resigned to working with the time thing...

When I engineered live orchestral sessions in the 1980s (for movies), I remember one frustrated producer noting "...the string cues are arriving by bus," his way of saying the string section seems late. So the problem goes back to the days before samplers, I guess. 🙃

That said, in the very few times I have used string in CbB I have noticed them coming in late, and I have compensated manually by increasing MIDI velocity or adjusting attack time. Easy for me to say, I guess, since I rarely used strings.

Edited by Larry Jones
punctuation

Share this post


Link to post
Share on other sites
  • 0

Thanks for your input, Larry. I am definitely leaning toward that conclusion. Work arounds are the key here, as in so many complications we encounter in this work.

Share this post


Link to post
Share on other sites
  • 0

Well, I have learned something, namely that part of the problem appears to be the result of having activated the native reverb on the Synchron and Vienna players. So I turned it off and used Lexicon Pantheon on the synths instead. I'm working on a three movement piece, and the first movement had the native reverb on, the second had it off. The second movement sounded better, there was less latency. I have gone back to the method of not using any native reverb on my vsti, instead using Pantheon on the synths, then sending them to the EW Spaces Reverb bus. This also results in better sound overall. Still some minor latency but much better.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

A comment about the rewind and playback problem when you have advanced the timing on a track or some notes: it is possible to enable MIDI note chasing so that notes that started before your playback point are triggered. From the manual:

You can now start playback from the middle of a MIDI note and the note event will trigger and sustain for the remainder of its duration. You no longer need to start playback before the note start time in order to trigger the note.

To enable/disable MIDI Note chasing, go to Edit > Preferences > Project > MIDI and select MIDI Event Chase on Play and Include Note Events.

On 4/16/2019 at 8:17 PM, mdiemer said:

You may be correct Canopus, it doesn't make sense to me either. Not sure what was going on there. Anyway, I guess I am resigned to working with the time thing. It's a pain though, because, say you are working on measure 20. you do something and rewind to ms. 20. But there is no sound. You have to go ms. 19 and go from there, because you altered the starting time, and it now really starts in ms. 19. Another workflow blocker. Oh well...Cakewalk is still the best for me, I'll just have to put up with it. but you are right, it's the strings that are the biggest offenders. It's the bow thing. A case where making the sampled inst. so realistic, it screws up your workflow...

 

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, bvideo said:

A comment about the rewind and playback problem when you have advanced the timing on a track or some notes: it is possible to enable MIDI note chasing so that notes that started before your playback point are triggered. From the manual:

You can now start playback from the middle of a MIDI note and the note event will trigger and sustain for the remainder of its duration. You no longer need to start playback before the note start time in order to trigger the note.

To enable/disable MIDI Note chasing, go to Edit > Preferences > Project > MIDI and select MIDI Event Chase on Play and Include Note Events.

 

 

Wow, thanks bvideo, I'll have to check that out!

Share this post


Link to post
Share on other sites
  • 0

Thanks for posting the answer you found, mdiemer. It's a good reminder to me to always check to see if a sample player or synth patch or whatever is using its own reverb so that I can decide whether to (usually) turn it off or leave it on.

I almost always dial in reverb by using a single plug-in on a single send bus because I like the retro and gluing effect (and because I haven't learned how not to get my reverbs all piled up if I put them on individual tracks😉). Built-in reverbs are usually not as good as the ones I have available in my VST folders and they clutter things up.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...