Jump to content
  • 0
Dave G

No audio playback using WASAPI driver mode

Question

Posted (edited)

[Some users have helped me with this issue in a different Topic, but I thought it deserved its own thread here.]

While using WASAPI, there's no audio playback although the Track meters are moving. Previously, I've used MME and ASIO4ALL flawlessly.

I've tried the following:

  1.   Experimented in Sonar, CbB, and Studio One v4 (but no WASAPI option there)
  2.   Switched between WASAPI "Exclusive" and "Shared"
  3.   Confirmed the sample rate is 24-bit 48K in both Sound Settings and in Sonar/Cakewalk
  4.   Checked/unchecked "Suspend Audio Engine..." in [Audio --> Playback and Recording]
  5.   Disabled/re-enabled the Audio Engine button and exited/restarted the program
  6.   Confirmed each Instrument Track is output to Master Bus, and the Master Bus is output to RealTek

As you can see, I've tried everything short of reformatting my hard drive and starting all over. What else is there?

I've learned that WASAPI is the suggested Driver Mode for my onboard audio configuration. I'm still in the amateur stages of my music projects, so I don't want to rush into buying an audio interface (yet) just to use ASIO4ALL.

** Screenshots of my Windows Sound and CbB Preferences are attached.

Any help towards a resolution would be greatly appreciated! Thanks in advance.

 

1.PNG

2.PNG

3.PNG

4.PNG

5.PNG

Device.PNG

Edited by Dave G

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Have you tried de-selecting "Realtek Digital Output" and selecting "Speakers..." on the first page? Always first de-select, then select audio devices... 😉

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
21 minutes ago, michheld said:

Have you tried de-selecting "Realtek Digital Output" and selecting "Speakers..." on the first page? Always first de-select, then select audio devices... 😉

As you instructed, per the Output Drivers in my first screenshot, I unchecked RealTek and checked the first (and only the first) Speakers option. I'm getting playback now! And it sounds very clean. (Confirmed with Sonar and CbB, and in more than one project.)

I don't know how I wrestled with this the past few days. I'm using WASAPI for the first time! Feels like a fluke; so if this acts up again, I'll post back here.

Thanks for your tip! :)

d.PNG

Edited by Dave G
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Are you using the digital output? Probably not. Because that is the only box checked in audio device outputs it will be the default in your master buss and you won't hear anything from your speakers.    Cakewalk goes to the top of the list and will select that as the master buss output.  I show you all of this in this video if you haven't watched it yet do so. 

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
33 minutes ago, John Vere said:

Are you using the digital output? Probably not. Because that is the only box checked in audio device outputs it will be the default in your master buss and you won't hear anything from your speakers.    Cakewalk goes to the top of the list and will select that as the master buss output.  I show you all of this in this video if you haven't watched it yet do so.

I actually did change the Output Driver to the Speaker(s), and that naturally was the solution.

I did watch your video. It was very informative and easy to understand! Thank you for including that, as that helped very much.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

In this part of the forum, it is handy, when a question is answered, to select the best answer by clicking the check next to the reply

It let's everyone know there is a solution posted to the question.

I checked this one for you

thanks

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Just so you know, most people rush into buying an audio interface so they can stop using ASIO4All.

Most quality interfaces have their own ASIO drivers for best performance.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...