Jump to content
Sign in to follow this  
Astraios

Something like a "Ghost Track"

Recommended Posts

Posted (edited)

Hi and Hello  Mr. Cakewalk ☮️
Hmm, something strange occurs here on my system...  There is no MIDI note in the track/clip, but Cakewalk
generates a sound from a softsynth, but doesn't affect it. There is also no Audio to find containing this sound.
I've recorded this melodie with my live-keyboard and then deleted the MIDI notes. Any idea?
 

Here you can see what I mean: no MIDI notes in the second track (only one lane), no Audioclip. Nexus 2 synth is set to solo and it doesn't respond to the played sound as you can see in Multidock window.

I found this in the forum: 

Edited by Astraios

Share this post


Link to post
Share on other sites

Not sure exactly what the question is but I suspect the Track 2 input setting (not shown in the image) may provide a clue.

If the sound being produced is not expected chances are the input is set to Omni or one of the other synths in the project with "Enable MIDI Output" turned on.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you for your answer. So what I did is: I split the instrument track into MIDI and Track-Synth folder and this is what happend:

Split.PNG.cf985f58665e3d09dc0391ab28803587.PNG

which is the solution of my question... but how can this be? The Audio content wasn't shown in the Instrument track.

Edited by Astraios

Share this post


Link to post
Share on other sites

If you were trying to record audio directly from the synth, it cannot be done with an instrument track. An instrument track can only record MIDI data.

Soft synth audio recording requires, as you have discovered, separate audio and MIDI tracks.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
9 minutes ago, scook said:

If you were trying to record audio directly from the synth, it cannot be done with an instrument track. An instrument track can only record MIDI data.

Soft synth audio recording requires, as you have discovered, separate audio and MIDI tracks.

Okay, but it wasn't my intension to record audio directly and I don't understand why it happened anyway. I recorded with my MIDI-Ctrl keyboard, like I did this for thre last 20 years..? (I'm getting old, he?) or has it something to do with Nexus 3?

Edited by Astraios

Share this post


Link to post
Share on other sites

I based the comments about synth audio recording on the image.

This image shows the audio+MIDI track pair setup to record audio only. The record button is not enabled on the MIDI track.

Split.PNG

I am not a fan of Always Echo Current MIDI Track being enabled (as shown by the "A" in the input echo button) because of the effect input echo has on track input settings. The auto-echo setting along with hiding the track input drop down seems like an opportunity for problems.

  • Great Idea 1

Share this post


Link to post
Share on other sites
10 minutes ago, scook said:

I am not a fan of Always Echo Current MIDI Track being enabled (as shown by the "A" in the input echo button) because of the effect input echo has on track input settings. The auto-echo setting along with hiding the track input drop down seems like an opportunity for problems.

Thx anyway, for concern my question. However, it scares me a bit, knowing there might be audio takings beyond my visual control in behind... (depending on a 1 millimeter symbol)

Share this post


Link to post
Share on other sites

To answer your other question, yes, you are getting old. Nothing you or I can do about that, other than to never stop learning stuff.

The lesson from this is to not use instrument tracks. They were added as a feature not because they improve anything, but solely because other DAWs did it that way and users demanded it. 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I have located the cause of this problem...

It occurs, while using the shortcut for --> "Arm Tracks"

 

1) Recorded in Instrument Track (doesn't show the recorded audio in behind)

+1395873402_Track-Arm1.PNG.d4e88f9be5725da0ad0e16450839a9af.PNG

2) Same situation with split Intrument Track (now the recorded audio clip is available)

808307233_Track-Arm2.PNG.ccac3fc426be4409afed46120cf1484c.PNG

1337907216_ArmTracks.PNG.b130da861822bb10096f0d3a769f073b.PNG

Edited by Astraios
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Once again...

1) highlight an intrument track in track pane, which is routed to your MIDI-controller keyboard and a softsynth

2) use shortcut "Alt+R" to make the highlighted track ready for record

3) start record and play some notes on your keyboard

4) stop recording

now Cakewalk did record two things together A) your MIDI notes   B) a direkt audio record of of that stuff you played on your softsynth !! which will not be shown as existing !! unless you split the instrument track into two lanes --> MIDI/Audio

then you will find a hidden audioclip in the audiolane

 

Hm, I haven't found any warning about this issue in the manual....

 

 

Edited by Astraios

Share this post


Link to post
Share on other sites

Looks like a bug to me.  Arming a Simple Instrument track by the shortcut should only enable MIDI recording as you expected - same as clicking the record arming button.

  • Like 1
  • Great Idea 1

Share this post


Link to post
Share on other sites
On 6/1/2021 at 8:52 PM, David Baay said:

Looks like a bug to me.  Arming a Simple Instrument track by the shortcut should only enable MIDI recording as you expected - same as clicking the record arming button.

...but what if you accidentally delete (Ctrl+Delete) a track in "Instrument Track" mode and redo? - just try... 🙄

806002474_deletetrack.PNG.ed23d6508b608dbd107451798f9b2b87.PNG

Hm, I've always (the last 10 years) wonder Cakewalk doesn't respond to issues like that...

Share this post


Link to post
Share on other sites
5 hours ago, Astraios said:

...but what if you accidentally delete (Ctrl+Delete) a track in "Instrument Track" mode and redo? - just try... 🙄

Not sure what you're getting at here. First, off, I never use Ctrl+Delete, and it did not work for me; I had to use the context menu. Redo is not available until I first Undo, so I did both, and both seemed to work fine...?

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...