Jump to content
Larry Shelby

Bandlab Assistant Updated to 7.1.2

Recommended Posts

1 minute ago, Paul Young said:

Does anyone ever bother to update this.  It seems there are always issues.

I've always updated.  Only had issues one time for me...and manually re-installing solved that...
I'll always keep current

Share this post


Link to post
Share on other sites
34 minutes ago, Paul Young said:

Does anyone ever bother to update this.  It seems there are always issues.

Since the Cakewalk app itself no longer relies on BA for updates, I no longer see the point as well.

  • Like 2

Share this post


Link to post
Share on other sites
16 minutes ago, Brian Walton said:

Since the Cakewalk app itself no longer relies on BA for updates, I no longer see the point as well.

Don't forget offline authorisation! It is only supported by BA!

Share this post


Link to post
Share on other sites

For me, I don't necessarily run the Program every day...but I do run ALL of my installers
every day to check for updates, so the BLA keeps me informed of updates.  Also, they
now have the new Mastering service "tab" in the BLA, should you be so inclined....

Share this post


Link to post
Share on other sites
1 hour ago, marled said:

Don't forget offline authorisation! It is only supported by BA!

Is it?

Seems odd they don't have a website up, so you would have to actually install bandlab assistant on the "on-line" computer to get the offline one to work.  

image.png.f5f59d00a16f458aa0687151574c1476.png

Edited by Brian Walton

Share this post


Link to post
Share on other sites

When I update the Bandlab app, I always end up with 2 instances of the app in my Windows install/uninstall program list. One is the previous, the other the mere one. If I uninstall the earlier one, they both uninstall.

It's that normal?

Share this post


Link to post
Share on other sites

After updating BandLab Assistant to v7.1.2 from v7.1.1,
I get an error popup window it says "TypeError [ERR_UNESCAPED_CHARACTERS]: Request path contains unescaped characters" when clicking the gear icon. (I get this my both PCs)
Anyone else? Maybe on Japanese Windows only?

Share this post


Link to post
Share on other sites

BA doesn't work right on my system. I end up going to Apps & features in Windows, uninstalling Bandlab Assistant, and then to bandlab.com to download it and reinstall it.

Share this post


Link to post
Share on other sites

Yeah. Updating BA has been difficult since the beginning. At this point, all updates fail. I simply download the latest version on top (no uninstall) and all is well. I maintain the updates but I never use it anymore. I run CbB updates from within CbB.

 

Unless BA evolves to something more useful for me as was CCC back in Sonar days, it’s only a maintenance task for me.

Share this post


Link to post
Share on other sites
38 minutes ago, Keni said:

Unless BA evolves to something more useful for me as was CCC back in Sonar days, it’s only a maintenance task for me.

A clue to BA's main duties could be the name...BandLab Assistant.

This tool, written by a dev team in Singapore, was originally designed to support BandLab, the web-based DAW.

After BandLab acquired Cakewalk IP, BA was extended to handle CbB install,  activation and update.

With in-app updates and re-activation added to CbB,  reliance on BA is not as critical for CbB users as it once was.

BA does offer a loop library and  most recently a front-end for BandLab's mastering service.

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
6 minutes ago, scook said:

It may but a clue to its main duties could be in its name...BandLab Assistant.

This tool, written by a dev team in Singapore, was originally designed to support BandLab, the web-based DAW.

After BandLab acquired Cakewalk IP, BA was pressed into service to handle CbB install,  activation and update.

With in-app updates and re-activation added to CbB,  reliance on BA is not as critical for CbB users as it once was.

BA does offer a loop library and  most recently a front-end for BandLab's mastering service.

 

 

 

Thanks scook.

 

I totally understand and was glad to have any method of maintaining updates for CbB. I would be using it (gratefully) still with my continued appreciation, but even more appreciation for the continued development and evolution of this great work which has progressively been freeing CbB from this need.

 

I think the Bandlab project is a wonderful service and seeing it integrate and evolve with CbB is much appreciated.

 

If I could, I'm sure I would be making more use of it.

 

 

Share this post


Link to post
Share on other sites

Bandlab Assistant updates have been working for me for many versions. I'm always on the latest Windows 10.

Share this post


Link to post
Share on other sites

I find I have to completely uninstall BA everytime (I use the free Revo Uninstaller - highly recommended) and d/load and install the new version . Otherwise I always have 2 versions sitting there. And the whole app becomes unresponsive.

Share this post


Link to post
Share on other sites

I used to have to do the full uninstall/install, but it seems to have been fixed in the last couple of updates (for me anyway!).

Share this post


Link to post
Share on other sites
On 2021/5/6 at 午前4時57分, HIBI said:

After updating BandLab Assistant to v7.1.2 from v7.1.1,
I get an error popup window it says "TypeError [ERR_UNESCAPED_CHARACTERS]: Request path contains unescaped characters" when clicking the gear icon. (I get this my both PCs)
Anyone else? Maybe on Japanese Windows only?

Support says: We're investigating the issue.

And now... Seems the problem was resolved with v7.2.1

Edited by HIBI
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...