Jump to content
Martin Bannet

AUDIO LAG / AUDIO DRIFT - New problem on PC from out of nowhere

Recommended Posts

Posted (edited)

Hey all! Boy, it's been a while. Here's the scoop and a HUGE THANK YOU in advance.

I have done tests with Sonar/Soundforge/Vegas ... my soundcard's native drivers, ASIO drivers, Realtec drivers (PC's own system), WDM drivers and here's what I have after 14-15 minutes of audio. The audio that's recorded via the PC (on any software) LAGS behind the audio that's from say, a Youtube video (downloaded as MP3) or my 2 camera sources (whose audio is ALWAYS in sync - Samsung phone and Sony FX1000). They call it AUDIO DRIFT and it's a mystery. Here's what I've done to assess/fix:

1. Optimized AND Defragged SSD (I know, you're not supposed to defrag, but once was worth a shot) that SONAR/SOUNDFORGE/Vegas runs on - my Operating System Drive: C-Drive.

2. Cleaned out ALL unnecessary Windows bloatware and settings (as per PC optimization guides that have been around for years)

3. Tried JUST USING AUDIO software recording with no video-audio to sync with - same problem, so video is not the issue. Strictly audio recording over time. 

4. Defragged 'landing' drives for the audio wav files (2 Terabyte HDD - fairly new)

5. Disabled Realtec/onboard sound in the BIOS 

6. Removed ANY additional USER ACCOUNTS

7. Analysed system for ANY odd changes/software upgrades that could have been behind issues - and checked: no viruses/malware etc.

NO JOY.  I have narrowed down the problem to one of 3 things: 

1. PC hardware (ram/cpu/mobo) is dying (system is 6-years old this coming December)
2. SSD (though reported as health with CrystalDisk) is dying
3. Windows Updates have altered something re Audio Syncing abilities. 

Any others I might have missed? 

So is there a fix for this that I can do RIGHT IN SONAR (I have Platinum Edition) that will 'shorten' the recording length by a specific amount of bytes to match other audio sources of the same material (from camcorders/phone videos, etc.)?

Seriously if ANYBODY who figures out (not necessarily solves) my issues will get a free copy of any/all recordings I've done (whoopee, huh?) and a link to a handy-dandy EQ-Cut/Boost/Dip Guidance Chart I designed that has had over 500,000 downloads from my Box.com site. 

THANK YOU SO MUCH FOR ANY GUIDANCE RE THE ABOVE. MUCH MUCH APPRECIATED! Looking forward to direction from someone. 

Martin Douglas 

www.youtube.com/flagrantregard

 

Edited by Martin Bannet

Share this post


Link to post
Share on other sites

1) It's well past time to upgrade to CbB. Probably won't fix this, but it won't hurt either and there are tons of bug fixes & refined features in the meantime.

2) If you have sample rate mismatches, you will get drift.

3) All your different audio sources have different clocks and this is not helping either.

Share this post


Link to post
Share on other sites

Sonar is very outdated compared to Bamdlab cakewalk. Update this first. If crystal disk says you have a problem. You should replace the drive. It is spot on for drive reliability.  This could but probably would not cause differences. Like bdickens said sample rate could cause this. What sound card are you using now that you have disabled the Realtek? What are you settings in the audio preferences page ? 
 

Share this post


Link to post
Share on other sites

Thanks guys.

Have tried using the onboard sound device (Realtek) and my AP-2496 soundcard.

As I said, no matter WHAT audio program I use, there is the drift (Audacity/Sonar/Soundforge 14) and it's the same regardless of drivers, sample rates, buffer sizes etc. Tried to switch to Bandlab but my plugins weren't showing up right and it was just a buggy conversion. (Would like to keep my system as is, if you know what I mean.) I know that I can 'tweak' the separate audio tracks recorded while taking video can be stretched without any discernible difference, but that's still not the ideal solution. This wasn't happening 3 months ago. Just a new thing out of the blue. Drives are all checking out fine. 

When recording audio in Sonar, is there some setting/buffering management anyone can suggest that could curb the audio drift?

So, no other wild guess out there? 

Share this post


Link to post
Share on other sites
Posted (edited)

In my signature is a link to my tutorials Watch the one on ASIO as it gives you info about sync and what to look for. 
that sound card  is from like 2004 so that’s my guess as to what is wrong. Probably outdated drivers not compatible with W10  latest version. 

Edited by John Vere

Share this post


Link to post
Share on other sites

Most likely this is a clock issue.

Any time you are synchronizing two or more different machines there must be a common clock or they will drift apart.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...