Jump to content
  • 0
jkoseattle

Selection weirdness

Question

I'm wondering if this is unique to my situation somehow or is a bug, or what.

Screencast of the problem, (with narration)

https://360.articulate.com/review/content/9da08074-44b5-42d0-abe9-1e3ece158e73/review

I have two tracks in PRV. I want to move a selection of notes from one track to the other. 

I select the notes I want to move out of one track. These are somewhere in the middle of the piece, let's say bars 14-17 of a 100 bar piece. I then go to the destination track and paste. I see that the selection bar with the green triangles starts and ends at the correct place, starting at the beginning of the first selected note and ending at the end of the last. I also ensure that the Now time is at the beginning of the selection, so that when I paste, the notes will stay in the same place in the timeline.

I then go to the destination track and paste. But all of a sudden, what was once a 4-bar selection area turns into an arbitrarily long one, maybe 19 bars, and the paste wipes out everything in those 19 bars. I don't want ANYTHING in the destination track to be deleted, much less a whole bunch more afterward, I just want to add the selected notes to the track.

I double-checked that "Blend Old and New" is checked in preferences, so nothing should be getting deleted at all, and for all these years, it wasn't.

(Possibly related: when I use the Tab key to jump between markers, I am getting jumps BETWEEN markers sometimes. Is there something corrupted in the project?)

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I have no idea why that is happening, I have never tried to copy and paste from one track to another in PRV. If you need a way to do it meanwhile, if you are in track view, you can separate into a clip the parts in the track you want to copy from, the copy and paste that clip into the track you want to add it to. This is how I have done it. 

Share this post


Link to post
Share on other sites
  • 0

Thanks. I forgot to mention that I don't want to do that because it breaks my flow, as I write in PRV almost exclusively. Plus, I'm doing a hundred other edits, often creating a hundred tiny little clips which every once in a while I have to merge together.

Share this post


Link to post
Share on other sites
  • 0

Yeah that would get tedious. Since you are used to working in PRV has this happened before? 

Share this post


Link to post
Share on other sites
  • 0

More data:

Cut/Paste is the example above (simple drag). Copy/paste (ctrl-drag) does not exhibit this problem.

Recorded a brand new third track. Tried cutting and pasting from the new track. Same problem. So apparently not corrupted clips

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...