Jump to content
Jim Hurley

Sound Forge Pro 15.0 is now out

Recommended Posts

By the way, I checked this behavior in Sound Forge 14 and 15 in multiple machines and in Sound Forge 12 on my laptop. They all do the same thing.

Kevin's Kludge outlined above works well enough for me. My posting on Magix probably will go nowhere.

Share this post


Link to post
Share on other sites
Posted (edited)

Ah - I have show logo  splash-screen disabled.  If I enable it, I see what you see.

Do you also see result.html and result.xml created in a folder* every run (both essentially empty files)?

* I say "a folder" as I'm not sure what the logic is.  I have a T drive on my machine which has a bunch of backup files, installers and the like, but also a Temp folder (T:\Temp) which happens to be the target for my %TEMP% and %TMP% environment variables.  The result.* files are created in the root of the T drive - I'd understand if they were in the T:\Temp folder, but not in the root!

Edited by Kevin Perry

Share this post


Link to post
Share on other sites
On 3/22/2021 at 3:50 PM, Kevin Perry said:

Ah - I have show logo  splash-screen disabled.  If I enable it, I see what you see.

Do you also see result.html and result.xml created in a folder* every run (both essentially empty files)?

* I say "a folder" as I'm not sure what the logic is.  I have a T drive on my machine which has a bunch of backup files, installers and the like, but also a Temp folder (T:\Temp) which happens to be the target for my %TEMP% and %TMP% environment variables.  The result.* files are created in the root of the T drive - I'd understand if they were in the T:\Temp folder, but not in the root!

Yes, these have appeared here and there in root folders at various times. I've seen them in other folders, too. It is related to the VST scan, I think. I think they have always been empty, but my memory is faulty these days...

I have my TEMP system environment folder set to C:\Temp and the temporary file folder in Sound Forge prefs set to D:\Temp and I've seen them in C and D root drive as well as C:\Program Files\Sound Forge.

These past few days I've spent many hours rummaging through Procmon logs of Sound Forge startup and tutorial processing so I am getting accustomed to it more.

I attempted to figure out when this started - I know it happened in SF 12, 14 and 15. I have the SF 11 installer as well as many earlier ones, maybe back to the Sonic Foundry days (I never through anything out, drives are cheaper than my time), which is the last version when SF was owned by Sony. I tried to install that, but it required an installation of early DOTNET installations to proceed, so I quit at that point.

Very Off Topic. It is interesting to follow the history of these types of tools. I bought Cool Edit 95 and Sonic Foundry Sound Forge when they were introduced. I liked Cool Edit more and purchased a 'LifeTime license' from Syntrillium. A short time later, maybe in CooEdit 2000 or so, Syntrillium sold Cool Edit to Adobe and it became Audition. I guess that was the end of life, because my license no longer worked.

Sonic Foundry was sold to Sony and now Magix. 

Spectral Layers was owned by Magix, but now Steinberg.

Confusing. And if you want to get support you have to upgrade and switch to the new owner.

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
On 3/21/2021 at 7:24 PM, Matthew Sorrels said:

They may not have added this to Sound Forge 11.0 (from you screenshot).  If you take the Sound Forge binary and strings it (a utility that will extract strings from it) you can find the grovel commands.  Try it and see if they are in your binary

Good Strings Utility for Windows
https://docs.microsoft.com/en-us/sysinternals/downloads/strings

If you search through the results you should see something like:

image.thumb.png.cd804e7a4adc93d40f00632e3580fbed.png

I have been thinking about this a bit, and the better tool is Sysinternals Process Explorer.

It will show strings in the image of a file as well as in memory and allow search for strings.

For example, here is the memory image string search for 'tutor'  showing an intriguing entry:

 

 

procexp64.png

Share this post


Link to post
Share on other sites
Posted (edited)

I currently have both Sound Forge 14 and 15 installed.

Both menu entries are identical except the executable.

If I use Sound forge 14, it opens as expected; I edit the file and close the file.

If I want to edit another audio file, it loads it into the existing open Sound Forge 14 program.

The first time I use Sound Forge 15, it opens as expected; I edit the file and close the file.

If I want to edit another audio file in 15, it opens a new instance of the program making it basically unusable as an editor.

(I have to shut down the previous instance)

I can find no setting in Sound Forge 15 preferences to stop this.

Any ideas?

 

Edited by jim137

Share this post


Link to post
Share on other sites

The same thing will happen if you open a sample from Windows File Explorer, each sample gets its own editor.

That's how Cakewalk keeps track of which sample you are working on -- it is by window.

In that SF window you can open another sample from the audio data folder of your project, and it will open in the SF Workspace.

 

 

 

Share this post


Link to post
Share on other sites

Reread my post.

It is different for Sound Forge 14, I close each sample before opening another and it uses the same instance of Sound Forge 14.

(This has been true of SF11, SF12, SF13 also)

In Sound Forge 15: I open a sample, close it, keep Sound Forge 15 open. Open a different sample it starts a new instance of Sound Forge 15 and I 

have two Sound Forge 15 open.

Thanks for your response, but I still have the problem.

I was hoping for a flag that would stop opening the second instance and use the instance that is open.

 

I reread your response and did a test; not involving Cakewalk.

Sound Forge 14 does not open a second instance of Sound Forge 14 for each wave file loaded from Windows explorer.

Sound Forge 15 does open  new instance of Sound Forge 15 for each wav file loaded in Windows Explorer.

I want to achieve the old behavior and you seemed knowledgeable. 

Share this post


Link to post
Share on other sites

The behavior I see is different. Both Sound Forge 14 and 15 behave the same in Windows file opening and in loading via  Cakewalk tools menu.

In both cases, new windows open when SF is invoked externally. It is only by loading a file inside SF14 or 15 via the open file menu that I can load the file into the current SF workspace. I can also load an external file into an SF workspace if I drag a file in Windows Explorer to the Sound Forge menu bar (but not dragging into the  workspace which invokes Mix/Replace).

I have Sound Forge Pro 14 64-bit build 130 and Sound Forge Pro 15 64-bit build 27. 

I don't know how to achieve the behavior you wish. I would like it to work like that also.

Both have similar registry open shell command entries with a cryptic string passed.

SF15-open-reg.png.9aa1a767e848a695bb8a09694d11dc8a.pngSF14-open-reg.png.cb9fd631290f28591938f3e1ac487be5.png

Share this post


Link to post
Share on other sites

Okay, I found the answer in the Sound Forge Forum.

Sound Forge opening multiple instances

Essentially this is the answer:

<Thank-you for pointing out the abnormality.

I can confirm this behavior in both 32 and 64 bit Sound Forge Pro 14 (build 111). I am not aware of any setting but will look.

Addendum:

This a result of the new "Multi-instancing default", and stated in the release notes. The option to change it back to the legacy builds, was not mentioned though. It is also in the normally hidden "Internal" menu.
- go to the 'Options' menu
- hold 'Shift' key and select 'Preferences'
- select the 'Internal' tab
- find "Force Single Instance behavior" (bottom of list or use search)
- change value from 'FALSE' to "TRUE"
- click 'Apply' and 'OK'
- Exit or restart SF>

There are many other secret values here, that may be of interest to some of the previous discussions above.

 

  • Like 1

Share this post


Link to post
Share on other sites

Very interesting and something I had not known.

I had seen these strings in the various viewer tools we talked about above and knew they could be altered somehow, but I never read about the hidden Internal preferences.

I changed a few things for both SF 14 and 15 (It took some sets and resets and restarts to make everything consistent) and now I can get the behavior you saw in SF 14 and also SF 15. It seems that you must press Apply before OK to make them take. And system restarts seem to help.

There are many ways to invoke SF and there are some differences that I have to resolve. You can invoke from a file type or shell command, etc.

Thanks!!

Share this post


Link to post
Share on other sites

The embarrassing thing is that I must have already found this solution when 14 was installed and forgot about it.

One of those Computer things: You find a solution to a problem you need once in a blue moon and then forget about it.

Share this post


Link to post
Share on other sites
Posted (edited)

 

4 hours ago, jim137 said:

Okay, I found the answer in the Sound Forge Forum.

Sound Forge opening multiple instances

Essentially this is the answer:

<Thank-you for pointing out the abnormality.

I can confirm this behavior in both 32 and 64 bit Sound Forge Pro 14 (build 111). I am not aware of any setting but will look.

Addendum:

This a result of the new "Multi-instancing default", and stated in the release notes.

 

 

I tend to read the manuals and release notes. I didn't find any release notes in the download, nor mention of this in the What's new sections (For SF 15 or 14)

 

 

Edited by Jim Hurley

Share this post


Link to post
Share on other sites

I have not heard  back from the developers on this topic.

I also find that marking regions seems to cause instant crashes very often.

So I no longer use version 15. I will update it as new ones come out, but I find SF14 to be a superior product.

 

 

  • Haha 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...