Jump to content
Sign in to follow this  
jono grant

Help! Audio snap issue

Recommended Posts

Posted (edited)

Hey there, I have a problem I need to solve.

I'm using audio snap on a full song mix, I set it to (set project tempo from clip) after that, I set it to (clip follows project) and at that point is make make a simple tempo map and the audio follows it really nicely. (using the Radius mix algorithm) All good!

My problem is: Now I need to deliver the track but I need to do a split mix vocal and music separate.

When I try to do this, the vocal track doesn't follow correctly, it's all crazy. I assume because it can only do (set project tempo from clip) properly from the music track and that the vocal is different in that regard.

Is there a way for the vocal track to follow the tempo map the same way as the music is? 

Difficult to explain this, but if anyone has a clue I'd be very grateful!

Thanks

Jono

@msmcleod

 

 

Edited by jono grant

Share this post


Link to post
Share on other sites

PS. I see that groove clip looping can do this but the quality is terrible in comparison. Is there a way to get better quality out of groove clips, similar to the quality of the audio snap algorithms?

Thanks

J

Share this post


Link to post
Share on other sites

The problem is that the transient detection on the vocal track is not accurate. Thus there are 2 ways you can fix this:

  1. Correct the transients in the vocal track manually.
  2. If you are satisfied with the transients of the whole mix, then you can also extract the groove (in AudioSnap!) of the mix to the vocal track and then let it follow the project. I only don't remember if it is necessary to disable all the transients in the vocal track first.
  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, marled said:

The problem is that the transient detection on the vocal track is not accurate. Thus there are 2 ways you can fix this:

  1. Correct the transients in the vocal track manually.
  2. If you are satisfied with the transients of the whole mix, then you can also extract the groove (in AudioSnap!) of the mix to the vocal track and then let it follow the project. I only don't remember if it is necessary to disable all the transients in the vocal track first.

Thanks! I think I need to figure out how to do #2 method... I'll give it a shot.

 

Share this post


Link to post
Share on other sites

I think the way to do this is to use "Merge & Lock markers"

So:

1. Change the filter on both tracks to transients
2. Select both tracks
3. On the music track, right click Select->All Markers
4. On the music track, right click "Merge & Lock markers"

This should apply the transient markers of your music track to your vocal track:

merge_and_lock.gif
 

  • Like 1

Share this post


Link to post
Share on other sites

So you have the music and vocals separate.   
I make sure they are single clip tracks that start at zero to avoid confusing audio snap.

Don’t use Set Project from clip.  Map your tempo (matching Cakewalks grid and tempo map to your songs tempo either by hand (my preferred) or using melodyne via dragging the clip to the timeline (not as accurate in my experience) .  Don’t use any Audio snap while Mapping your tempo.

Once Cakewalks tempo and grid match your audio, highlight the music track and the vocal track and open audio snap view.

Turn On Audio Snap. 
Click Clip follows project  (it turns blue) make sure it has the Auto stretch option selected.

Set Offline stretch method to Radius Mix.

Now adjust the tempo map to your New likings!

Finally, right click each clip and Bounce to Clip. 
 

They will stay perfectly together!

✌️

 

Share this post


Link to post
Share on other sites
3 hours ago, msmcleod said:

I think the way to do this is to use "Merge & Lock markers"

So:

1. Change the filter on both tracks to transients
2. Select both tracks
3. On the music track, right click Select->All Markers
4. On the music track, right click "Merge & Lock markers"

This should apply the transient markers of your music track to your vocal track:

merge_and_lock.gif
 

This is it! But before you begin, first disable the transients in the vocal track to avoid that they are included in the merge:

  1. On the music track, right click (in an empty space) "Select Markers > All".
  2. Right click on one of the transient markers and select "Disable".

 

Share this post


Link to post
Share on other sites

By the way I do this sort of thing all the time.


If the two tracks are in sync to start with, there’s no need to copy and lock the audio transients.

With Clip Follows Project (auto stretch) turned on for both tracks prior to tempo changes, they will auto stretch together perfectly regardless of where the audio transients of each track are located.

In fact, without Clip Follows Project turned on, any tempo changes made in the map will NOT change the tempo of the Clips with the locked transients.
 

Copying and locking transients is better suited for adjusting the timing of tracks needing to be fixed, for instance with multitrack drums that are not quite in the pocket of the grid.
 

With a track and a vocal that are already in sync with each other and just need the tempo(s) to be adjusted simultaneously, Clip Follows Project (auto stretch) is the way to go! 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...