Jump to content
tdehan

Recorded vocals are ahead of the instrument tracks

Recommended Posts

This is really weird and the first time I've experienced this.  I am trying to lay down the vocal track to a new song.  I've already recorded the instruments.  But when I record the vocal track and play it back it comes in ahead of the instrument tracks.  In order to fix it I have to NUDGE the vocal track to the right by 5.

As mentioned, this has never happened before with vocals I've laid down.  Any ideas?

Share this post


Link to post
Share on other sites

Two thoughts/questions to help diagnose:

1.  Are your instruments recorded as wave files or they "recorded" as MIDI and being played with soft or external synths?   

2.  Did you change/update audio drivers recently?

Share this post


Link to post
Share on other sites

The instruments are a combination of MIDI and real instruments.  So it's a combo of MIDI and wave files.  The MIDI instruments are all TTS-1.  There's no issue with the instrument tracks being out of sync.

I have not changed or updated audio drivers.

Edited by tdehan

Share this post


Link to post
Share on other sites

Could you post a screenshot of your Audio -> Device Settings and Audio -> Sync and Caching settings in Preferences? (If you don't see the latter, click on the "Advanced" radio button at the bottom.) Also let us know what driver you're using (e.g. ASIO, WASAPI).

 

 

Share this post


Link to post
Share on other sites

You really need to watch the video I’m making. Just finished editing the audio. Take the rest of the weekend to edit the video part. It is Tutorial on latency. My guess is that your not using ASIO 

and if you are I think Bitflipper is thinking what I’m thinking about your Latency adjustment 

Edited by John Vere

Share this post


Link to post
Share on other sites

Try these experiments...does the sync issue persist

- if you increase the buffer size?

- under WASAPI instead of ASIO?

Yes, you can increase the buffer size and therefore overall latency and still record live vocals that will line up properly.

 

Share this post


Link to post
Share on other sites

I am not clear exactly what you are suggesting I try.  Could you kindly be more specific?  Thanks

Share this post


Link to post
Share on other sites

Sorry, I'm talking about the "Buffer Size" slider on the Audio -> Driver Settings page, and the "Driver Mode" selection on the Playback and Recording page.

 

Share this post


Link to post
Share on other sites

Ok, thanks for the clarification.

What buffer size should I try?

With regards to the Driver Mode, if I change it to anything other than ASIO my Presonus Audiobox USB96 interface does not get recognized and instead Cakewalk reverts to my internal sound card.

Share this post


Link to post
Share on other sites

Buffer size: anything bigger, e.g. 1024.

I am surprised that your interface isn't recognized unless you use ASIO. I thought WASAPI was compatible with anything. So never mind on that one.

The main thing is to make sure this problem isn't limited to just one project. We don't want to make a global correction that will affect other projects that don't exhibit this behavior.

Note that what I'm about to describe shouldn't be necessary when using ASIO drivers. At least, that's what I've always heard. But there may be a problem with your specific driver wherein it's not reporting latency correctly. If that's the case, then the cure is to enter a correction into the Manual Offset field under "Record Latency Adjustment" at the bottom of the Sync and Caching page of Preferences. Don't worry, you can always un-do this if it doesn't work out.

Before you can do this, you'll have to figure out just how far off your vocals are,  in samples.  Do this with all fx plugins bypassed.

In the upper-left corner of the track view there's a box that shows the current time position. Right-click on it and select "Samples". Now your time is going to be displayed in samples. Zoom in on the beginning of an audio clip and jot down the number shown. Now do your nudge trick to get the audio lined up properly, zoom in on that same place and note the new value in the time position display. You now know how many samples you had to nudge the track by, so we can tell Cakewalk to do that nudging for you. The difference between those two numbers is the amount of manual adjustment that will be needed. Enter that into the Manual Offset box and un-check the "use reported ASIO latency" box.

The above method is not terribly precise. You'll need a loopback test to get it smack on. However, a) we just want to see if it fixes your problem, and b) it really doesn't have to be absolutely smack on - you won't notice if it's off by a few samples. Or even a few hundred, actually.

 

Share this post


Link to post
Share on other sites
1 hour ago, bitflipper said:

I am surprised that your interface isn't recognized unless you use ASIO. I thought WASAPI was compatible with anything. So never mind on that one.

yeah, like HP PC of yore, a number of interfaces need their own ASIO drivers to function. Windows will recognize them in the Device Manager as Audio Interface, etc but only the IO device drivers will work. usually they make a WASAPI driver for general Windows usage, and an ASIO "equiv" for "power users"... not sure how much ASIO is there when they do this. to wit: newer UMC series by Behringer, M-Audio, Focusrite, Avid, etc. many seem to adopt the old "we don't need to use no stinkin' class compliant device drivers" that HP used to do to us, because, ya know? then again, if it's well made device with great features, ok then...

Share this post


Link to post
Share on other sites

The strange thing here in my mind is that, this tune I am working on is the only one that exhibits this behavior!  None of my other projects that I've laid down vocals has this issue.  And the other really strange thing to me is that it is ONLY the vocal track that is doing this.  I started this tune with a MIDI drum track, MIDI strings and MIDI guitar.  I then added audio tracks for bass, strummed guitar, picked guitar and harmonica.  No problem until I added a vocal track.  This is what is so puzzling to me as it is only happening on this project and none of the others...

Share this post


Link to post
Share on other sites

Are you Looping a section to add vocals to?

Are you Punching In a section to add vocals?

Are you doing both?

Are you allowing "Arm" changes on this project?

tom

Share this post


Link to post
Share on other sites

I am not looping a section or punching in.  I have no idea what ARM changes are.

Share this post


Link to post
Share on other sites
7 hours ago, tdehan said:

have no idea what ARM changes are

When selected, you can "ARM" (set to record) a track when CbB is running.
Has caused some issues for me if I had a section looped and a Punch In set.

t

Share this post


Link to post
Share on other sites

Looks good in your screen shot. That info is totally the same more or less as all 3 of my interfaces. 
 

From what you just said I’m thinking you are recording with

your effects turned on. This can cause the sync issues for sure. Especially look ahead effects. I always bypass my effects when tracking audio and midi 

Edited by John Vere

Share this post


Link to post
Share on other sites
8 hours ago, tdehan said:

The strange thing here in my mind is that, this tune I am working on is the only one that exhibits this behavior!  None of my other projects that I've laid down vocals has this issue.  And the other really strange thing to me is that it is ONLY the vocal track that is doing this.  I started this tune with a MIDI drum track, MIDI strings and MIDI guitar.  I then added audio tracks for bass, strummed guitar, picked guitar and harmonica.  No problem until I added a vocal track.  This is what is so puzzling to me as it is only happening on this project and none of the others...

In that case, ignore everything I've suggested thus far. This is not an issue with your audio interface. 

Question: did you use the same gear to record the guitar and harmonica? Meaning the same mic, same preamp, same signal chain? 

Share this post


Link to post
Share on other sites

 

I was going to say I had the same problem but checking my settings I was wrong and had the wrong ASIO driver set in playback.

Edited by Luke Brickley
Edited for PEBCAC

Share this post


Link to post
Share on other sites
15 hours ago, bitflipper said:

In that case, ignore everything I've suggested thus far. This is not an issue with your audio interface. 

Question: did you use the same gear to record the guitar and harmonica? Meaning the same mic, same preamp, same signal chain? 

Everything is the same except I am using a different mic for the vocal track.  Perhaps I should try my other mic that I typically use for vocals.  However, I have used this particular mic to record my wife's vocals with no issue before.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...