Jump to content
fhinojosa

V-Studio 100 works in Cakewalk 8.5, but not bandlab

Recommended Posts

I'm having an issue with my V-Studio 100 audio interface. I still have an old version of Sonar 8.5 Producer installed along with the latest version of Cakewalk by Bandlab. My V-Studio 100 works as an audio interface with both applications, but as a native control surface only on the 8.5 version. In the Bandlab version I can  install a (VS-100-1) controller/surface, with an in and out of CONTROL (VS-100), but neither the WAI nor ACT checkboxes are available. And although I can see, via the Preferences menu, that the control surface is set,  no controller is visible via the ACT menu, and the surface doesn't appear to work.

In the Bandlab version I am able to use the ACT MIDI and Cakewalk Generic Surface settings, but unfortunately these settings do not provide the complete functionality that I am able to obtain in the 8.5 version.

Any help would be very much appreciated.

Share this post


Link to post
Share on other sites

I have a VS-100 I keep as a backup interface sitting in the closet.  Short of a quick connection test on my DAW system (Win 8.1) I haven't done much with it on CbB.  I can dig it out and install on my Win 10 machine to test, but I won't be able to report back until this evening. 

In the meanwhile, can you confirm that --

You're running on Win10, fully updated (or no later than one major update behind).

You've installed Roland driver 2.02 for Win 10.

You are running CbB with RUN AS ADMINISTRATOR.  (Always worth trying when having problems with an older, discontinued interface).

If interface is installed via USB3 port, try a USB2 port instead if possible.

Edited by JonD

Share this post


Link to post
Share on other sites

JonD,

Wow. Thank you so much. I also won't have access to the device until later today, but I am able to confirm:

WINDOWS:

Windows is up to date (Windows 10, Version 20H2).

DRIVER:

The driver installed automatically when I connected the device. When I unzipped the Roland file at "V-STUDIO 100 (VS-100) Driver Ver.2.0.2 for Windows 10" there is a readme that states:

"Driver for Windows 10

Your computer downloads the Windows® 10 driver for VS-100 automatically from the Internet when VS-100 is connected to the computer."

USB:

I'm not sure if the port is USB2 or USB3, but it seems notable that everything works with version 8.5 of Sonar and the Sonar VS.

ADMINISTRATOR:

I can try running the program as administrator when I get home tonight.

 

Thank you again for your help!

Frank

Share this post


Link to post
Share on other sites

Hi Frank,

Okay, here's what I did to make the VS-100 appear as ACT controller:

Open Preferences page.  On the left under MIDI, click on Control Services.

On the right page, click the icon for Add New Controller Surface (To the extreme right of Import ACT Data button).

In Controller/Surface Settings -- choose ACT MIDI Controller (If that's what you want), and Control VS-100 for your input and output.  Click OK to exit settings.

WAI and ACT boxes should now be checked next to your new controller device. 

That's as far as I've tested.  If this didn't answer your question, let me know what you need and I'll test further.

 

-Jon

 

Share this post


Link to post
Share on other sites

Jon,

Thank you again for your help. Under "Preferences" > "Controller/Surface" I can, as you have suggested, select either ACT MIDI or Cakewalk Generic Surface, and I can use the "Learn" feature to configure the device. But on both my 8.5 version and Sonar VS I can select "VS-100" instead of ACT MIDI or Cakewalk Generic, and by using this native VS-100 setting the device automatically utilizes all the features without any additional configuration. On CbB I am able to see a "VS-100" Controller/Surface, but when it is selected neither the ACT or WAI checkboxes are available, and the device isn't available via the ACT menu.

So the goal I am seeking is to have the VS100 operate the same in CbB as it does in Sonar 8.5 and Sonar VS.

I hope I'm making this clear?

Frank   

Share this post


Link to post
Share on other sites
20 minutes ago, fhinojosa said:

..... On CbB I am able to see a "VS-100" Controller/Surface, but when it is selected neither the ACT or WAI checkboxes are available, and the device isn't available via the ACT menu.

So the goal I am seeking is to have the VS100 operate the same in CbB as it does in Sonar 8.5 and Sonar VS...

I'm on Win 10 Pro.  Latest CbB version:  2021.01 (Build 085)

Once I create the controller device - by default called ACT MIDI Controller 1 - the ACT and WAI check boxes are both there and checked.  Clicking the Help button on this page brings up CW documentation and a screenshot that seems to confirm this is what you should be seeing. 

After the above step, go to the main page of CbB, then by clicking on Utilities (top toolbar), the ACT controller is available at the very bottom.  Clicking on that allows you to configure the device further.

So if you're not at least seeing the above, something probably isn't set up quite right.  Did you try Run as Admin? 

As far as what you're seeing in Sonar 8.5/VS, I don't know if any programming changes have been made to ACT up to CbB, so I can't help there.  Hopefully one of the CW staff can chime in.  Wouldn't hurt for you to submit a support ticket.

 

Jon

Share this post


Link to post
Share on other sites

Jon,

Consistent with your findings, I am able to configure both the ACT MIDI and Cakewalk Generic Surfaces to work with the device. And this does give some functionality. My hope is that I will be able to obtain the same level of functionality with CbB that I am able to obtain with both Sonar 8.5 and Sonar VS - which I think is likely only to be available by using the VS-100 setting instead of the ACT MIDI or Cakewalk Generic Surface - which is where I'm having trouble.

Per your suggestion, I will attempt to reach CbB for their input, and as you also suggested - if a CW staff can chime in - that would be great.

Thank you again so much for taking the time to help. It is very much appreciated.

Frank

  • Like 1

Share this post


Link to post
Share on other sites

I found a link on Cakewalk.com that says:

Control Surface Installers

Last updated on 3/18/2016

Since the latest SONAR installers do not install control surface plugins, we have created a separate installer for these. Follow the steps below if you are missing any control surface plugins.

https://www.cakewalk.com/Support/Knowledge-Base/2007013438/Control-Surface-Installers

When I run the file as Administrator an installer starts, a gui, allows me to select English, then I get an error saying, "Cannot locate the required version of the program on this system. Please install the correct version of the program to use this pack. (see graphic below). I realize that this installer may not be compatible with CbB, but I wondered if it might help someone make sense of my problem - as described below?

On 1/24/2021 at 5:15 PM, fhinojosa said:

'm having an issue with my V-Studio 100 audio interface. I still have an old version of Sonar 8.5 Producer installed along with the latest version of Cakewalk by Bandlab. My V-Studio 100 works as an audio interface with both applications, but as a native control surface only on the 8.5 version. In the Bandlab version I can  install a (VS-100-1) controller/surface, with an in and out of CONTROL (VS-100), but neither the WAI nor ACT checkboxes are available. And although I can see, via the Preferences menu, that the control surface is set,  no controller is visible via the ACT menu, and the surface doesn't appear to work.

In the Bandlab version I am able to use the ACT MIDI and Cakewalk Generic Surface settings, but unfortunately these settings do not provide the complete functionality that I am able to obtain in the 8.5 version.

Any help would be very much appreciated.

ay 

  560259975_CaptureControlSurfaceInstallerError.PNG.b5f4fbf72fbc1dc0710046921c0551c0.PNG

 

Share this post


Link to post
Share on other sites
5 hours ago, fhinojosa said:

  560259975_CaptureControlSurfaceInstallerError.PNG.b5f4fbf72fbc1dc0710046921c0551c0.PNG

 

Confirmed.  Does it here too.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...