Jump to content
  • 0
Mehrdad

Keystrokes on my midi keyboard no longer showing up on the piano in the piano roll view

Question

The most pathetic thing happened today and I seriously can't figure out why? Keystrokes on my midi keyboard are no longer showing up on the piano in the piano roll view. How the hell can I fix this ?

Here's a picture to display where I am talking about.

Before this happened, when I pressed a key on my midi keyboard the corresponding key on the piano in the piano roll view would get pressed, but now it doesn't!

4356345634.PNG

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 1

This is to be expected.

When setting any MIDI device up as a Control Surface, that control surface takes full control over the MIDI device. When adding the ACT Control Surface, the MIDI input & output devices assigned to the control surface will be used exclusively by the ACT Control Surface and cannot be used for standard input.

This is true for ALL Control Surface device types.

Most keyboard controllers with DAW functions present themselves as more than one MIDI device, where one MIDI Input device is used for standard keyboard functions, and the other(s) are used for DAW functions. So its important to ensure only the DAW function MIDI ports are assigned to the ACT Control Surface.

If your MIDI keyboard only has one MIDI output, you can't use it as a standard keyboard and an ACT device at the same time. You can however, assign controls using the "Remote Control" feature of controls such as faders & pan controls. 

An example of Remote Control (without using the ACT Control Surface) - once set up, this can be saved as a project template for later use:

remoteControlWithoutACT.gif


You can also use MIDI messages within Preferences->Customization->Keyboard Shortcuts to assign MIDI keys or controller messages to anything that can be bound to a key (e.g. transport controls). Again, this is without the need for the ACT Control Surface.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Yes, same for me as well. This problem has been mentioned before, but I’ve never seen any response or comment from support.

https://discuss.cakewalk.com/index.php?/topic/18788-prv-animation-on-midi-input

https://discuss.cakewalk.com/index.php?/topic/18923-issue-with-piano-roll

As I wrote in one of those threads, when I run SONAR Platinum 2017.10 (i.e. last SONAR) it still works with live input, but not so in CbB. Something seems to have been changed in the code that renders the PRV keyboard, but not for the better. Here’s an animated GIF showing the problem in CbB side by side with SONAR:

qF4hTeF.gif

Edited by Canopus

Share this post


Link to post
Share on other sites
  • 0
22 minutes ago, RobertWS said:

It looks like you are using an early access version (EA?)

There is a separate forum for that.

This is not something that started to occur in 2021.01 EA. It has been like this for quite some time in CbB production releases, although I don't know exactly when it started.  I know for sure that it was present in 2020.08 but I think it was a problem long before that. However, I also realise that not everyone is affected by this issue.

Share this post


Link to post
Share on other sites
  • 0

All fine here 2021.1 Build 75.  Pressing keys on my MIDI controller show the key in my PRV   

(Yes I know 2021.1 build 85 is available, but I am having an issue with articulation maps that makes build 85 a show stopper for me)

Share this post


Link to post
Share on other sites
  • 0

I figured out what's causing this issue for me but the reason is quite a bummer. It was due to enabling Cakewalk's MIDI ACT feature for me. Whenever I enable the MIDI ACT Function and set my MIDI keyboard as the ACT device the next time that I open up any project in Cakewalk this happens. Those of you who are still having this issue if you happen to use ACT disable it and remove your MIDI keyboard from the list of ACT devices in the "Control Surface" settings of cakewalk and see if it fixes this issue.  (Be aware doing this though! I am guessing this should remove all your MIDI binding in ACT! I don't know for sure.) If this is the source of the issue this literally means that I have to give up the ACT feature for my keystrokes to show up!!

(By the way, I am on the 2020.11 Version, Build 099)

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Mehrdad said:

I figured out what's causing this issue for me but the reason is quite a bummer. It was due to enabling Cakewalk's MIDI ACT feature for me. Whenever I enable the MIDI ACT Function and set my MIDI keyboard as the ACT device the next time that I open up any project in Cakewalk this happens

Quite so! Great troubleshooting, @Mehrdad! In CbB I had created an ACT Controller/Surface for my MIDI keyboard and when I now removed it, the visual keys on the PRV keyboard started to work. And in SONAR Platinum by contrast I did not have any ACT Controller/Surface defined, which is why the visual keyboard worked there without any issue. Now that the cause seems to be determined there’s at least some hope to have it fixed. As long as the root cause wasn’t found I didn’t see any point in reporting it as not everyone was experience this issue. Maybe we should send a trouble report each to support in order to get some attention?

Share this post


Link to post
Share on other sites
  • 0

From your description it seems to me that the ACT apparatus prevented the note data from going to the PRV keyboard animation apparatus.    If we had a midi data flow chart we might know (1) if there is something else causing the behavior (and if so, what), (2) if the behavior is by design, or  (3) if it is a bug (along with other odd behaviors which no one seems to know if they are intentional or bugs). 

Edited by User 905133
to reduce the footprint of the post

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, User 905133 said:

If we had a midi data flow chart we might know (1) if there is something else causing the behavior (and if so, what), (2) if the behavior is by design, or  (3) if it is a bug (along with other odd behaviors which no one seems to know if they are intentional or bugs). 

In order not to derail this thread any further, I will just say that the posts above indicate that the ACT layer somehow blocks the MIDI note data being sent from the controller to the code that renders the PRV keyboard. I don’t think it’s is any more complicated than that. And I sure hope it’s not by design. :)

 The important thing is that there now seems to be a reliable way to reproduce the issue. 

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, msmcleod said:

When setting any MIDI device up as a Control Surface, that control surface takes full control over the MIDI device. When adding the ACT Control Surface, the MIDI input & output devices assigned to the control surface will be used exclusively by the ACT Control Surface and cannot be used for standard input.

Thanks for the info! Luckily for me my MIDI keyboard has both a classic DIN MIDI output as well as a USB MIDI output. I’ve previously only had the DIN output connected to my interface and that was of course also the In Port chosen for ACT. But by specifying DIN as input for ACT and USB as input in Track View, I seem to get the best of both worlds: being able to use knobs and sliders of my MIDI keyboard as a control surface while not losing the animated keys in PRV.

Now I only have to get myself a longer USB cable.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

For these occasions - and probably others - it would be great if it was possible to:

  • Temporarily disable control surfaces in the Preferences instead of just deleting/re-creating
  • Enable/disable control surface usage via the Control Bar module

👌

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...