Jump to content
Starship Krupa

Routing TAL Vocoder II in Cakewalk

Recommended Posts

I finally fully grasped how routing works in TAL Vocoder-II, so posting it here as a public service.

The basic concept of a vocoder is that you're using one audio signal to modulate another. It's a form of sidechaining, you have one audio source and you're using another one to affect it. The audio signal being affected is the "carrier" and the one affecting it is the "modulator." Many vocoders, including hardware ones, include simple internal synths to use as a carrier. TV-II has one, but may be used in a way where you may disable the internal synth and feed it both audio signals.

My initial confusion with TV-II was that in order to use it with its internal synth, you set it up backward from the usual sidechain arrangement. The plug-in is installed on the modulator track, not the track actually being modulated. That was the biggest thing to get my head around.

There are two ways to use it.

1. You want to use its internal synth (as the "carrier") with other audio controlling it (as the "modulator," traditionally a vocal). This is fine for the bread-and-butter Tupac/Daft Punk effect where you want a "robot voice."

2. You want to feed it carrier from your own synth track, and another audio track as modulator. This was my ultimate goal with a vocoder, because I want to use breathier pads for the synth input than the TAL Vocoder's simple internal synth is capable of. More Kraftwerk "Autobahn" than Tupac "California."

We'll begin with case 1.

  1. Start with a MIDI track with the notes you want to send the synth, and an audio track you want to use to modulate it (usually a vocal).
  2. Insert TV-II as an effect on the audio (modulator) track.
  3. In the plug-in UI, at the top, click on the VST2 button and enable MIDI input.
  4.  Go to the MIDI track and set its output to TAL Vocoder.

That's it. Now, you'll have to fiddle with the controls in the plug-in, adjust the synth to get a sound you like, etc., but the routing will be set up.

(The confusing part here is that you're inserting the plug-in on the modulator track, not the carrier. That's what I mean by backward.)

For case 2., you'll be using a stereo bus. You will be sending audio only, not MIDI, to the plug-in.

  1. Create a stereo bus. Name it "Vocoder."
  2. Insert TV-II as an effect on the bus.
  3. Click the button in the plug-in UI that's labeled "Input Mode On."
  4. In the audio/synth tracks you wish to use, create sends to "TAL-Vocoder-2." Set the sends to Pre-Fader.
  5.  Pan the send on the track you wish to use as the "carrier" to hard left. Pan the send from the "modulator" to hard right.

To mute the dry sound from the carrier and modulator, just pull their faders down. If you want some dry sound, bring them up

There are alternate ways to accomplish case 2, but this is the easiest I've found. Send a nice hot signal from the modulator to the right input of TV-11 and again, do some fiddling with the vocoder controls. The internal synth is inactive in this mode, so leave it alone.

General tips for vocoding: on your modulator track (usually voice) fire up a good 1176 emulation, set it to 12:1 and smash the snot out of the signal before sending it to the vocoder. Also, if using a vocal, a tuning correction/pitch changing plug-in can add another dimension. I use Meldaproduction MAutoPitch on the "Man To Woman" setting to bring my voice up (for the AIR Talkie Walkie sound), and set it so that it "glitches" a little bit. Feed the vocoder a nice, hot modulator signal.

Edited by Starship Krupa
TAL Vocoder only goes to 2 so far, not 11
  • Like 6
  • Thanks 2

Share this post


Link to post
Share on other sites

I can't find how to set the MIDI track's output to the audio file.  It only offers me the option to select a MIDI output. Am I looking in the wrong place? I'm attaching screenshots to show where I'm looking.

Screenshot 2021-06-14 114041.png

Screenshot 2021-06-14 114230.png

Share this post


Link to post
Share on other sites

It is not possible to directly route MIDI to an audio track, it must be routed to a plug-in. in this case TAL Vocoder.

After adding the plug-in to the audio track FX Rack, select "Enable MIDI Input" from the VST2/3 drop down in the standard header above the plug-in UI

WBoEAIf.png

This is enabled by default for synths but not for FX plug-ins.

Once enabled, the plug-in will be available in the output drop down in MIDI tracks.

  • Like 3

Share this post


Link to post
Share on other sites

You should be setting the output of the MIDI track to the plug-in. This will appear as an available output once you do my Step 3, as shown in Steve's graphic.

From your screenshot, it seems you may have some confusion as to how to set the output of a MIDI track. Down at the bottom of the MIDI strip (Console or Inspector):

image.png.2b13deb42387b26a455e8fef7ad37235.png

Or from the Track View Track Header:

image.png.0662266085a658c27aeba820814bb363.png

Share this post


Link to post
Share on other sites

I'm trying to do this today, and I'm not getting a sound when I press Play.  I added the Tal Vocoder VST in the Audio track (image below).  I clicked Enable Midi Input.  I put notes into a Midi track and selected the Tal Vocoder as the Midi output.  I press play and I hear nothing.  I can hear the Audio track, but not the Midi track.  Do you know what I am missing to get this to work?

Cakewalk2.jpg

Share this post


Link to post
Share on other sites

I found the answer.  Do you see it?  The Vocoder effect is shaded in my screenshot.  I had the Effect Rack in Bypass mode.  I didn't even know that was a "thing" or that I had that turned on.  I turned off the Bypass and now the vocoder works.  Mystery solved.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, DallasSteve said:

I found the answer.  Do you see it?  that I had that turned on.  I turned off the Bypass and now the vocoder works.  Mystery solved.

Glad you got it to work!

Just to mention: one of the features of my custom themes is that the buttons for enabled and bypassed states are designed with more contrast, so as to be more obvious.

  • Like 3

Share this post


Link to post
Share on other sites

still not getting this to work... I don't hear any effect from the modulation...... trying to recap.

 

1. Have midi and synth setup... plays notes fine

2. Have a vocal phrase --- by itself plays fine

3. I add a new stereo bus - drop TAL on to it

4. Set TAL to input mode on

5. Add a send on the vocal phrase audio track to the TAL plugin (or should this be the Vocoder bus??). Pan the send right., Change the send to be Pre.  I left this output going to master, and pulled down the fader (because I only care about the send)

6. Add a send from the instrument (synth) track to the TAL plugin (or should this be the vocoder bus??). Pan it left. Change the send to be Pre.

I hear the synth playing but no influence from the modulator.

ANy help appreciated. Also having a heck of a time getting Morphoder to work from an external synth.

Share this post


Link to post
Share on other sites
On 1/15/2022 at 2:59 PM, Scott Kendrick said:

5. Add a send on the vocal phrase audio track to the TAL plugin (or should this be the Vocoder bus??). Pan the send right., Change the send to be Pre.  I left this output going to master, and pulled down the fader (because I only care about the send)

6. Add a send from the instrument (synth) track to the TAL plugin (or should this be the vocoder bus??). Pan it left. Change the send to be Pre.

Okay, so you're trying to set it up so that you're feeding it both the carrier and the modulator. This is "Case 2" in my tutorial, and I'll recap:

To do that, you need to insert TAL Vocoder on a bus, then use sends from the carrier and modulator tracks to the vocoder plugin.

Pan the carrier send (usually a synth sound) hard left. Pan your vocal phrases track's send hard right.

For this operation mode, the vocoder should only be on the bus, and you shouldn't send your audio to the bus itself, but rather to the plug-in. The plugin's input should show up on the send menu's list of available destinations.

It looks like you're doing that part correctly. Sometimes you need to crank the levels of the sends to get good results. Too low a modulator signal can result in no modulation, and all you'll hear is the unmodulated carrier. Get it good and hot. Use the Gain knob or a gain plug-in like BL Gain to boost the level if you need to,

Hope this helps.

Share this post


Link to post
Share on other sites

This thread was very useful for me, thank you! I ended up with slightly different settings than is discussed above, though.

 

As you can see, I ended up having to send the vocal signal to the BUS, not to the plugin itself. The midi does go to the plugin, though.  The final I had to get over was remembering to turn on the Input Echo in both tracks when I made my initial recording :)

I also wish the TAL vocoder plugin had visual feedback indicating it was, or wasn't getting signal, to help figure out what I was getting wrong along the way, which was everything.

This setup let me do several things I wanted:

1) have my own synth sound in Vital as the carrier

2) Be able to play and sing live to myself, to work out what I wanted to do, appromixately.

3) Record both singing and playing keys each to their own track

4) Play it back and also be able to edit the midi to stack up more harmonies than I can play live.

 

The remaining bit I don't fully get is the panning. Trying it just now I was able to put the Voice panning anywhere I wanted, both the track pan AND the Send pan, and my singing robot self was still there.

Also the MIDI track pan could be anywhere, but the Midi Send pan had to be center OR right.  I know the TAL plugin is listening on the left and right side of the stereo signal for its input, but would that be the track pan or the send pan settings here?

I'm happy today, though, I finally got this vocoder thing working, thanks to all of you!

image.thumb.png.4e78ad8389497133d730c8cc34e0ca91.png

  • Like 1

Share this post


Link to post
Share on other sites
On 5/3/2022 at 10:37 PM, satyabrata satapathy said:

Can anyone teach routing of MPC Beats in cakewalk, or give a free template

Best to ask this in the Q&A forum.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...