Jump to content
Sign in to follow this  
jono grant

File continually auto-saving

Recommended Posts

I find many files that get to a point where they have a lot going on, are auto-saving constantly, sometimes after every time I hit stop! I have the preference set to autosave every 10 minutes or 10 changes. I think I've been told in the past that recorded midi tracks that have automation etc. may be calculated as "changes" when mod wheels etc. get moved or other parameters get automated, very annoying. I don't make any change at all and it auto saves. 

I've also found that almost any time a crash happens, it's right when an autosave happens... not a coincidence I don't think, it's gets messed up because it tries to auto-save while I'm making some other change and can't handle it.

Anyone know how to make auto-save behave better? 

Thanks

J

 

Share this post


Link to post
Share on other sites

Mine is also set at 0.

If i was forced to set something i should probably not go under 30 minutes.

That's the lowest i've gone in word, excel and other that has that function.

Share this post


Link to post
Share on other sites
1 hour ago, jackson white said:

Preferences > File > Advanced > "Auto save every" ?

Mine is set at 0. 

Wouldn't that turn the feature off? Auto save has saved my butt so many times...I can't imagine not having it enabled.  

Is that what you meant?

Thanks

Share this post


Link to post
Share on other sites

I think my main point here is that; even with autosave set to 10 minutes/10 changes, it's autosaving each time I stop playback...like, all the time!

What is causing that??

Thanks

J

Share this post


Link to post
Share on other sites

@jono grant   Maybe try setting it to zero and see if that changes the observed behavior. 

fwiw, my 'best practice' is a well conditioned "ctrl+s" reflex and a permanent position in the custom control module. 🙂

 

  • Like 2

Share this post


Link to post
Share on other sites
59 minutes ago, jackson white said:

@jono grant   Maybe try setting it to zero and see if that changes the observed behavior. 

fwiw, my 'best practice' is a well conditioned "ctrl+s" reflex and a permanent position in the custom control module. 🙂

 

As do I save all the time but I also make 100 changes per minute and I hate losing stuff. Often it's a performance of some kind. 

I've been using Cakewalk since I had windows 98, perhaps even 95... there are issues that don't ever get fixed, it puzzles me.  

The one thing I mention above about crashes occurring at an auto-save point is an issue as well. I think it just tries to autosave at the exact same time as you make a move and it blows up...lol

Anyhow, thanks

 

Share this post


Link to post
Share on other sites
9 hours ago, jono grant said:

As do I save all the time but I also make 100 changes per minute and I hate losing stuff. Often it's a performance of some kind. 

I've been using Cakewalk since I had windows 98, perhaps even 95... there are issues that don't ever get fixed, it puzzles me.  

The one thing I mention above about crashes occurring at an auto-save point is an issue as well. I think it just tries to autosave at the exact same time as you make a move and it blows up...lol

Anyhow, thanks

 

We fixed an issue a while back for some plugins that were registering multiple changes in parameters either due to automation resetting when going back to zero, or on zero all controllers... but not all plugins were playing ball with this, and still register multiple changes.

My recommendation is to set the number of changes to zero, and rely on the timer instead.

Could you elaborate on what you're doing when it crashes?  We did go through a bunch of operations and postpone auto-save if it tried to do it mid-operation. Maybe one or two have been missed.

Share this post


Link to post
Share on other sites
11 hours ago, jono grant said:

I also make 100 changes per minute

Lol, hear ya on that.  CxB has some incredibly productive workflow capability.  I often feel like I'm abusing it for the types of projects I tend to work on.  

 

2 hours ago, msmcleod said:

elaborate on what you're doing when it crashes?

In my case, it's been full on speed comping  with lots of 'asynchronous' clip editing across multiple take lanes and varying degrees of automation manipulation. By 'asynchronous', I mean the clips do not line up nicely across take lines. 

Share this post


Link to post
Share on other sites
13 hours ago, msmcleod said:

We fixed an issue a while back for some plugins that were registering multiple changes in parameters either due to automation resetting when going back to zero, or on zero all controllers... but not all plugins were playing ball with this, and still register multiple changes.

My recommendation is to set the number of changes to zero, and rely on the timer instead.

Could you elaborate on what you're doing when it crashes?  We did go through a bunch of operations and postpone auto-save if it tried to do it mid-operation. Maybe one or two have been missed.

It's random, I could be altering an envelope or even just moving a clip, if it happens right when the autosave happens it can crash. Again, I go look at the time of the last autosave when it happens and it's always right when the crash was. 

Share this post


Link to post
Share on other sites

I've disabled auto-save since it crashed the DAW the first time it happened. That is a bit more strain on you, as you have to manually save, but no more issues and I can even save with the project running.

Share this post


Link to post
Share on other sites

I'm with OP: mine autosaves all the time, so much so that its interrupting my workflow. And i also get crashes when it does. 

 

I'll try setting to 0 and 10 min and see if it improves. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...