Jump to content
Misha

Interface with loopback function with Cakewalk and another audio softwarequestion

Recommended Posts

John, 

Thanks for the info! I got my M2 last week. As much as I would like... to like it, it is going back next week to the store.

On 41k projects MAX buffer size is 1024. You can not go higher (on 41k). This is the most ridiculous maximum buffer size I have seen in the past 20 years.  The lowest I can get away with is 2048 due to FX/VSTs  when mixing/auditioning.  I should have been more careful in reading specs. This did not even remotely ring a bell. As soon as I ran my project, first 15 seconds, I had clicks/pops and stopped audio engine. A nice young man at Motu wanted to "tweak" my computer, I kindly refused telling him that even my 10+ year old audio Yeti Pro and 2 other interfaces, for the sake of argument (with enough buffers) are pulling my project just fine on the same computer. 

Ohh well. If it is a hardware limit, which I will accept as a lame excuse that is one thing,  but if they artificially limited buffer size within software for whatever twisted reasons they might had, this will be my last Motu experience.  You had been warned.

Share this post


Link to post
Share on other sites

I'm actually having driver issues with mine. It keeps changing sample rates or ?? my projects play fast and 1/2 step up. Also I'm  getting crackles at my normal setting of 256 which I've used for as long as I can remember without issue.  I guess I'm not as heavy a user as you are. Are you doing orchestral stuff?   I'm still going to keep it as overall I like it. Not a huge jump over the 6i6, mostly having something new and shiny I guess. 

Share this post


Link to post
Share on other sites

I am not a heavy user  at all :)

But I might have instance of Halion + Kontakt + few FX... Still 2048 is usually what I have for mixing / auditioning and it works, but sometimes need to go higher.  Limit 1024 in Motu is  just ridiculous. 

Built is great btw,  preamps are nice if you are dealing with small projects.  

Share this post


Link to post
Share on other sites

You shouldn't need to go that high, there is something seriously wrong with your set up. I can have dozens and dozens of VST effects and instruments at 256. I have used 256 on lots of systems and interfaces. And these are older interfaces and basic computers .  No wonder Motu doesn't  go that high, I doubt if anyone would need use it? 

Share this post


Link to post
Share on other sites

My M4 is running fine. After a week or two I got a lot of crackles that had me worried, but it was a bad PCI USB card. The M4 is running fine for me now. It's pretty solid with a buffer size of 64. I ran the old sample projects - Cory Yarckin Floating and  Shifty and the Big Shots. I think they're around 30 tracks.  I did a simple song with 15 or 16 tracks. Five or six audio tracks, Kontact, Reaktor Prism, 2 instances of Omnisphere with 3 patches, 2 instances of Korg Arp Odyssey, Korg Mono/poly, Alchemy. At 64 I did have to load Kontact, Omnisphere, and Alchemy at the start of the project or I would sometimes get a click when they loaded.

I haven't got Win 10 tamed yet. It will do the occasional virus scan in the background (and I don't know what else) and that will cause crackles. If I set the buffer to 128 I don't have to worry about some of those Win 10 unknowns.

Share this post


Link to post
Share on other sites

I don't think that buffer processing overhead plays significant role at such buffer size, so the need to go over 1024 comes from some severe jitters in processing. It can be seriously underpowered or not optimal for audio processing system. Are simple projects (f.e. audio + not sample based synth + FXes) run fine with low buffer (64, in worse case of 10 years old celeron, 128)? If yes, is the same project still runs fine with 1-2 Kontakt instruments? If both are fine, I guess the system is underpowered for current project. If "CPU only" project runs fine, but sample based has troubles, closer look at the disk system (disks, controller, settings, fragmentation) should help to understand from where it comes. If CPU only project doesn't run with 128, something is the system introduce (unexpected) latency, so system settings are not optimal.

I guess MOTU think that modern computers don't need huge buffers, also in some DAWs the buffer size has little impact on possible mixing project size (mixing doesn't work in real-time).

Share this post


Link to post
Share on other sites

 Just did a test. First just to make dang sure I re-installed both drivers for each unit. Seems this has cured the playback speeding up issue with the Motu. I can't get it to do it for now.  So even though the exact same driver something must have been corrupted in the initial download and install.  

But the crackling is definitely an issue.  Just a hint of it at 256 but if I switch to 128 it is totally garbled. So  then I turned off the Motu and turned on the Scarlett. 

The Scarlett played silky smooth and I switched to 128 and all I got was very random glitches. This is a fairly busy project with lots of goodies but I added 6 instances of the Adaptive limiter which I think is a heavy hitter and it didn't change. I returned to the Motu and now 256 is glitching worse. 

Interesting things between the 2 interfaces- When I turn off the Motu and turn on the scarlett with Cakewalk open, I get the disconnect and the choose device pop ups messages. When I turn off the Scarlett and turn on the Motu I get the disconnected but no choose device pop up.. I did this a few time too. Also notice the Motu adjustment for mixing latency is not adjustable.  But you can see the Motu wins the RTL test with about 10ms better performance. 

So just now I opened this thread and seeing what @rsinger said about USB ports I swapped the Motu to my front USB 3 ports and now I'm not hearing crackles at 256 but 128 seems just as bad as before? I fail to see how it would make a difference but the M4 does come with a USB C connector so ?? FYI the Scarlett is still plugged into the USB 2 ports on the back. This machine only has 2 USB 3 ports and I like to reserve them for external drives. 

The Motu has better RTL performance so perhaps this is a case of sacrificing stability for better RTL performance. 

 

910246456_2020-12-26(2).png.a5b2fbeb2ae015c09172de342b25498f.png1877305002_2020-12-26(1).png.6e5138a01ac9f8d6f535251e31bc393c.png

Edited by John Vere

Share this post


Link to post
Share on other sites

I feel like completely disconnected. 

When recording, sure, I press little "fx" button and can get away with 256  buffers... 

But when mixing, having a bunch of dynamic, lookahead vsts (8 or more) plus  some Kontakt/Halion stuff, I can not getaway with anything lower that 2048.  

 i7-8850H/32ram/nvme m.2/ usb 3 + thunderbolt.. Tried both usb controllers. Oh well. Thanks everyone!

Share this post


Link to post
Share on other sites
18 hours ago, John Vere said:

 So just now I opened this thread and seeing what @rsinger said about USB ports I swapped the Motu to my front USB 3 ports and now I'm not hearing crackles at 256 but 128 seems just as bad as before? I fail to see how it would make a difference but the M4 does come with a USB C connector so ?? FYI the Scarlett is still plugged into the USB 2 ports on the back. This machine only has 2 USB 3 ports and I like to reserve them for external drives. 

 

I have the M4 connected to a USB 3 port and the only other thing on the hub is a USB Drive I use for backup and it isn't running when I'm doing audio work. IIRC the M2/M4 are USB 2. When I was having the problem with the bad USB PCI card I tried the M4 into my laptop. That was USB 2 and it worked fine. It's an old laptop so I had the buffer set to 128 and it worked fine with no crackles, but I didn't try 64. 

Share this post


Link to post
Share on other sites

I'm sending the M4 back and hoping they will swap it ( plus $$) for the Focusrite 8i6. It's hard to get over that my 2013 Focusrite 6i6 is more stable than a brand new interface. The MAIN REASON I bought a Motu was everybody raves about the drivers. I guess if RTL is important then this might be true, But I don't use real time effects and what I need is rock solid stability. 

Misha possibly you should see if you can try a different interface? Is there a store you can demo one from?

And one other thing is I've read a lot of threads with thunderbolt issues, seems you need the correct chipset from Texas Instruments or something like that. 

Edited by John Vere

Share this post


Link to post
Share on other sites
13 hours ago, Misha said:

I feel like completely disconnected. 

When recording, sure, I press little "fx" button and can get away with 256  buffers... 

But when mixing, having a bunch of dynamic, lookahead vsts (8 or more) plus  some Kontakt/Halion stuff, I can not getaway with anything lower that 2048.  

 i7-8850H/32ram/nvme m.2/ usb 3 + thunderbolt.. Tried both usb controllers. Oh well. Thanks everyone!

Have you checked your computer for "audio processing compatibility"? I mean Ultimate power plan, latency monitor, CPU throttling, etc. I mean something has to make your system (unexpectedly) busy for more then 20ms to force 2048 buffer size.

Another quick check: open the project in REAPER (with ReaCWP, that should load some if not all plug-ins with project specified settings). Check performance monitor to detect what is going on (it will display CPU load per track, RT load, etc.).

Even on old notebook with Realtek and ASIO4All I was never forced to set more then 192 for recording, if the project could work at all (if CPU is insufficient, the buffer size doesn't help). I think 256 is "safe maximum" for mixing on modern systems, it tolerates not optimized systems and other glitches. Your system should be able to record with 128 with many FX/VSTi. I mean with any interface (if everything is optimized and the interface is reasonable,  64 or even lower should work without glitches).

PS. Lookahead in plug-ins increase RTL but has no direct influence on the buffer size nor CPU use. Lookahead is just algorithm forced approach, by itself that doesn't indicate the plug-in is CPU heavy.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...