Jump to content
Apeirofobia

Sidechain not working

Recommended Posts

Hi guys. 

I've seen another topic with the same issue but there was no solution.

The trouble is that in some projects the sidechain function is not working. I send my signal to some compressor(Any plugin, not just Sonitus) and theres no input. I open a new project and the sidechain works fine. But right now I'm working on a project which is almost finished so it would be a disgrace to start a new project. 

Any ideas about how could I fix this?

Edit: I use a Scarlett 18i20 (Third gen) and Windows 10.  The drivers are up to date.

 

Thanks in advance!

Edited by Apeirofobia

Share this post


Link to post
Share on other sites

Testing again, I discovered a strange behaviour. I have 2 buses (one for the drums, and another one for the bass(DI and Mic tracks). I added a compressor to the bass bus(and tried with the individual tracks too) with an input from the kick, and the problem starts when I solo the bass and drums buses. When I disable the soloing of the buses, it recognizes the input from the kick. Is it normal?

I mean, when I solo the drumand bass buses, their individual tracks should be recognized by the compressor, right? If the tracks are routed to the right bus...

Edited by Apeirofobia

Share this post


Link to post
Share on other sites

Hi Apeirofobia
I'm locking for a solution for the same issue.
Sidechain signal work only when I disable all SOLO 

Please, tell me if you can solve, and I'll do the same!

Good luck!

  • Confused 1

Share this post


Link to post
Share on other sites

One solution is use aux tracks as buses.

Make sure the sends feeding the sidechain inputs on the FX in aux track are pre-fader.

Share this post


Link to post
Share on other sites
3 hours ago, Leonardo Bisaro said:

Hi Apeirofobia
I'm locking for a solution for the same issue.
Sidechain signal work only when I disable all SOLO 

Please, tell me if you can solve, and I'll do the same!

Good luck!

I haven't found a solution. I emailed the cakewalk support this weekend but there are still no answers.

 

3 hours ago, scook said:

One solution is use aux tracks as buses.

Make sure the sends feeding the sidechain inputs on the FX in aux track are pre-fader.

That was the first thing I did, but even when I insert the compressor on aux tracks, and then I solo their respective buses, the compressor stops working.

Edited by Apeirofobia

Share this post


Link to post
Share on other sites

Here are two videos, one inserting the compressor on the bus, and the other one compressing the aux tracks. In both, the compressor stops working everytime I solo their buses.  (Sorry for the quality) Whe I disable all solo, it works just fine.

 

Compressor on bus

 

Compressor on the aux tracks

 

Edited by Apeirofobia

Share this post


Link to post
Share on other sites

It is rather quirky the way CbB handles soloing for busses and aux tracks.  Sidechaining works best when using regular tracks, if you want to hear the effect when soloing  make sure you set the send feeding the compressor to pre-fader.  Soloing on busses acts differently to tracks.  For example if you have a bass buss and solo it you will hear all the bass tracks feeding that buss, but as soon as you solo a track not feeding the bass buss, for example the kick track, you will no longer hear the bass buss, even though it remains soloed.  This is because as soon as you solo the kick all the bass tracks are muted.  Furthermore, you won't hear the kick either because the Bass Buss remaining soloed mutes the Drum Buss!  If you put a compressor on a buss and feed it's sidechain from a track you need to solo the tracks not the busses to engage the effect.

In your example, simply group the solo buttons of the DI Bass and Mic Bass tracks. Set the send of the Kick to Pre Fader.  Now you can solo the grouped Bass tracks (not the buss) and the compressor will work. In my case I only work in track view so it is easy to make a Folder for all the bass elements and use the folder solo button.  I agree that sending a pre-fader sidechain signal from a Track to a compressor on a Buss should result in the expected behaviour,  but this is either a bug  or a quirk.

Another way is to create an Aux track for the bass elements and put the compressor on there.  However you would need to set the kick send to pre-fader, solo it, and then turn it's volume all the way down in order to hear the effect when soloing the Bass Aux Track.  So definitely not the best solution.  Cheers

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, tonemangler said:

It is rather quirky the way CbB handles soloing for busses and aux tracks.  Sidechaining works best when using regular tracks, if you want to hear the effect when soloing  make sure you set the send feeding the compressor to pre-fader.  Soloing on busses acts differently to tracks.  For example if you have a bass buss and solo it you will hear all the bass tracks feeding that buss, but as soon as you solo a track not feeding the bass buss, for example the kick track, you will no longer hear the bass buss, even though it remains soloed.  This is because as soon as you solo the kick all the bass tracks are muted.  Furthermore, you won't hear the kick either because the Bass Buss remaining soloed mutes the Drum Buss!  If you put a compressor on a buss and feed it's sidechain from a track you need to solo the tracks not the busses to engage the effect.

In your example, simply group the solo buttons of the DI Bass and Mic Bass tracks. Set the send of the Kick to Pre Fader.  Now you can solo the grouped Bass tracks (not the buss) and the compressor will work. In my case I only work in track view so it is easy to make a Folder for all the bass elements and use the folder solo button.  I agree that sending a pre-fader sidechain signal from a Track to a compressor on a Buss should result in the expected behaviour,  but this is either a bug  or a quirk.

Another way is to create an Aux track for the bass elements and put the compressor on there.  However you would need to set the kick send to pre-fader, solo it, and then turn it's volume all the way down in order to hear the effect when soloing the Bass Aux Track.  So definitely not the best solution.  Cheers

Thank you so much for your detailed response. I tried to set the send as pre-fader and I had the same exact results.  Whenever I try to solo their respective buses the compressor stops working.

But I haven't tried to group the tracks. That will be my next option. 

Thank you again!

Share this post


Link to post
Share on other sites
On 12/4/2020 at 9:16 PM, tonemangler said:

In your example, simply group the solo buttons of the DI Bass and Mic Bass tracks. Set the send of the Kick to Pre Fader.  Now you can solo the grouped Bass tracks (not the buss) and the compressor will work. In my case I only work in track view so it is easy to make a Folder for all the bass elements and use the folder solo button.  I agree that sending a pre-fader sidechain signal from a Track to a compressor on a Buss should result in the expected behaviour,  but this is either a bug  or a quirk.

I tried this, but it only works if I want to solo the kick and bass. This means I have to solo every drum track if I want to hear the bass in the context of the drums? Aside from the impossibility to hear the buses processing, as reverb, compression, etc

 

Edit: Today I tried creating buses for every drum piece instead of aux tracks, and then I inserted the compressor on them so I could only work with buses, but then again, when I solo the Drum kit and the bass, the compressor stops working, there's no input.

Edited by Apeirofobia

Share this post


Link to post
Share on other sites

Yes, to audition the whole drum kit, bass and effect return you would have to customize your project.  Firstly, as mentioned previously, you would group all bass tracks.  Next group all drum tracks.  It is easier to use track folders for this but I see you work in the console view which I believe you does not support folders.  The next step depends on if you have a lot of busses.  Create a new buss, call it something like 'Pre Mix'.  Send all busses except for bass, drums and effects to this buss and set it's output to the Mix buss.  Now, if you want to audition the kick and bass you press Ctrl and click the kick track (this solos only the kick) and then click any bass track.  Next to hear all drums and bass, first you Ctrl click the kick track (to un-solo it) and then click on any drum track.  Next you want to hear drums, bass and effects, leave the bass and drum tracks soloed and simply mute the 'Pre Mix' buss.   If you don't have a lot of busses you don't need to create the 'Pre Mix' buss just mute all busses except for drum, bass and effects. I hope this works for you.

  • Thanks 1

Share this post


Link to post
Share on other sites
11 hours ago, tonemangler said:

Yes, to audition the whole drum kit, bass and effect return you would have to customize your project.  Firstly, as mentioned previously, you would group all bass tracks.  Next group all drum tracks.  It is easier to use track folders for this but I see you work in the console view which I believe you does not support folders.  The next step depends on if you have a lot of busses.  Create a new buss, call it something like 'Pre Mix'.  Send all busses except for bass, drums and effects to this buss and set it's output to the Mix buss.  Now, if you want to audition the kick and bass you press Ctrl and click the kick track (this solos only the kick) and then click any bass track.  Next to hear all drums and bass, first you Ctrl click the kick track (to un-solo it) and then click on any drum track.  Next you want to hear drums, bass and effects, leave the bass and drum tracks soloed and simply mute the 'Pre Mix' buss.   If you don't have a lot of busses you don't need to create the 'Pre Mix' buss just mute all busses except for drum, bass and effects. I hope this works for you.

Thank you so much for your time and effort. Im trying this method, and it's working when I mute the rest of the band in the "pre-mix" bus. It's a strange behaviour but it's working.

Thanks again!

Share this post


Link to post
Share on other sites
1 hour ago, Apeirofobia said:

Thank you so much for your time and effort. Im trying this method, and it's working when I mute the rest of the band in the "pre-mix" bus. It's a strange behaviour but it's working.

Thanks again!

I agree about the strange behaviour!! I imagine every DAW has it's quirks.  I'm glad I could help.  Cheers.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...