Jump to content
Michael Fogarty

Solved: SoundForge successfully added to Utilities but .wav doesn't import -Scook?

Recommended Posts

Posted (edited)

Years back I had this same problem and somebody suggested a way to fix this.  Went through all the prompts suggested in other threads I read by Scook and others.  How to get wav to import export?

Thank you - I promise I'll save it as a manual this time. Duh!

For the sake of clarity not only is SF in my utilities pull down, but when I select the wav and click SF, SF does open - but no imported wav.

Edited by Michael Fogarty

Share this post


Link to post
Share on other sites

Usually the cause is a bad entry in the registry "Type" field. The type should be WaveEditor, all one word, no spaces.

One way to avoid problems when adding to the Tools section of the Utility menu is use the Tool Editor that I wrote some time ago. It is available on my Google page. The readme pdf includes an example of how to setup SF11.

Share this post


Link to post
Share on other sites
12 minutes ago, scook said:

Usually the cause is a bad entry in the registry "Type" field. The type should be WaveEditor, all one word, no spaces.

One way to avoid problems when adding to the Tools section of the Utility menu is use the Tool Editor that I wrote some time ago. It is available on my Google page. The readme pdf includes an example of how to setup SF11.

Hi Scook. Yes, I tried to. It was difficult for me to comprehend. I will try the above and see if that works.

Share this post


Link to post
Share on other sites
Posted (edited)

Scook -went back and checked and it does say WaveEditor. It doesn't say tool not found or anything. SF does open, but the wav doesn't pop in.

Guess I will take a look at you pdf. So, downloaded but don't know what to do with it. Yes, there are people like me in the world. For instance, though this is I'm sure very clear to you, I don't know what it means.

 

"Installation: There really is no installation process. After unzipping the archive, put the appropriate program in a convenient location. Usage: Run the appropriate version of ToolsEditor. Use the F1 key to access the built-in help. Note: The DAW reads the registry and builds the Utilities menu on start up. Any changes made by this tool while the DAW is running will take affect (should read effect I think) after restarting the DAW.

Edit - so I just fill in the same thing you did on page 3 of your PDF, leaving the same blanks, but using Sound Forge 10 instead of 11? Then I hit submit?

Here goes.

Edited by Michael Fogarty

Share this post


Link to post
Share on other sites

After downloading the zip, unzip the file, the program anywhere you wish and run it.

If running the ToolEditor from the inside the DAW (not a requirement), changes will not show up until the DAW is restarted.

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, scook said:

After downloading the zip, unzip the file, the program anywhere you wish and run it.

If running the ToolEditor from the inside the DAW (not a requirement), changes will not show up until the DAW is restarted.

😀Amazing. It worked. So, now I have a Sound Forge and a Sound Forge 10 in my utilities, the latter which you helped me set up, works. The Sound Forge opens but does not import the wave. How can I delete the old path? Or safer to just leave it there? I wanna be like you when I grow up.

Share this post


Link to post
Share on other sites

In the ToolsEditor

  • Use the Edit drop down to select the item to delete
  • Click the Delete button at the bottom of the tool

If running the ToolEditor from the inside the DAW, changes will not show up until the DAW is restarted.

Share this post


Link to post
Share on other sites

Almost anything may be added to the Utilities menu. CbB will pass audio clips to any program that accepts an audio file as an argument on its command line. Setting the "Type" in ToolEditor to WaveEditor is what tells CbB to send the clip to the other program.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...