Jump to content
tdehan

Things don't snap to grid since the recent update

Recommended Posts

Are you set to “snap by” instead of “snap to”?

 I never use “snap by” but occasionally it raises its ugly head.

Why; good question...

tom

Share this post


Link to post
Share on other sites

I, otoh, can't live without Snap By, so I will better waiting for confirmation if it's working fine, before I upgrade. Thanks

Share this post


Link to post
Share on other sites

Really? What do you use it for, if I may ask?

When I was a new to - then Sonar - the fact that it is the default on install made me think for a long time snap to grid was broken. Even today I wonder what situations it could find a use.

Share this post


Link to post
Share on other sites
On 11/24/2020 at 5:18 PM, tdehan said:

Things don't snap to grid since the recent update.  Anyone else experiencing this issue?

We're not aware of any snap related issues. Can you be more specific about the nature of your problem? What view are you trying to use and what are you editing? 

Share this post


Link to post
Share on other sites
3 hours ago, twelvetone said:

Really? What do you use it for, if I may ask?

When I was a new to - then Sonar - the fact that it is the default on install made me think for a long time snap to grid was broken. Even today I wonder what situations it could find a use.

Personally, I don't use it a lot... but here's the scenario I do use it in.

Say I've got an un-quantised MIDI recording, or an audio recording that is in no way snapped to anything.  For arguments sake, lets say the start of the clip is 1:04:527.

If I want to move it by 1 bar, I'll set snap to be Whole and set it to snap by.  Moving it to the next bar gives a start time of 2:04:527.

If I'd used snap to, the start time would be 3:01:000.

  • Thanks 1

Share this post


Link to post
Share on other sites
7 hours ago, msmcleod said:

Personally, I don't use it a lot... but here's the scenario I do use it in.

Say I've got an un-quantised MIDI recording, or an audio recording that is in no way snapped to anything.  For arguments sake, lets say the start of the clip is 1:04:527.

If I want to move it by 1 bar, I'll set snap to be Whole and set it to snap by.  Moving it to the next bar gives a start time of 2:04:527.

If I'd used snap to, the start time would be 3:01:000.

Cool, I didn't know this! 👍 In such cases I always did it much more complicated (with cut, set now time, then paste). 😄

Share this post


Link to post
Share on other sites
15 hours ago, twelvetone said:

Really? What do you use it for, if I may ask?

Snap By takes care of order in my projects by keeping clips in their relative position on the grid while copying/moving.

The way I'm used to keep clips organized in my projects makes them almost never perfectly aligned to bars. Unless it's electronic kick or snare, most of my clips will be slightly off the grid or anywhere in between bars. That's because if I do record live audio, I cut somewhere between the breath and voice or guitar notes, if I do MIDI acoustic drums then I tend to play it live on keys or pads and I never quantize 100%. And so on. That way most of the notes, say kick, fall somewhere around the beats but never exactly on the beat, clips can start a couple ticks before or after the beat.

If I used Snap To instead, then it would happen exactly what Mark says to the clips, and their relative position would have got screwed.

Edited by chris.r

Share this post


Link to post
Share on other sites
On 11/24/2020 at 2:18 PM, tdehan said:

Anyone else experiencing this issue?

Snap working fine here!

2 hours ago, chris.r said:

Snap By takes care of order in my projects

Ah, the beauty of CbB, tailor it to suit your needs!

t

Share this post


Link to post
Share on other sites
On 11/24/2020 at 6:53 PM, DeeringAmps said:

Are you set to “snap by” instead of “snap to”?

 I never use “snap by” but occasionally it raises its ugly head.

Why; good question...

tom

Yup... Snap To

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, Jonathan Sasor said:

We're not aware of any snap related issues. Can you be more specific about the nature of your problem? What view are you trying to use and what are you editing? 

I have no idea what you mean by What View.  As far as editing I am editing MIDI tracks.

Share this post


Link to post
Share on other sites
On 11/26/2020 at 11:33 AM, tdehan said:

I have no idea what you mean by What View

Such as, Track View, Piano Roll View, Staff View, Arranger View, etc.

Share this post


Link to post
Share on other sites

Ah... got it.  Sorry.

The good news is that it is now working again.  I have no idea what's different.

Share this post


Link to post
Share on other sites
On 11/24/2020 at 11:18 PM, tdehan said:

Things don't snap to grid since the recent update.  Anyone else experiencing this issue?

Be sure to use 1/4 note when you copy and paste.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...