Jump to content

Recommended Posts

I'm very new at this so please don't attack me for not knowing things. I'm sure it's an easy fix but I've tried and tried and tried to no avail.

I can't get cakewalk to record any midi from my yamaha piano. I've got it set up with a USB2Midi cable, the computer's recognising it fine, I've followed all the instructions online to get it set up the way it should be, but for some reason cakewalk still won't recognise when it's being played or record anything. I'm at my absolute wits end, please help!

Edited by Kit Fox

Share this post


Link to post
Share on other sites

Hello @Kit Fox,

Welcome to Cakewalk by Bandlab, or CbB for short and to the forum.

Please post your CbB midi devices input and output selections and your midi Playback and Recording settings.  A screen shot of these two screens would be wonderful!

When you said, "the computer's recognizing it fine", what feedback are  you seeing that convinces you enough to make that statement?

Edited by Jim Fogle
  • Like 2

Share this post


Link to post
Share on other sites

Go to Preferences (press "P"), then click Devices under the MIDI heading. This will list all MIDI input devices that Windows has reported to CbB as being available. If the synth isn't included in that list, that means Windows doesn't know about it. If it is on the list, check the box next to the device name to enable it within the DAW. At that point, it will appear in the dropdown list in the MIDI track and can be selected.

You can verify that all's well with the routing by clicking the Record button, hitting some keys and seeing that some MIDI notes have been recorded. If nothing's recorded, the next step is to figure out what's impeding MIDI data (make sure the MIDI channel is set to Omni). If MIDI notes do show up in the track, then you're in good shape.

If your issue is that you don't hear the instrument while recording, that means you don't have Input Echo turned on. There's a button in the MIDI track header for that. 

If MIDI is recorded but you don't hear anything when you play it back, it's probably because the Yamaha's MIDI Out device has not been enabled. Try inserting the TTS-1 and routing the MIDI to that - you should hear sound then.

 

  • Like 3

Share this post


Link to post
Share on other sites

The midi channel is set to omni, the Yamaha is all set up in preferences > devices (that was the first thing I did before seeking help, it shows up in the dropdown as USB2Midi), but notes do NOT show up in the track when recording. I hit record, I hit a few keys, nothing happens. I don't understand what's wrong. According to all advice I've found so far it should be working fine.

Share this post


Link to post
Share on other sites

Have you selected the keyboard as the input device in the audio track?
Make sure the Inspector is open: Views -> Inspector.
1946837052_2020-11-2612_12_28-Window.jpg.fe8516f5de08aa98c290a3587f2859db.jpg
Here it says I -None-. You must select your keyboard.

Then, the red button on the track is Record Arm. That must be selected.
Then you need to click the Record button in the transport module.
1814583808_2020-11-2612_16_28-Window.jpg.0426c769c278813df357f5a41ff2c5df.jpg


 

Share this post


Link to post
Share on other sites

Yes, I've done both of those things - the midi track (I'm trying to record midi, not audio) is record enabled and the keyboard is selected in the track dropdown. It still doesn't recognise any input.

Edited by Kit Fox

Share this post


Link to post
Share on other sites

Double check that the MIDI end of the cable is the correct way round. i.e. "In" connected to the IN port on the keyboard and "out" to OUT.

 

If the keyboard is recognised in CbB-  and the drivers are selected in preferences with input on the track set correctly there's not much else it can be other than the keyboard isn't outputting any MIDI data.

Share this post


Link to post
Share on other sites

The cable definitely is the right way around. I'm doubtful about it being an issue with the midi keyboard as it worked fine with cakewalk and the same cable on my other laptop - but the fact remains that since installing cakewalk on this laptop, I've had no luck whatsoever.

Share this post


Link to post
Share on other sites

One way to debug this is to install a midi monitor app (one i recall is called midiox). Studio one, another DAW, ahs one build in. You need to make sure that windows is seeing the MIDI events before you can debug it in Cakewalk. Using a monitor app you can tell what channel and what device is sending the data.

If windows sees the midi data then you can make sure Cakewalk is using the right midi device. Cakewalk has a little icon that shows up in the bottom right corner tray in windows that will blink an fake LED when cakewalk sees midi data coming in or out.  Is this showing any activity?

Before trying to record your midi make sure that you can hear a virtual instrument playing, with echo enabled on the track, when you play your keyboard. If you can't hear it you are not going to get anything to record.  You should also see "MIDI" activity in the inspector, Hit I or view Inspector, when the MIDI tab is selected.

 

image.thumb.png.278807e867382e35133398d9e4529a59.png

Share this post


Link to post
Share on other sites

This is a basic video that explains MIDI and set up in Sonar X1 but is still relevant to CbB today.

 

However I would follow the advice above ref MIDIox or an alternate DAW first to check that MIDI data is definitely reaching your laptop. If it is, the video link above should help.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...