Jump to content
  • 0
Peter Stiens

PercX VS Cakewalk - crackling sound (finally solved)

Question

Good morning everyone,
hope you all have a nice Sunday morning ūüėČ

Sorry to disturb you, but this is annoying and I don't know what to do:

Please find attached a soundfile. 

What you here is the sound of PERCX (a drum sound lib) used in cakewalk and exported to mp3.
You also hear that unwanted crackling sound.

This crackle is independent of output device, i.e. headphones, speakers, wired or bluetooth.

It does NOT appear when using the PERCX standalone module.

I've checked the latest audio drivers, tested different audio formats in Cakewalk preferences, I tried some checkboxes (not really knowing what purpose they serve)
Can someone please help with this problem?

Thank you all in advance.

Best regards

Peter

Link to PercX, in case it's needed: https://www.auddict.com/percx
sysinfo, if needed;
Win 10 Home
Dell Inc. , XPS 15 7590
Intel(R) Core(TM) i9-9980HK CPU @ 2.40GHz, 2400 MHz, 8 cores, 16 logic proc
BIOS-Version    Dell Inc. 1.8.1, 03.07.2020
BIOS-Mode    UEFI
phys RAM     32,0 GB
Audio Adapter:  Intel Cannon Lake-H/S - cAVS (Audio, Voice, Speech) [B0]
Video Chipset:  NVIDIA GeForce GTX 1650
 

cakewalk-percx.mp3

Edited by Peter Stiens
update sysinfo

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Thank you, both.
I've tried ASIO first, but unfortunately I wasn't able to get it working (cause I have no clue what's going on with all this different modes)

Switched to WASAPI/shared with a sampling rate of 48000.

This works fine with my bluetooth headphones SONY WH-1000XM3.

and..... no more crackling sound. Phantastic!

Maybe this post may help someone with a similar problem:
cakewalk, crackling noise, crackle, soundproblem, sampling rate 48.000, WASAPI
see pictures for setup

~~~~~~~~~~~~~~~~~

Edit:  (quote from member scook)
When sharing devices with Windows and Cbb make sure the sample rates are the same.
Above shows CbB is set to 48000.
Windows must be set to the same sample rate.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Following posts are no longer relevant.
Reboot your PC at least once after changing settings ūüėȬ†

Best regards

Peter

 

wasapi3.png

wasapi2.png

wasapi1.png

Edited by Peter Stiens

Share this post


Link to post
Share on other sites
  • 0

What driver mode are you using (ASIO is prefered)

What sample rate, bit depth and buffer size are you using?

Share this post


Link to post
Share on other sites
  • 0
26 minutes ago, Promidi said:

What driver mode are you using (ASIO is prefered)

What sample rate, bit depth and buffer size are you using?

Promodi, thank you for answering so fast.
 

I've tried different driver modes.
Worked with MME but crackled.
Switched to ASIO now, does not work - please see pictures.

asio-1.png

asio.png

Share this post


Link to post
Share on other sites
  • 0

The Realtek ASIO driver is not good.

The WASAPI modes are the best choice when running Win10 and using the internal sound chip 

ASIO4All may work too but try the WASAPI modes first.

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, scook said:

The Realtek ASIO driver is not good.

The WASAPI modes are the best choice when running Win10 and using the internal sound chip 

ASIO4All may work too but try the WASAPI modes first.

Thank you scook, I'll give them a try.

Share this post


Link to post
Share on other sites
  • 0

Uuuuh. Sorry. I was happy too early ūüėČ
Bluetooth headphones work perfect, but I can't switch to my speaker out.

See picture

What does that mean and what do I have to do?

  

wasapi-speaker-output.png

Share this post


Link to post
Share on other sites
  • 0

When sharing devices with Windows and Cbb make sure the sample rates are the same.

Above shows CbB is set to 48000.

Windows must be set to the same sample rate.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

√ó
√ó
  • Create New...