Jump to content
Rfcousins

How Can This Be Happening???????

Recommended Posts

I know this post will seem too strange to be credible, but I have verified it many times over the last week.

I have been editing my entire project library to modify screensets and a few other minor settings. This is 1000's of projects.

They are MIDI only for the most part.

I began to find that every so many files, Cakewalk would begin to "buffer" and display "Not Responding" in the title bar. This would resolve itself after several seconds and would repeat after each new "mouse click" until the project was saved. The behavior would continue for each successive project. Only by restarting the computer would Cakewalk return to "normal" behavior. Restarting Cakewalk would not correct the problem, only restarting the computer. Next, I began counting the number of projects that I could work on before the behavior would return. I expected this to be random but was surprised to find that in fact it could be relied upon to appear every 17 project files loaded.

I have no clue what to investigate next ! Open to all suggestions. Happy to try anything to resolve this.

My next thought is a "Bad RAM stick". Don't want to mess under the hood unless others think it is worth the effort.

Thanks for any input!

 

 

Share this post


Link to post
Share on other sites

If you have 2 screens try opening the Performance monitor found in Settings for Windows and keep an eye on RAM usage. But that said I think there is/was a setting that releases stuff from RAm when you close a project? 

Share this post


Link to post
Share on other sites

Yes I am using 2 displays. Not sure where you are suggesting I look for RAM usage. Can you be more specific for Win 10 Ver 1909 64 bit?

Share this post


Link to post
Share on other sites

A failing hard drive can also cause some explainable behavior. If you know already know how to access the S.M.A.R.T diagnostics for your drive you may get some info about the drive performance without running anything else. If not, locate the manufacturer of your HDD, and download their diagnostic tool.

I would also run the Windows memory test (requires a reboot) https://www.howtogeek.com/260813/how-to-test-your-computers-ram-for-problems/

or run the standalone memtest86 via a bootable USB stick. https://www.memtest86.com/

 

Share this post


Link to post
Share on other sites
1 hour ago, Rfcousins said:

Not sure where you are suggesting I look for RAM usage. Can you be more specific

Open Windows Task Manager, which you can access by pressing Win+X and selecting Task Manager from the menu, or by right clicking on your Task Bar and selecting it.

Once you have Task Manager running, click the Performance tab at the top, then click on Memory. That will give you a graph of how much RAM your computer is using.

17 is a very specific number. Since it happens system-wide, I'm thinking iffy hard drive. Cakewalk does write to the disk for some caching tasks, most notably the picture cache. That folder is usually C:\CAKEWALK PROJECTS\PICTURE CACHE\ by default. You may delete all the .WOV files in it. Check the dates and times and see if there's any relation to your issue.

Share this post


Link to post
Share on other sites

Interesting that you are thinking iffy HD. I just upgraded to Samsung 860 SSD's for both of my drives because I felt my 10 year old WD 7200 rpm was going soft. I need to see if I can duplicate this issue with my laptop that is very close in spec to my desktop.

Thanks for the help so far.

Share this post


Link to post
Share on other sites

Memory Test Shows no issues. File count before problem has now changed to "23" projects. S.M.A.R.T. hd tests show no errors! Open to anything else to test or try.

Thanks for the help again ! 

Share this post


Link to post
Share on other sites

@RfcousinsIf memory tests and HD tests are clean, then it's probably a software issue rather than hardware. Have you tried uninstalling Cakewalk and reinstalling it? As you mentioned, testing with your laptop may help you to determine if it has something with the project files themselves causing the issue.

I mention the following because you initially indicated Cakewalk was "not responding".

The next thing I would check is that all my drivers are up to date, especially the audio and video. Go to the manufacturer's sites and see if there are any driver updates.

There are also methods available to "clean boot" Windows with minimal startup programs. The step by steps for that procedure are available on many computer blogs and forums.

By clean booting one can rule out possible conflicts with real-time antivirus scan, or other programs, utilities, etc. that launch at startup. If you startup with only the Windows processes, and your DAW + audio drivers, and that works you will know that it was caused by something that you temporarily disabled. Then enable one thing at a time, reboot and test Cakewalk again until you identify the culprit.

 

Edited by abacab

Share this post


Link to post
Share on other sites

UPDATE: Laptop Lenovo T530 does not exhibit the behavior. FYI.......checked on all the settings for a system running SSD drives. A couple of changes there , but nothing that corrects the problem. Going to try the "clean boot next". What a pain this small thig has become. THanks for the help and support.

Share this post


Link to post
Share on other sites

Hi, here are  things that I regularly use in order to prevent and solve problems and improve DAW performance:

  • check that all drivers are up to date. For example, use a freeware tool like Dumo. If it finds outdated drivers just go to the hardware manufacturer's site directly and download it from there (in general I find that safer than to use a tool to do it for me)
  • run Windows update to be up to date and to and make sure that no update has been downloaded that is still waiting for install or reboot (this has been a cause of sudden malfunctioning for me several times and is very easy to solve. However, considering your story I assume you've restarted enough and probably are up to date with Windows 10 itself)
  • check that all other software is up to date. For example, use a freeware tool like SUMo. If it identifies outdated software versions, update the software from the software itself, you don't need to use the tool (or support the makers and pay for the function to let it download the software for you) 
  • to make sure you've got all the latest runtimes there are two handy downloads: AllinOne Runtimes (contains the following: .NET Framework 4.8 + Updates, Java Runtime Environment 8, DirectX 9.0c Zusatzdateien, Allgemeine Runtime Dateien, Microsoft Visual C++ Runtimes (v2005 - v2019), Microsoft Visual J# 2.0 SE, Microsoft Silverlight 5, Adobe Flash Player (Opera, FireFox, Internet Explorer), Shockwave Player 12. Each can be selected or deselected for installation)
    and Visual C++ Redistributable Runtimes All-in-One (This last one might be a bit more up to date but has only the C++ updates)
  • run the different windows repair tools (Windows File Protection, Component Store Corruption, System Components, Rebuild WMI Repository, Reset Windows Update, Windows Installer (MSI)): you can find them by searching the web and find explanations for each how to do it or you can see if you can get a free trial of Window 10 Manager which has a very handy repair centre tab where you can execute them with one click
  • use CCleaner to get rid of junk files, clean the registry (you can select what the program will check, will deleted and what not! If you don't understand how to use it don't but it  is one of the few really reliable programs that perform this kind of actions so recommended to check it out. It also has many other functions, like startup manager where you can see which programs automatically start with Windows and prevent them from doing so if you don't really need them to start with Windows, etc.) 
  • check that PC power is set to maximum: 1.    Set your computer's power for high performance - Go to: Control Panel>Power Options - Choose "High Performance" - Then click the "Change plan settings" button. Make sure both power options are set to "Never"
  • check that no USB adapters can switch off power. On the Properties screen, click on Power Management tab and uncheck the option for “Allow the computer to turn off this device to save power” and click on OK.
    Disable power management for USB root hubs in the Device Manager. Open the Device Manager and expand the Universal Serial Bus controllers category. Right-click each USB Root Hub, click Properties and click the Power Management tab. Uncheck any boxes next to “Allow the computer to turn off this device to save power.”
    Check this after each big Windows update. Windows has the annoying habit to reset many options after an update...
  • disable network cards, WIFI and Bluetooth if not used (Device Manager => network adapters, right-click and select disable device)
  • check that you your graphics card doesn't install audio and other things than the driver itself. If you have an NVIDIA GeForce you can use NVcleanstall to get the latest driver, do a clean install and deselect everything that is not the main driver (other software, audio driver, telemetry etc.).
  • check in device manager under
    1) audio inputs & outputs that only the desired audio controller is being used (e.g. Focusrite) and no other device is being used (like NVIDIA)
    2) sound video & game controllers (see 1))

On the same page as DUMo and SUMo you'll find many other tools to find problems (KC softwares). Other sites with many handy tools that might help you are Resplendence (LatencyMon, WhoCrashed, WhysoSlow etc.),  Nirsoft and SoftwareOK (I regularly use many of the tools from these websites for different purposes, also to improve my workflow with windows and other programs) 

To find out what goes wrong on windows:

  • try Control Panel\All Control Panel Items\Security and Maintenance\Reliability Monitor => click on the alarm signs to find out the details
  • try other tools in the same Security and Maintenance directory like Windows Memory Diagnostics
  • try Windows event viewer. Explanations for use are in the hyperlink. This records anything software does on your PC and might pinpoint a problem you have.
  • try What's my computer doing

Hope this helps!

Share this post


Link to post
Share on other sites

UPDATE: This problem seems to be related to my Tascam USB20X20 USB 3.0 interface. Updated driver: No luck Disabled ports on motherboard and installed new USB3.1 card: No luck. I am close but just can't pin it down yet. Any suggestions appreciated.

Share this post


Link to post
Share on other sites
6 hours ago, Rfcousins said:

UPDATE: This problem seems to be related to my Tascam USB20X20 USB 3.0 interface. Updated driver: No luck Disabled ports on motherboard and installed new USB3.1 card: No luck. I am close but just can't pin it down yet. Any suggestions appreciated.

Check your plugins - it could be a vst. Bypass each one individually and check if it still happens. 

Also check if the project you open are not linked to a second project that might be hanging open and "Saved As."

I had this rare issue last year sometime.  I had two projects open and every 30 mins or so, I would flip between the two, to make the deadline. Somehow, they got linked and saved as such.  

I had to go through 20 saved versions to fix this issue. It took me a while to figure this out. Thought-oh-no! Project lost. 

If you have different copies of the same project - open the from the project folder and see if the problem still persist. 

Edited by Will_Kaydo
  • Like 1

Share this post


Link to post
Share on other sites

First I come to think of if 17 projects are open at the same time?
- mean if closing one before opening next

There is a setting in preferences if to allow more than one project at a time.
Then current project is replaced as another is opened.

And OP never answered how much free memory task manager show as new projects are opened(or I missed it)?
24 GB is plenty for one project, for 17 project not so much.

Behavior is typical for pagefile is starting to be swapped with physical memory, that is reeeeeeeeeeeeeeeeeeeeeeeaaaaaaaaaaaaaaaaaaalllllllllllly slow.

And the advanced settings to automatically save every x changes or a time span is also under suspicion.

Share this post


Link to post
Share on other sites

Keep those thoughts coming, I will check them all as time permits. Many thanks:

Here is the latest observation: This does not occur when connected to USB2.0 port.

 

Share this post


Link to post
Share on other sites
22 hours ago, Will_Kaydo said:

Check your plugins - it could be a vst. Bypass each one individually and check if it still happens. 

Also check if the project you open are not linked to a second project that might be hanging open and "Saved As."

I had this rare issue last year sometime.  I had two projects open and every 30 mins or so, I would flip between the two, to make the deadline. Somehow, they got linked and saved as such.  

I had to go through 20 saved versions to fix this issue. It took me a while to figure this out. Thought-oh-no! Project lost. 

If you have different copies of the same project - open the from the project folder and see if the problem still persist. 

I will work on the checking the VST's. Thanks for the suggestion. Not sure how I would check to see if a project is linked to another. Can you point me there?

By the way I can STOP the behavior by running Cakewalk without connection to my Tascam 20X20 USB, or by connecting the Tascam to USB2.0 port.

Did I mention that none of this happens on my Lenovo Thinkpad i7 16Gig Ram 2X Samsung 860 EVO SSD's, Same Tascam connected to USB3.0 port, Same Version of WIn 10 64bit.

I am focused on the USB3.0 ports of my desktop for now. Pondering an add-on USB3.0 card to try instead of the motherboard ports.

Share this post


Link to post
Share on other sites
8 hours ago, LarsF said:

First I come to think of if 17 projects are open at the same time?
- mean if closing one before opening next

There is a setting in preferences if to allow more than one project at a time.
Then current project is replaced as another is opened.

And OP never answered how much free memory task manager show as new projects are opened(or I missed it)?
24 GB is plenty for one project, for 17 project not so much.

Behavior is typical for pagefile is starting to be swapped with physical memory, that is reeeeeeeeeeeeeeeeeeeeeeeaaaaaaaaaaaaaaaaaaalllllllllllly slow.

And the advanced settings to automatically save every x changes or a time span is also under suspicion.

I am only opening one project at a time. The behavior occurs when I open the 17th or the 23rd project by itself. I have the setting in preferences set to one project at a time. I do not automatically save every x changes.

Where would I check on the pagefile setting etc?

Share this post


Link to post
Share on other sites
1 hour ago, Rfcousins said:

I have the setting in preferences set to one project at a time. I do not automatically save every x changes.

 

Has this always been a default setting for you - OR - have you changed it recently? 

1 hour ago, Rfcousins said:

Not sure how I would check to see if a project is linked to another. Can you point me there?

Do you know how to find your Project folders in Windows? 

Share this post


Link to post
Share on other sites

"Where would I check on the pagefile setting etc?"

Starship Krupa mentioned it above, rather early task manager Performance tab.

How much physical memory are you having free just booted computer?
You have 24 GB in your specs for computer. So around 20 GB free is probably close.

How much free as Cakewalk is started?
How much after first project loaded?
How much after 2nd project loaded?

....and so forth.

Are you getting less and less free memory all the time?
A little is normal depending how much a project contains in sampler plugin instances etc.

So when getting to 17th - what does it say in free memory in Performance tab?
You can also look at memory in the Processes tab, how much Cakewalk alone is using.
But overall free memory in system will probably do - it probably says available physical memory somewhere.


When you start getting above 75% of physical ram memory used, windows is starting to use pagefile swapping to virtual memory, This is simply using a file on disk as temporary storage to extend capabilities overall what can run.

But just below 10 GB memory or so available might having system use pagefile, so just get the number of what task manager Performance says is free when you feel system is getting slow.

Since you had harddrives earlier this would use some memory as read cache for things you loaded. Now using SSD this read caching is not needed in the same way, since reading arbitrary spot on disk is so much faster and read caching.

So mission is
- put a number here on forum for taskmanager available memory as you getting a slow system(17th load or whatever)
- size of pagefile or virtual memory also put that number here

That will give clues what is going on....

Share this post


Link to post
Share on other sites

As a former professional software QA engineer, with such a precise (and well-observed, I might add) symptom, there are questions to be asked outside of the usual "running out of memory" "bad drive," etc.

The most important one is: what event happens on your system each time you open (or possibly save or close) a project? There is some event, such as initializing the ASIO driver, the MIDI port, something like that. After the 22nd time, it breaks something. Software bugs are sometimes like this.

My guess, since it stops happening when you disconnect the TASCAM (good troubleshooting, BTW), is that there is something going on either in its driver or in the hardware itself. It can only take being reinitialized (or whatever) 22 times before going into an error condition. Did the change in the number of projects opened coincide with a change in buffer size? If you switch to WASAPI driver mode, does it still exhibit the problem?

It is a little unusual to open and save 22 projects in a row, so it's possible that TASCAM didn't test for this exact condition in the driver software or the interface's firmware. In any case, you have identified the component that is most likely the source of the issue: your audio interface. Contact TASCAM and see if anyone else has experienced similar issues.

  • Great Idea 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...