Jump to content
  • 0
yeto

How do I sync vocals to recording?

Question

In the below picture, where it says Timing Offset(msec), is this where I would sync vocals to my instrument recordings?

Thank you,

yeto

 

Sync Vocals.PNG

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

After more research maybe I would adjust here (see photo).

Can someone provide any help as to how I would do this?

Thank you in advance for any help,

yeto

Record Latency Adjustment.PNG

Edited by yeto

Share this post


Link to post
Share on other sites
  • 0

I have tried both "Full Chase Lock" and "Record latency Adjustment - Manual Offset" and I just can't get the Audio/Vocal track to line up with the Instrument Tracks. BandLab's "Online" DAW has a Latency Test does Cakewalk have something similar?

Thank you in advance for any help,

yeto

Share this post


Link to post
Share on other sites
  • 0

I take it Cakewalk does not have a "latency compensation" feature/setting?

Share this post


Link to post
Share on other sites
  • 0
On 3/12/2019 at 11:11 AM, yeto said:

I take it Cakewalk does not have a "latency compensation" feature/setting?

Cakewalk has always had latency compensation built in from the early days of Sonar (unlike the cheaper versions of Pro Tools). It's automatic and doesn't need to be enabled.

Cakewalk relies on the information provided to it by the driver. As the vast majority of users here don't get issues with latency compensation, I suspect it's your audio driver that is misrepresenting the actual latency values.

Edited by msmcleod

Share this post


Link to post
Share on other sites
  • 0
On 3/12/2019 at 4:11 AM, yeto said:

I take it Cakewalk does not have a "latency compensation" feature/setting?

Sorry you haven't been getting any help here. Can you tell us what PC you are using, what audio interface (or no audio interface), and how you are going about putting vocals onto your backing tracks?

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Larry Jones said:

Sorry you haven't been getting any help here. Can you tell us what PC you are using, what audio interface (or no audio interface), and how you are going about putting vocals onto your backing tracks?

Dell desktop - Windows 10 - motherboard sound card - "no" audio interface

I am running my mic into a usb port.

Edited by yeto

Share this post


Link to post
Share on other sites
  • 0

Right off the top I'll say that you'd be far better off with an audio interface designed for this kind of work and a "real" microphone. Your computer is seeing the mic as an audio device. The mic is used as an input, but it can't be an output (for playback/monitoring), so the internal sound card is used for that. Under Edit|Preferences|Audio|Driver Settings you will probably see your internal sound card as the Playback Timing Master and your USB mic as the Record Timing Master. That should screw up your sync right there, but it's the only way it'll work at all. Maybe if you go to Edit|Preferences|Audio|Playback and Recording and change the "Driver Mode" to one of the WASAPI choices you'll get better results. Also, the mic may be a 16-bit only device, so make sure you're not recording at a different bit depth (like 24).

Cakewalk is designed for use with a single, fast audio interface and if you use one your latency and sync should not be (much of) an issue. You would never, for example, have to slide a recorded track around on the timeline to get it in sync with existing tracks. I'm not an expert on this stuff, but I hope this helps.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Larry Jones said:

Right off the top I'll say that you'd be far better off with an audio interface designed for this kind of work and a "real" microphone. Your computer is seeing the mic as an audio device. The mic is used as an input, but it can't be an output (for playback/monitoring), so the internal sound card is used for that. Under Edit|Preferences|Audio|Driver Settings you will probably see your internal sound card as the Playback Timing Master and your USB mic as the Record Timing Master. That should screw up your sync right there, but it's the only way it'll work at all. Maybe if you go to Edit|Preferences|Audio|Playback and Recording and change the "Driver Mode" to one of the WASAPI choices you'll get better results. Also, the mic may be a 16-bit only device, so make sure you're not recording at a different bit depth (like 24).

Cakewalk is designed for use with a single, fast audio interface and if you use one your latency and sync should not be (much of) an issue. You would never, for example, have to slide a recorded track around on the timeline to get it in sync with existing tracks. I'm not an expert on this stuff, but I hope this helps.

When I try to use ASIO my mic won't work. Do you see anything I am doing wrong?

ASIO input.JPG

ASIO input2.JPG

Share this post


Link to post
Share on other sites
  • 0

The ASIO specification requires the host to use one I/O driver at a time.

If the microphone has an ASIO driver and the driver is installed, in order to use the microphone in ASIO driver mode, all audio input and outputs in preferences must be deselected before the microphone may be selected in preferences. Once selected in preferences, the device will appear in audio input and output drop downs.

To use the Realtek chip for output and the microphone for input requires a different driver mode or ASIO4All which aggregates WDM drivers and presents them to the DAW as a single ASIO driver.

Share this post


Link to post
Share on other sites
  • 0
30 minutes ago, scook said:

The ASIO specification requires the host to use one I/O driver at a time.

If the microphone has an ASIO driver and the driver is installed, in order to use the microphone in ASIO driver mode, all audio input and outputs in preferences must be deselected before the microphone may be selected in preferences. Once selected in preferences, the device will appear in audio input and output drop downs.

To use the Realtek chip for output and the microphone for input requires a different driver mode or ASIO4All which aggregates WDM drivers and presents them to the DAW as a single ASIO driver.

I deselected > then clicked apply > I don't see the mic if I did everything correctly.

Pref1.JPG

Pref2.JPG

Share this post


Link to post
Share on other sites
  • 0

Either the device does not have an ASIO driver or the ASIO driver is not installed.

Share this post


Link to post
Share on other sites
  • 0

I think the Realtek Speakers & Microphone are different devices from the Realtek HD Audio, and they are all presented as separate devices within Windows.

It would seem Realtek have provided ASIO drivers for the HD Audio part, but not for the Speakers or Mic.

Note that the analog ports (certainly on my motherboard) are the speakers/microphone, whereas the HD Audio can only be used via an adapter to the digital output on the motherboard, or through HDMI. The reason there are 3 HD Audio output devices is for surround support.

My recommendation would be to get a dedicated audio interface. Failing that, use WASAPI or ASIO via ASIO4ALL.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, msmcleod said:

My recommendation would be to get a dedicated audio interface. Failing that, use WASAPI or ASIO via ASIO4ALL.

I studied  some old threads related to ASIO via ASIO4ALL and I don't think I want to go down that road. I am going to experiment with WASAPI and I will report back.

Thank you for taking time to help,

yeto

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...