Jump to content
locrian

Steinberg Cubase 11 (not a deal)

Recommended Posts

The new metering is certainly nice/welcome.  Otherwise (to me)... not an overly exciting update.

More than anything, I'd like to see Cubase improve on CPU efficiency.  That's where they're lagging behind numerous other DAWs.

 

  • Like 1

Share this post


Link to post
Share on other sites

I'm "in process".  It had rescan plugins, and now I'm refreshing my "photos" in the VST Instruments..etec...
Glad I got in early!

Share this post


Link to post
Share on other sites

i am a cubase user on 10.5 . i find i keep reverting to 9.5 b/c or performance.  i dont really see anything in the features that would entice me to upgrade.

*if* I had the fancy dual super duper large displays like the guys  in the ads, i might bite b/c of this though.

"

Windows 10 Variable DPI

More scaling settings.

"

Share this post


Link to post
Share on other sites
Just now, cclarry said:

I'm "in process".  It had rescan plugins, and now I'm refreshing my "photos" in the VST Instruments..etec...
Glad I got in early!

Yup I was out earlier or I would have done it then. Just wondering whether I can enter the code on the Steinberg website instead of the e-licenser software?

Otherwise I'll just leave it until tomorrow! 

Share this post


Link to post
Share on other sites
Just now, ZincT said:

Yup I was out earlier or I would have done it then. Just wondering whether I can enter the code on the Steinberg website instead of the e-licenser software?

Otherwise I'll just leave it until tomorrow! 

I entered it on the eLicenser and that's what auto-upgraded me...then just went to the Steinberg
Download Assistant, and downloaded from there!

  • Thanks 1

Share this post


Link to post
Share on other sites

the licence code I got was in a new format - it was a "download code" - had to enter it in the SB download assistant and this authorised it - gave me a new elicencer code and installed it on the elicencer.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
16 minutes ago, simon said:

the licence code I got was in a new format - it was a "download code" - had to enter it in the SB download assistant and this authorised it - gave me a new elicencer code and installed it on the elicencer.

 

I bought the upgrade in July and received an activation code (8 groups of 4 alphanumeric digits) rather than a download code. As it is on my old PC the e-licenser and download assistant software were outdated so I have updated them but it still fails to connect. I suspect that my e-licenser database is out of date but it cannot connect to synchronise  😵 To be honest I can't wait to get rid of this Cubase/E-licenser nonsense. It was also a hassle moving my Halion 6 (soft e-licenser) to my new PC.  
 

  • Thanks 1

Share this post


Link to post
Share on other sites
9 minutes ago, ZincT said:

I bought the upgrade in July and received an activation code (8 groups of 4 alphanumeric digits) rather than a download code. As it is on my old PC the e-licenser and download assistant software were outdated so I have updated them but it still fails to connect. I suspect that my e-licenser database is out of date but it cannot connect to synchronise  😵 To be honest I can't wait to get rid of this Cubase/E-licenser nonsense. It was also a hassle moving my Halion 6 (soft e-licenser) to my new PC.  
 

ahh - that's the reason.  Looks like they've changed to a new way of generating codes, starting today I assume as something I bought a couple of weeks ago was in the old format.  It's 5 groups of 5 alphanumeric digits which obviously wouldn't work in the elicencer software.  Then I remembered the SB download thing had a new code input section thing.  That took the 'download code' activated it in the downloader and generated an elicencer code...it even installed it on the dongle too.

Worked pretty well actually - although I haven't been a fan of the SD downloader...but it wasn't available on the website to download this morning so I was forced to use it.

edit...

and I don't mind the physical elicencer - I assume the issue you had was the software elicencer and I expect if they do get rid of the dongle they'll still retain an awkward software licencer ...so probably the same issue moving stuff around.  With the dongle > new pc  > plug it in

edit 2

lots of grumbling on the SB forum about the elicencer server being down/overloaded....

 

Edited by simon
  • Thanks 1

Share this post


Link to post
Share on other sites
17 minutes ago, ZincT said:

I bought the upgrade in July and received an activation code (8 groups of 4 alphanumeric digits) rather than a download code. As it is on my old PC the e-licenser and download assistant software were outdated so I have updated them but it still fails to connect. I suspect that my e-licenser database is out of date but it cannot connect to synchronise  😵 To be honest I can't wait to get rid of this Cubase/E-licenser nonsense. It was also a hassle moving my Halion 6 (soft e-licenser) to my new PC.  
 

Just reading on the Cubase forum, lots of folks have the same problem connecting today.  This just posted on that forum:

"

 Matthias Quellmann » Wed Nov 11, 2020 9:38 am

Hi all,

Please excuse the inconvenience. The servers are up and running, but there are currently just too many activation requests. Unfortunately we need to ask you for some patience.

All the best,
Matthias

Matthias Quellmann - Senior Marketing Manager"

 

Despite the urge to update/upgrade today, I'll try to persevere and see if there is an upgrade from 10.5 to 11 at a bit lower price in the next several weeks!

Edited by balinas
clarification
  • Thanks 1

Share this post


Link to post
Share on other sites
17 minutes ago, simon said:

ahh - that's the reason.  Looks like they've changed to a new way of generating codes, starting today I assume as something I bought a couple of weeks ago was in the old format.  It's 5 groups of 5 alphanumeric digits which obviously wouldn't work in the elicencer software.  Then I remembered the SB download thing had a new code input section thing.  That took the 'download code' activated it in the downloader and generated an elicencer code...it even installed it on the dongle too.

Worked pretty well actually - although I haven't been a fan of the SD downloader...but it wasn't available on the website to download this morning so I was forced to use it.

edit...

and I don't mind the physical elicencer - I assume the issue you had was the software elicencer and I expect if they do get rid of the dongle they'll still retain an awkward software licencer ...so probably the same issue moving stuff around.  With the dongle > new pc  > plug it in

edit 2

lots of grumbling on the SB forum about the elicencer server being down/overloaded....

I was trying to move Halion to the new PC and I had quite a lot of back and forth with their support to do something which should be simple. In the end Steinberg support had to create a new soft e-licenser which then let me install Halion on the new PC. 

My issue with the hardware dongle is that it is very restrictive for transferring licenses so I will effectively have to sell Cubase with my USB e-licenser which means physically posting something losable rather than via a quick e-transfer.

Share this post


Link to post
Share on other sites
22 minutes ago, balinas said:

Just reading on the Cubase forum, lots of folks have the same problem connecting today.  This just posted on that forum:

"

 Matthias Quellmann » Wed Nov 11, 2020 9:38 am

Hi all,

Please excuse the inconvenience. The servers are up and running, but there are currently just too many activation requests. Unfortunately we need to ask you for some patience.

All the best,
Matthias

Matthias Quellmann - Senior Marketing Manager"

 

Despite the urge to update/upgrade today, I'll try to persevere and see if there is an upgrade from 10.5 to 11 at a bit lower price in the next several weeks!

Thanks for the information. My Cubase license is now shown as "Transfer pending" in my e-licenser. Will try again tomorrow and then raise a support ticket if no joy 😬

Share this post


Link to post
Share on other sites
2 minutes ago, Tony Carpenter said:

Not only are the servers playing up.. during my upgrade which seemed to be working it took out my 10.5 license off my elicenser stick.. gone!.  :((

I see others complaining about the same issue - very annoying but the elicencer has some way of tracking that so it will come back....

 

Share this post


Link to post
Share on other sites
3 minutes ago, ZincT said:

My issue with the hardware dongle is that it is very restrictive for transferring licenses so I will effectively have to sell Cubase with my USB e-licenser which means physically posting something losable rather than via a quick e-transfer.

yes - that's annoying, although there isn't a licence transfer fee so that pays for the postage with insurance.   I bought a copy of nuendo a couple of years ago and picked up the dongle and the transfer was very straightforward

 

  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, simon said:

I see others complaining about the same issue - very annoying but the elicencer has some way of tracking that so it will come back....

 

Thanks Simon, I have taken screen shots of current state in case, including licenses do show on my account page :).

  • Great Idea 1

Share this post


Link to post
Share on other sites
10 minutes ago, Tony Carpenter said:

Thanks Simon, I have taken screen shots of current state in case, including licenses do show on my account page :).

can you log into mysteinberg ? you'll probably see it there....(edit - you said yes 👍)..stress not though :)   the licencer server has an audit trail.

Usual SB type fiasco but you should be able to use 10.5 on the elicencer 24hour licence 

In other news - it's as underwhelming as expected.

 

There are some new plugins,( but thanks to Larry) I have better alternatives

 A slight modernisation of some of the GUI..and I mean slight

ARA2 fixes that should have been there in the initial release 2 versions ago

Sampletrack improvements (which I don't use)

They pulled the Remote API thing - wasn't working

Tweaks to some other bits and pieces but nothing earth shattering.

PLUS lots of outstanding bugs and issues NOT fixed and all the big feature requests ignored.

I bought every update since the Atari days - and pro24 before that...think this is the most meh yet.

 

Edited by simon
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

@simonYeah, my licenses are showing on the MySteinberg. I just can't get up and going. I don't actually have Cubase 10.5 on my PC. I am in the middle of installing everything on it at last. As I was about to do Cubase, new version came out, and I went.. eww good idea... new version on fresh install... DoHHH :). LOL

Share this post


Link to post
Share on other sites
Just now, Tony Carpenter said:

@simonYeah, my licenses are showing on the MySteinberg. I just can't get up and going. I don't actually have Cubase 10.5 on my PC. I am in the middle of installing everything on it at last. As I was about to do Cubase, new version came out, and I went.. eww good idea... new version on fresh install... DoHHH :). LOL

I'm sure it will settle down soon 

incidentally, for those who don't have Spectralayers or lots of plugins there is more in the update than I listed.  And I still think cubase is amazing...just frustrating that they spend their time messing around the edges instead of making the core functionality better.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...