Jump to content
James Reid

Bandlab Assistant will not download, and delay when trying to record vocals.

Recommended Posts

I am having trouble trying to download the latest edition of Bandlab Assistant. It gets so far into the download process, and then stops. I have tried removing older versions of the program with the add/remove function in Windows 10, but it will not delete them. Secondly in one of my projects when trying to record vocals, there is an annoying latency/ echo. When I create a new project and try and record vocals, it's fine. I may have switched something on or off in the project I am having problems with.

Share this post


Link to post
Share on other sites
43 minutes ago, James Reid said:

Secondly in one of my projects when trying to record vocals, there is an annoying latency/ echo. When I create a new project and try and record vocals, it's fine. I may have switched something on or off in the project I am having problems with.

There are two sources of latency a user can control

  • Audio driver buffer settings
  • Plug-in delay compensation

My guess is the delay in the existing project is plug-in related.

This can be tested by bypassing all plug-ins using the FX button in the Mix Module. If the delay goes away, one or more plug-ins in the project need the DAW to delay the signal in order to work. Enabling all plug-ins and turning off the FX Racks and ProChannels one at a time can help isolate the plug-ins.

Generally plug-ins such as dynamics processor and IR reverbs either need to look into the future to react to the incoming signal or take time to compute their effect. This is achieved by buffers built into the plug-ins. As a result, the DAW delays the rest of the audio in the project so that everything says in sync. This is called Plug-in Delay Compensation. Most plug-ins requiring large amounts of compensation have some mention of it in their documentation.

While reading about the FX button and Mix Module take a look at the PDC button documentation too.

Share this post


Link to post
Share on other sites

I have tried turning th FX switch on and off, but this makes no difference. I have also tried the PDC button, but again the problem remains.

Share this post


Link to post
Share on other sites

There are two causes of the delay.

If it is not the plug-ins then it is the audio interface buffer.

If you are hearing a slap back echo on the track being recorded, this is due to monitoring both the direct signal and the recording track from the DAW. Turn off input echo on the recording track.

 

Share this post


Link to post
Share on other sites

I have tried turning the input echo off, but the problem still remains. I have managed to Download the latest edition of the Bandlab Assistant, thanks to the above post. I downloaded and used the CC Cleaner and removed the previous version of the Bandlab Assistant, from my registry. Thanks for that.  

Share this post


Link to post
Share on other sites

There's another thread and he is finding that his Saffire 6 USB is probably the cause of all his issues. It's very outdated so will not work well on a modern system. 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...