Jump to content
David Riley

Help! Time bar is jittery/stuttering

Recommended Posts

I'm hoping someone can help me.  I have Cakewalk Sonar X3 and also Band Lab's Cakewalk on my system.  I've noticed with Sonar X3 my time code runs very smoothly without any jittery issues.  However, Band Lab's Cakewalk has a really jittery time code.  it doesn't smoothly run through a 4 count even though there's no issue with audio playback or lag.  Both versions of the software have the same settings as far as I can tell.  But it's really off putting to try to record with the time code stuttering along.  Any ideas?

Share this post


Link to post
Share on other sites

My knee-jerk reaction was to say "Press Scroll-Lock PAUSE on the keyboard" but if you are working with time code and sync in Cakewalk then that suggestion is probably way off base and you'll need someone else's advice...

Edited by Colin Nicholls
  • Like 1

Share this post


Link to post
Share on other sites

When you say time code, do you mean the time code display within CbB itself ?

The "Pause" key (next to scroll lock)  puts CbB into low CPU usage mode by reducing the UI refresh rate.

Pressing pause again will take it out of that mode.

  • Like 2

Share this post


Link to post
Share on other sites

Crap I meant the PAUSE key. Thanks Mark.

From the manual:

Quote

Like the Scroll Lock key, the Pause key now works as a special GUI throttle toggle key. When the Pause key is pressed, Cakewalk runs in a CPU conservation mode by reducing the frequency of GUI updates. For example, VU meter updates, Now position pointer and progress updates will appear to update less frequently.During CPU conservation mode, the UI is only updated once per second.

 

Share this post


Link to post
Share on other sites
15 hours ago, msmcleod said:

Pressing pause again will take it out of that mode.

Thanks for that info... Since it's next to Scroll Lock, I'll hit it accidentally and end up rebooting CbB to reset the mode... Ya live & learn 😁

Share this post


Link to post
Share on other sites

Thanks for the info, but no that didn't help matters (actually pressing Pause made it worse, so maybe I was already in low UI mode).  And yes I'm referring to the time bar that shows measures and beats.  It's really jerky and not fluid, and yet Sonar X3 works just fine.  Any other ideas?  I don't suffer any lag or latency issues with audio so I really can't figure out why it's doing this.  One thing I DID notice is that when I press play and it's stuttering, if I open up the preferences and look at the time bar it's operating smoothly as it should.  The moment I close the preferences it reverts back to stuttering.  

  • Confused 1

Share this post


Link to post
Share on other sites

Interesting. I have no idea about what is going on with your system, but I can confirm that the PAUSE GUI throttle doesn't magically go away when I bring up the Preferences window. It continues to update periodically in the background. It sure *looks* similar to what you're experiencing.

Do you have some kind of screen mirror or streaming component that is running? What processes are running in the Windows TaskBar?

Share this post


Link to post
Share on other sites

Did you just switch to the floating track view to show the effect of switching to the Preferences dialog? Does the problem persist if you maximize the track window? Also, is CbB referencing the same driver as X3 for Playback Timing Master in Preferences > Audio > Driver Settings?

Share this post


Link to post
Share on other sites

When ever I've (rarely) experienced this rebooting, the DAW, or in the worst case, the OS, is usually necessary.
Always, after an oS reboot, the problem is gone.
I've always guessed that it's just a Windows trying to allocate ram and not doing a good job of it.
 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...