Jump to content
jono grant

How do I get midi input on an audio channel?

Recommended Posts

Hi, I'm trying to do a midi learn setup on a knob in guitar rig 5, the guitar rig plugin is in the efx bin of an audio track though and when I press "learn" it won't recognize the midi input.

I can do it out on windows with the standalone version of guitar rig, and I can midi learn controls in cakewalk with soft synths like kontakt etc.

I can't seem to access any midi setting when it's used as an effect in Cakewalk. (Midi and audio settings show up in the stand alone version but not in CW)

How do I make a plugin like guitar rig  accept midi data input when it's inserted onto an audio track?

Thanks!

Jono

 

 

Share this post


Link to post
Share on other sites

Enable the plug-in's MIDI Input in the VST2/3 drop down above the plug-in UI

OCJrN7P.png

Add a MIDI track, set the input to your controller, output to the plug-in and enable input echo

  • Great Idea 1

Share this post


Link to post
Share on other sites
14 minutes ago, scook said:

Enable the plug-in's MIDI Input in the VST2/3 drop down above the plug-in UI

OCJrN7P.png

Add a MIDI track, set the input to your controller, output to the plug-in and enable input echo

I don't seem to have that on mine. It looks like it's 32 bit or something. I can't seem to find the enable midi setting. I looked in the vst properties of the plug but it doesn't show there either...is it a vst3 only, type thing?

 

G rig.jpg

Edited by jono grant

Share this post


Link to post
Share on other sites

To see the standard header for a 32bit VST, hold the ALT key while opening the plug-in UI.

Usually the standard header window opens behind the plug-in UI window.

That said you would be better off Installing the 64bit version of Guitar Rig and any other plug-ins that have been updated to 64bit.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...