Jump to content
Hell_O.G.

Feature Request:function to MCU to change track in one-fader controllers

Recommended Posts

Hello!

I've posted it before, wrote to Support, but my request still not realized.

 I have Behringer X-touch One controller. This device has only 1 motorized fader, so I need to use it by selecting track in Cakewalk. When I plugged device to Cakewalk and set it up to MCU, I can use Mackie Control built-in utility (Utilities -> Mackie Control-1). There is good option in this utility - Select Highlights Track. When I checked this option I can select track in Cakewalk by mouse and x-touch one controller automatically jumped to selected track controls. It works good, but one problem appears. All manipulations depends on MCU fader bank. When I select tracks 1 to 8 (fader bank 1) all works good. When I select, for example, 9 track I have to change fader bank in X-touch to 2, then device jumps to 9 track settings.


So, I have an idea to add option in Cakewalk Utility Mackie Control: when user selects track in Cakewalk, fader bank automatically changes to selected track (e.g. if I select 24 track, fader bank automatically changes to 3)It would be realized using checkbox. I think it helps to X-touch controller jumping to active track settings no matter what track user selected.

I'm not alone with this problem, please, help users to control Cakewalk more comfortable)

Share this post


Link to post
Share on other sites

The "Select Highlights Track" option is actually to enable the MCU select buttons to set Cakewalk's current track, rather than the other way around as you describe.

But you can also set the current bank by right clicking on the WAI strip to the far left of the track header - this will allow you to move where the fader bank starts:

wai_set_bank.gif
 

Share this post


Link to post
Share on other sites

Thanks for answer)

I know about this function, but it's not comfortable to click RMB in WAI strip every time I need to change track not being in current MCU bank. If this function (given the fact it has already implemented) would be automated, it will be more comfortable to control DAW. 

I suggest to the programmers just need to bind function "Move Mackie Control-1 here" with clicking LMB to track)

Share this post


Link to post
Share on other sites

I already used it, but it works the same as standard MCU. I created a topic in that forum and Azslow suggested me a decision with tuning his plugin and it works. But I don't like it because every time I need to start this plugin I have to do it manually by open plugin settings and turn it on. Anotherproblem is more difficult settings than standard MCU driver.   

Share this post


Link to post
Share on other sites
2 hours ago, Hell_O.G. said:

Thanks for answer)

I know about this function, but it's not comfortable to click RMB in WAI strip every time I need to change track not being in current MCU bank. If this function (given the fact it has already implemented) would be automated, it will be more comfortable to control DAW. 

I suggest to the programmers just need to bind function "Move Mackie Control-1 here" with clicking LMB to track)

This does sound ideal for your situation, however there's two issues with this approach:

1. It doesn't work if you've got more than one control surface (hence the context menu allowing you to choose which controller to set WAI)
2. With the MackieControl, the WAI strip is always 8 tracks - so it'll not work with the last 8 tracks (a way around this is to create an extra 7 empty tracks at the end)

A better approach might be to have a single-fader mode within the MackieControl surface DLL itself.  My worry is that it'll cause compatibility issues with other 1 fader surfaces. They all pretend to be a MCU, but they all do it in slightly different ways.

All the hardware manufacturers which have a SONAR/Cakewalk mode have spent time ensuring that it works with Cakewalk's MackieControl DLL. Any changes we make can cause compatibility issues. I recently faced this with the Presonus FaderPort 16 when trying to improve the plugin/synth support... I ended up having to abandon it due to compatibility issues.

It might be easier for @azslow3 to address the issue of having to manually open it and switch it on, and use AZController... if this is still in fact an issue? The previous CbB release addressed a similar issue in this area with presets not loading up, so it might be worth trying it again.
 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...