Jump to content
jonathan boose

Can't change bit rate

Recommended Posts

I haven't added audio or MIDI at all. I can choose a sampling rate but not a bit depth.

Moreover, the drop down menu for the bit depth which is greyed out and inoperable says 24 while the display on the transport module says 16.

 

 

 

bit depth2.jpg

 

Win 10 Pro
Intel Core i7-3770 @ 3.40 GHz, 3.40 GHz
16 GB RAM
64 bit op sys
Lynx Aurora 16 ADC w/ AES16e card
 

Edited by jonathan boose

Share this post


Link to post
Share on other sites
16 hours ago, scook said:

 

"It is the record bit depth set here" 

What does that mean? If we record and mix at 24 bits we expect that to be what is indicated.

Edited by jonathan boose

Share this post


Link to post
Share on other sites

See Preferences | File | Audio Data to set the bit depth of any recordings.

The unchangeable '24 bits' in Driver Settings indicates the bit depth for all communication between CW and your audio driver. 

If you record at 16 bits* recorded data (coming in at 24bits) will be scaled down to fit in the +/-32K range of 16 bit data, (presumably) expanded during playback (CW mixes internally at 32 or 64 bit floating-point), and those floating-point values will be scaled down to fit the allowable 24 bit range when sent to the audio interface.

* Don't do that. Disk space is essentially free, and the added dynamic range of 24 bit recording is well worth the tradeoff.

 

If we record and mix at 24 bits we expect that to be what is indicated.

Your recording always comes in from the interface at 24 bits, though you can throw some resolution away and write the files at 16 bits if so desired. Mixing is always done internally at 32 or 64 bit float, and is always going to be played back at the 24 bits that the interface supports.

Edited by John Bradley

Share this post


Link to post
Share on other sites
4 hours ago, jonathan boose said:

"It is the record bit depth set here" 

What does that mean? If we record and mix at 24 bits we expect that to be what is indicated.

This

is a link to another post. Click the arrow in the upper right of the link to read the entire post.

For the DAW to record 24bit set the record bit depth to 24.

Regardless of the driver bit depth or the record bit depth, the DAW uses more than 24bits to mix.

Share this post


Link to post
Share on other sites

I guess it must've defaulted to a CD I "mastered" for my brother because that's the only time I record at 16 bits.

So when I change the record bit depth to 24, how come the transport display suddenly says 96 instead of 48?  I  made sure it was set to 48, saved the project and it still says 96.

 

 

post.jpg

Edited by jonathan boose

Share this post


Link to post
Share on other sites

I'm not certain the "Default setting for New Projects" can override or change your ASIO settings - that setting predates the existence of ASIO, and may only be able to control the sample rate for the other two audio driver modes. But don't quote me on that.

In any event, the line below Buffer Size says "Effective latency at 96kHz", indicating that that's the sample rate your interface is running. Go to the ASIO panel and change it as desired.

 

Share this post


Link to post
Share on other sites

The transport shows the sample rate and record bit depth that will be used when recording the project that is loaded. The sample rate is read from a clip header in the project. The record bit depth is read from preferences.

The yellow arrow points to the default sample rate that will be used in a new project and existing projects that do not have any audio clips.

Red Book CDs use 44.1 kHz 16bit. But the format of the final product has little bearing on how the DAW should be set up.

 

Share this post


Link to post
Share on other sites
40 minutes ago, scook said:

 

The yellow arrow points to the default sample rate that will be used in a new project and existing projects that do not have any audio clips.

 

 

This is a new project with no audio clips, as mentioned in the OP. 

So basically, since this is a new project with nothing recorded, I can just delete it and start it again and it will be 48 24 since I can't get this one to behave. I already opened another project that was a new project with no audio clips and the track module on  that reads 48 24.

Share this post


Link to post
Share on other sites
1 hour ago, John Bradley said:

 

In any event, the line below Buffer Size says "Effective latency at 96kHz", indicating that that's the sample rate your interface is running. Go to the ASIO panel and change it as desired.

 

That isn't something I did. I didn't set it on 96. Can you see how this is confusing?

"Go to the ASIO panel and change it as desired." ASIO panel? There isn't any. It's controlled by CbB preferences. If I put a CD in my computer to play through my monitors the Lynx automatically switches from 48 to 44.1

I'll just delete this project and start another with the same title and it will default to 48 24. 

The point is, I can't do this on the fly. According to Sonar X2 documentation, since there isn't any CbB documentation to be found in a search, you can change the settings if nothing is recorded. That doesn't appear to be the case now so that is misleading.

And a waste of time.

Share this post


Link to post
Share on other sites

There are several differences between the image in the OP and the second image including, snap settings, the sample rate and record bit depth.

There is no way to tell if the image showing the project sample rate at 96k is because

  • there is an audio clip in the project at 96k or
  • the preference setting was just changed and not applied

If a new project does not use the new project sample rate from preferences, the template used to create the project contains one or more references to 96k audio clips.

 

Changing the record bit depth does not affect a project's sample rate.

 

Share this post


Link to post
Share on other sites

Once again, there is no audio clip in the project.

CbB changed the sample rate to 96 AUTOMATICALLY when I changed the bit depth to 24. It wasn't me, it wasn't a poltergeist. I never ran a project at 96 so it didn't get it from anything I ever did.

"If a new project does not use the new project sample rate from preferences, the template used to create the project contains one or more references to 96k audio clips."

Apparently not.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...