Jump to content
Sign in to follow this  
greg54

uninstalling Sonar/registry key - SOLVED

Recommended Posts

I'm a little confused about something.   I'm doing a clean install of Sonar Platinum.   In the registry keys below, at the end they say:   <Platinum/Professional/Artist>

I don't have Platinum in my Sonar folders.   Mine only go this far:   HKEY_CURRENT_USER\Software\Cakewalk Music Software\SONAR

So my question is, Do I delete the folder that says Sonar, along with everything in that folder?

 

Delete the following Registry keys: If you do not have one of the Registry keys below, simply proceed to the next one on the list.


HKEY_CURRENT_USER\Software\Cakewalk Music Software\SONAR\<Platinum/Professional/Artist>
HKEY_LOCAL_MACHINE\Software\Cakewalk Music Software\SONAR\
<Platinum/Professional/Artist>
HKEY_LOCAL_MACHINE\Software\Wow6432Node\Cakewalk Music Software\SONAR\<Platinum/Professional/Artist>

Edited by greg54

Share this post


Link to post
Share on other sites

It won't hurt anything either way. There should be a product specific folder under SONAR. If it is not there that step may be skipped. Just like the instructions say.

There is a very good chance uninstalling SONAR Platinum will damage CbB so plan on running an uninstall/reinstall from BandLab Assistant after Platinum is reinstalled.

 

Share this post


Link to post
Share on other sites

I don't use Cakewalk by Bandlab.    I only use Platinum.  

I found this in the Cakewalk database, which makes it more confusing:

Delete the following Registry keys. If you do not have one of the Registry keys below, simply proceed to the next one on the list.
HKEY_CURRENT_USER\Software\Cakewalk Music Software
HKEY_LOCAL_MACHINE\Software\Cakewalk Music Software
HKEY_LOCAL_MACHINE\Software\Wow6432Node\Cakewalk Music Software

This one doesn't even add the folder SONAR.  

So is it ok to delete the folder SONAR, or is it ok to delete everything in CakewalkMusicSoftware?

Edited by greg54

Share this post


Link to post
Share on other sites

For Platinum the instructions say to delete the Platinum folder under

HKEY_CURRENT_USER\Software\Cakewalk Music Software\SONAR\
HKEY_LOCAL_MACHINE\Software\Cakewalk Music Software\SONAR\
HKEY_LOCAL_MACHINE\Software\Wow6432Node\Cakewalk Music Software\SONAR\

 

Cakewalk usually installs a SONAR product specific folder under each of those registry paths for the SONAR Platinum, Professional, Artist and Home Studio product lines.

If the folders are not there, the instructions say skip the step.

If you elect to do more than the instructions say AND you have SONAR Professional, Artist or Home Studio installed, they will be damaged.

If you do NOT have any of those products installed, removing the registry entries does not matter. They will be rebuilt during reinstall and VST scan.

 

Share this post


Link to post
Share on other sites

I uninstalled Platinum from the Command Center.   I did find Platinum in the Sonar folder in: HKEY_CURRENT_USER\Software\Cakewalk Music Software\SONAR\<Platinum/Professional/Artist>

But I did not find Platinum in the other 2.   So I guess I will leave them alone and re-install Platinum.

Thanks, scook, for your help!

Share this post


Link to post
Share on other sites

That didn't do what I wanted.   When I "reinstalled" Platinum, all the Picture Cache was still there, as were all my projects.   I want to clear everything and reinstall it from scratch.   The reason is, after a while when the Picture Cache adds up, the vocals start to sound bad.   I can delete the Picture Cache myself, but it doesn't help the sound.

The only thing that helps is a clean install.   So I guess I'm not understanding what needs to be done.

Share this post


Link to post
Share on other sites
11 minutes ago, greg54 said:

after a while when the Picture Cache adds up, the vocals start to sound bad. 

don't recall reading that before. A full cache is not a good idea though.

 

11 minutes ago, greg54 said:

 I can delete the Picture Cache myself, but it doesn't help the sound.

not surprising

 

11 minutes ago, greg54 said:

When I "reinstalled" Platinum, all the Picture Cache was still there, as were all my projects. 

Both are user data and not part of the reinstall process. Having an uninstall automatically delete user data is a really bad idea.

If you wish to do this as an extension to the clean install instructions, feel free to add those steps.

 

FWIW, the latest CbB now manages the picture cache automatically. From https://discuss.cakewalk.com/index.php?/topic/19403-current-release-202009/

Quote
  • Automatic Picture Cache management
    • On startup, Cakewalk now auto detects when the wave picture cache is full and will self delete the oldest files to make room for new files.  No user intervention is required.
    • For efficiency, picture cache management is only done at startup time. 
    • The Max size of picture cache has been raised to 10000 MB. 

 

Share this post


Link to post
Share on other sites

Sooo......as long as I use Sonar Platinum I'll have issues with picture cache.    But if I switch to CbB then I won't have to deal with picture cache issues ever again?

The ONLY reason I haven't switched to CbB is because of all the negative comments I've read.   People have issues with it all the time.   Except for the picture cache problem, I have no other issues with Platinum.   But that one thing drives me crazy.    I guess I don't have a choice.

Thanks, scook!

Edited by greg54

Share this post


Link to post
Share on other sites

There were a lot more problems with Platinum than there are with CbB.

CbB started out with the unreleased code for Platinum 2010.11 and has been continuously improved since.

CbB installs as an upgrade to Platinum. The DAW, ProgramData, Cakewalk Content and user directories are separate from Platinum. The shared utilities are updated to the latest versions.

Leave Platinum installed. All the Platinum content and plug-ins will be available in both Platinum and CbB.

Follow these instructions to install CbB using BandLab Assistant.

 

 

 

Share this post


Link to post
Share on other sites

Good advise as always and I will add that for me a lot of buggy issues have all disappeared as they upgraded CbB. I used to have to save after every change for fear of Cakewalk freezing up. It's latest version is definitely the most stable, solid version ever. I could never go back to Splat. It was not stable for me. 

And your issue with vocals going weird after too many takes needs to be looked at. It sounds more of a driver issue than DAW. 

Share this post


Link to post
Share on other sites
1 hour ago, John Vere said:

And your issue with vocals going weird after too many takes needs to be looked at. It sounds more of a driver issue than DAW. 

Not after too many takes, but with excessive picture cache build up.    Years ago I contacted Cakewalk about that (before they went belly up).  They told me others had said the same thing.  They're the ones who told me to do a clean install.  That was years ago and I didn't remember how to do it.    So I'm not the only one who has experienced this.  

And when I did do a clean install, all my issues went away.

Share this post


Link to post
Share on other sites

I followed the directions and installed CbB Assistant.   It wouldn't open.   I tried everything... and nothing.  So I had to uninstall it.  

Before I reinstall it, is there something I missed or should do?

Share this post


Link to post
Share on other sites

Finally got it installed.  Not sure why it wouldn't install before.  Anyway, so far so good....

Share this post


Link to post
Share on other sites

That was the hard part.

As of this release updates to CbB no longer rely on BA.

 

Share this post


Link to post
Share on other sites

I've often read on the forum ( old one ) that you should clean out your picture cache every now and then. I have never done this myself and have never really had any issues. This currant set up I'm using is over 5 years  since I re did the OS and Hard drives. 

Just looked into this and the information is dated. The W10 Task Scheduler does not seem to have a add scheduled task option. Might be because I have the Home Version. 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...