Jump to content
dougalex

Zoom "center on cursor" bug

Recommended Posts

I like the zoom behavior (Ctrl + Left/Right arrow) being "if cursor is visible, zoom centers on cursor". (Yaaay!)

HOWEVER when using ALT + mouse wheel to zoom, it does not behave that way (and I think it should, to be consistent).

Share this post


Link to post
Share on other sites

Zooming ALT+mouse centers where the mouse pointer is positioned here as expected. I don't like it that when I'm zooming out being somewhere close to the start of a project (zero) I'm loosing the position and it's not going back when zooming back in straight after. But other than that zooming with mouse is working fine for me. Did you check your mouse wheel zoom options?

Share this post


Link to post
Share on other sites

I just tried again based on your comment.

Mouse wheel zoom option fixed it. Needed to select "Zoom in at Now Time". Thx!

Only weird thing is: The other option "Zoom in at cursor" does not seem stay "at the ruler time where my cursor is".

Share this post


Link to post
Share on other sites

I just remembered that I'm not on the latest Cakewalk release. And there was probably some kind of an update to the way zoom works. You'd have to go check in the release notes if there is a change or are any new settings added recently.

EDIT: there was a change:

Quote

Option to center Now Time when zooming with the keyboard. The Track view Options menu has a new 'Center on Now Time with Keyboard Zoom' option that centers the Now Time when zooming with keyboard shortcuts (CTRL+LEFT ARROW and CTRL+RIGHT ARROW).

but it's for zooming with keyboard 🤔

Edited by chris.r

Share this post


Link to post
Share on other sites

Alt+MouseWheel zoom in Track View isn't working consistently for me. I have the options set to "Zoom Horizontal At Cursor" but sometimes it works and sometimes it doesn't.

Of course, having written this out and gone back to Cakewalk to make sure I can reproduce, well, now it's working as expected. But i know as soon as I post this and go back to actual work in the Track View, it will happen again. I will report back here if it does.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...