Jump to content
  • 0
Ronman

Audio export doesn't respond to faders

Question

Situation:  a MIDI track with a single instrument track as output.  No effects.  No bus.

a) When I export audio, the levels are too high.  Adjusting the trim on the instrument channel or master has no effect.  Neither does adjusting faders on either instrument or master.  It's like it wants to set its own, very hot, levels.  Meanwhile, normal playback is fine.

b) How do you cancel export to audio?  Once started, I'm having to wait until it completely finishes rendering before making any changes.

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

If playback is OK in the DAW, the problem may lie in the software use for playing the exported file.

One way to test this is import the file into a new project and play the clip. If the levels are OK, it is the playback software. If the levels are bad i the DAW, then the levels need to be changed in the project.

The gain on the audio tab in the inspector for an instrument track affects record clips only. It does not affect synth playback

 

There is a cancel button to the right of the progress bar (B in the image below) in the transport module when exporting. If exporting a single track, it likely won't get the cancel request until after the track is rendered.

ControlBar.06.25.png

 

 

 

Share this post


Link to post
Share on other sites
  • 0

scook, Tnx for the quick reply.

a) The meters are pegging, in the red at the loudest points, when rendering.  But safely in the green during playback.  I pulled down the fader in the Navigator for the instrument, no effect.  (Also, as before, the MIDI channel and instrument channel faders and trim have no effect.)

It's not the play software because I'm using Audacity and Windows Media, and  with Audacity I have lots of control over normalization, can see clipping in the waveform, etc.

I'm assuming it's the output volume on the VST instrument itself, but before I can test that, a wrinkle; no audio at all:

 

b)  That works to cancel rendering!  However, it also silences playback audio for some reason, playback is then silent through meters are moving and output device is unchanged.  In fact, after canceling the render now audio is silent for the entire system, though Windows Settings shows everything routed to the right place and system volume is up.

Share this post


Link to post
Share on other sites
  • 0

It might help to see an image of the track headers. Especially the routing details.

There are two basic track types in Cakewalk - audio and MIDI tracks.

An instrument track is a hybrid of one audio track and one MIDI track.

A separate MIDI track is not necessary if the synth is configured to use an instrument track.

 

 

Share this post


Link to post
Share on other sites
  • 0

scook,

As you can see, the top two tracks are muted.  It's the Synthogy Ivory II (piano)  that's creating the problem.  The two midi tracks are linked.  I'm trying to click the top piano icon on the Ivory track to bring up its instrument interface and play with the level, but it no longer comes up like it used to.  (The muted instrument, a Garritan CFX piano, does come up with its interface.

For good measure, I'm attaching an image of the console, too.

Capture.PNG

Capture.PNG

Share this post


Link to post
Share on other sites
  • 0

While routing track 3 to the same synth as instrument track 4 uses works, it may be clearer, for now, to drag the MIDI data into the instrument track. As noted above, a MIDI track is not necessary when using an instrument track. The instrument track can handle all communication with the synth.

If the event filter MFX plug-ins are doing something, they may be placed in the instrument track MIDI FX rack.

The MIDI FX rack is located on the MIDI tab in the inspector for track 4.

Once the data and plug-ins are moved, delete track 3.

If you prefer having two tracks, one for MIDI and one for audio - after moving the data and plug-ins to track 4, right-click the track header near the track number and icons and select "Split Instrument Track"

Might want to archive tracks 1 and 2 for now.

 

  • Great Idea 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Kevin Perry's solution works.  At least visually, using Audacity to look at the relatively small waveforms in the output file.  Can't audition it though, without closing Cakewalk because it has a habit of taking over my audio drivers, causing external players to fail...sometimes.

I'd still like to understand scook's solution, though.  When I select all in track 3 and drag to instrument track 4, the visual changes as if it's done, but if I look at it with Piano Roll there's nothing there, and nothing plays.  I tried dragging with all the different options, Blend, Overwrite, etc.

Edited by Ronman
clarity

Share this post


Link to post
Share on other sites
  • 0

May be easier with a new project

  • create a new project,
  • add Ivory2 using an instrument track then
  • copy and paste the MIDI data from the old project into the new project instrument track.

 

 

  • Great Idea 1

Share this post


Link to post
Share on other sites
  • 0

scook,

It works if, instead of copying by dragging from a midi track to an instrument track, I select all then Edit->Copy Special and then, in the instrument track, Paste Special.   Doing this to both instruments, I was able to delete the two midi tracks, and now I'm down to just two instrument tracks.  Much cleaner.

Kevin Perry's solution above is still necessary to get output levels that follow the faders and don't clip.

Thanks, guys, this is starting to feel like a workflow.

Share this post


Link to post
Share on other sites
  • 0

Two major wrinkles remain:

a) I can't play both instruments simultaneously from an external midi controller.   I can select one or the other instrument by clicking the instrument name, which highlights in yellow, but not both at the same time.  When I had separate midi tracks linked to the instruments, I could do this, but there was just enough delay between the midi tracks to cause phasing problems.

b) Click back and forth between the instruments, selecting one and then the other a couple of times, and Cakewalk crashes.  It takes 6 minutes to reload everything since the instruments both use gigabytes of sample data.  But they sound glorious played together.

  • 12Gb RAM
  • CPU is an I7 950 with 8 virtual cores
  • S/PDIF digital audio output.

 

Capture.PNG

Share this post


Link to post
Share on other sites
  • 0

Turn off Always Echo Current MIDI Track and take manual control of input echo.

If all you want to do is play both synths using the same data, record one instrument then copy the clip(s) into the other instrument track making sure to link the clips (an option in paste special). Linked clips allow edits to propagate to both tracks. Clips may be unlinked at any time.

Streaming samples my reduce the load on the PC. This is configured in the plug-ins that support the feature.

It is also a good idea to post separate threads for unrelated topics. Adding multiple topics in a thread does not help other users looking for solutions.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

This works for simultaneous play from an external midi controller.

I had already done the paste special with link, so that's good.

I'm not seeing a specific streaming samples option on my instruments, but the Synthogy Ivory has an "offline processing mode" of "faster", and the other piano allows reducing the buffer sizes, which I may experiment with if needed.

I don't want to paste your reply in another thread without your permission, but will do so if you like, copying the diverging-topic part of this thread to a new topic.

This forum is one of the best aspects of using Cakewalk.

Share this post


Link to post
Share on other sites
  • 0

Don't worry about creating another thread for topics created in this one.

Going forward consider creating new threads for new topics.

Everyone has my permission to quote my posts in this forum.

 

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Ronman said:

I'm not seeing a specific streaming samples option on my instruments, but the Synthogy Ivory has an "offline processing mode" of "faster", and the other piano allows reducing the buffer sizes, which I may experiment with if needed.

It may go by different names, I suspect large sample-based pianos stream samples. Certainly the one that has a buffer size setting sounds like a streaming setting. Synths that do not stream load all samples into memory at once and typically do not have any options at all for buffering.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...