Jump to content

Cannot find EZ Drummer

Recommended Posts

Hi all,

Let me start by saying I've used both products for years without any issues, Sonar (Okay, Bandlab now) and EZ Drummer.

I recently downloaded a couple of midi packs over on the Toontrack site and it seems my problem began then.  The plugin scan kept freezing on me whenever it tried to load EZDrummer. (I'll call it EZD from here on out).

I fixed that issue by running as an administrator and rescanning but now the situation has gone from bad to worse. Rather than freezing when it tries to scan, it goes through the scan but when I attempt to add EZD to a midi track, I can see it in the list of instruments but when I click to add, it says “MIDI ONLY”. It will create a new blank MIDI track not an instrument  track with EZD attached to it.  Oddly, I can see EZ Drummer in the list of available instruments but it doesn't appear in the list of available instruments. I believe it's in the list at the top of the drop-down menu only because it's been used in the past.


 For this example, I added a blank project using the most basic template so there's no conflict with any other instruments or anything of that nature. You can see from the screenshot, I’ve highlighted track 2, which is a MIDI track. I right-clicked and  chose “Insert Instrument” from the drop-down menu.






The following opens when I choose “Add Instrument”, which is the behavior I'm accustomed to. So  far so good...



This second image above shows the “Add Track” popup. In it, I can choose from the MIDI instruments installed on my computer and also choose my input, etc. Once I choose the instrument from the drop-down I then hit "Create". It is supposed to create the instrument track. The next image will show what the drop-down menu looks like. As you can see, EZDrummer is located in this menu. However, this is only because it has been one of the more recent instruments used. It is supposed to also appear under the “Uncategorized” menu which I will click next.




As you can see here, it isn't in the "Uncategorized" menu either. I checked every menu here, including the "Drums"  but it isn't in any of them.




If I choose EZD from the menu at top, it creates a track but just a MIDI track without an instrument attached and the “Instrument” shown in the “Add Track” menu shows “Midi Only”. It’s supposed to show the instrument.




To recount what I’ve done so far, I uninstalled and reinstalled EZDrummer using the Product Manager, making sure I had the latest version of Product Manager installed as well.  I verified that it shows Installed in Product Manager afterward. I ran Sonar as administrator. I’ve tried both an existing track that should have had EZD on it and tried working with a new one to ascertain whether or not a glitch or something on an individual project could be causing it. EZ Keys is installed and working fine so I know the Toontrack Product manager is working okay. I’ve scanned for new plugins after reinstalling and the VST scan shows EZD being scanned with no problem. I ran this scan from both the “Plugin Manager” located on the “Utilities” menu in the ribbon above and by going to “Edit > Preferences > VST Settings and scanning from this menu. I  verified  that the standalone version of EZD  works just fine.  I also made sure other  MIDI instruments are working.  I verified that I am using ASIO drivers in EZD and that it is running from my audio interface. I have plenty of space on my SSD hard drive which is only about 20% full. I’m not out of memory or anything. I’m running dual 6 core Pentium I-7’s at 3.2 ghz and DDR-4 32 GB RAM running Windows 10 Home 64-bit. 


 I reached out to Toontrack but they have only email support so I'm hoping someone here may have an idea. Any help would be greatly appreciated!






Share this post

Link to post
Share on other sites

At the top of the plug-in is the most recently used section. It really has nothing to do with what plug-ins are available at the moment. It simple shows which plug-ins were last used.

The section with the plug-in categories is built from the currently available plug-ins and EZD is not there.

I doubt running as administrator will make any difference. EZD should scan and work without admin rights. At least it does on my machine.

Hopefully the 64bit version of EZD was re-installed and where ever it was installed is in the VST scan path. The 32bit version of EZD does not work in 64bit DAWs.

Assuming the correct plug-in is installed and in the scan path, from preferences run a VST Reset with "Generate Scan Log" enabled.

If the plug-in does not show up review the scan log.


  • Like 1

Share this post

Link to post
Share on other sites

Thanks guys! I found it using Nigel's suggestion. It was excluded. No idea how that happened. Other than downloading new midi packs from them nothing had changed. I appreciate it! And I was right about one thing. I got help here much quicker than through Toontrack's email support. They really need to do something about that.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...