Jump to content
Josh Wolfer

Bug: Comps make X-fades go bananas

Recommended Posts

Posted (edited)

I'm calling this a bug, because there is no way that this could be considered by-design (I hope).

I do a lot of editing and comping. If you have a bunch of comps in the take lanes and you pick and pull from different takes and then collapse down to the main track and slide clips around and x-fade the edge, the X fades go bananas (best way to put it). All the hidden,  UNUSED clips in the comp lanes still affect the USED clips, making the x-fades completely non-sensical. Super frustrating. 

I've tried this with both "Display muted clips in the parent track" on and off and the behavior is the same. 

What I have to do, is after I've decided which comped clips to use, I have to go and complete delete out every other take and then collapse them down and finish editing. This completely defeats the purpose of having comp lanes for future pulling of clips if I change my mind later. 

It's simple, once I've chosen the clips from the various take lanes and collapse the track, all my edits to clips should only affect the clips I've chosen to work with. 

This is incredibly easy to reproduce, but in case it's needed, here are screen shots of the issue: 

Choose some comps:

image.thumb.png.d49b45ae55a44b00f70a56de5232eddf.png

I then select a clip that I want to nudge a hair: 

image.thumb.png.12b3bf50674c9bb914a98a42b903d36c.png

When I nudge it to the right, the starting cross fade is complete jacked up. It should have only changed the ENDING fade, since now there is overlap with the adjacent clip to the right. 

image.thumb.png.4c31674a81b27803f9da987413c256e0.png

To see what's happening, expand the comp lanes back out:

image.thumb.png.a24628e3b9a9a4ad37951c4803a4c954.png

^^^ what is that shenanigans? Those other ghosted takes should NEVER affect the master comp. 

you can see that Cakewalk thinks there is overlap between clip "4" and clips "record 98" and "record 99". And thus it's jacking up clip 4's starting x-fade.

 

 

 

Edited by Josh Wolfer

Share this post


Link to post
Share on other sites

This seems to be the current state of the take lanes. If you manipulate anything in the master track then it can mess up the takes and the cross-fades.  Personally, I don't like that it does this but that is the way it works. In another thread it was said to slip-edit (move the audio in the take lane) rather then moving the clip in the master.

Another way is to copy your comped clips into a new track and delete all the take lanes. Then there is nothing underneath to mess them up.

Share this post


Link to post
Share on other sites
Quote

 In another thread it was said to slip-edit (move the audio in the take lane) rather then moving the clip in the master.

This doesn't work well in general. The clips still act very odd when editing them in take lanes. Especially trying to dial in nudges and fades. It ends up creating tons of extra edits all of the place that aren't necessary and just end up fragmenting the heck out of everything. 

Quote

Another way is to copy your comped clips into a new track and delete all the take lanes. Then there is nothing underneath to mess them up.

Yeah, which kind of defeats the purpose of having take lanes with a master comp within a single track. I can do this as a janky work around, but it's kind of silly. 

Share this post


Link to post
Share on other sites
Posted (edited)

I agree that the work arounds are not that great. I can slip edit (Move the audio within the frame of the clip) in the take lanes fine. However, Moving clips or changing the size of the fades in the take lanes does not work well for me.

Edited by reginaldStjohn
  • Like 1

Share this post


Link to post
Share on other sites

We'll look into this.

For the moment, a workaround is to disable Autocross fade when nudging on the comp track.

The thing is though, once you've nudged a clip the cross fades no longer make sense. The clip you've nudged has now overlapped the adjacent clip far more than a normal crossfade, so you'll have to adjust the fade manually. This is especially true when dealing with clips in multiple lanes.

nudge_xfade_workaround.gif

  • Like 1

Share this post


Link to post
Share on other sites

@msmcleod

Thanks for looking into it. I use Cakewalk a lot and the comps are one thing that's quite challenging for my work flow. While you're at it, I'd love to see it where after you collapse a track with comps, the ghosted clips are invisible and have no interaction. 

There is an option to make ALL clips that are muted disappear from track view, but I really don't want that. I need muted clips to continue showing as ghosted and I'm constantly moving and muting clips around (film sound editing) trying things out. So I don't want all muted clips to disappear, just the ones that are part of unused comps.  Hope that makes sense. 

Cheers!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...