Jump to content
Goodsound

No sound output with plug ins

Recommended Posts

Hello

I have sound output when I load a demo song.

I also have sound output when I choose the GSM piano.

But when I choose a plug in out of the synthesizer rack, it doesn’t matter if it’s one that came with cakewalk or a third-party plug-in, my loudspeaker remain silent. I can see that the plug in  is receiving midi notes as there are lights blinking on the screen but no sound output.

Can anyone help a newbie? Thanks.

Share this post


Link to post
Share on other sites

Have you checked to see if any tracks including synth tacks have been marked as Solo ? It has caught me out on a number of occasions.

Share this post


Link to post
Share on other sites
On 7/11/2020 at 1:16 PM, brandon said:

Have you checked to see if any tracks including synth tacks have been marked as Solo ? It has caught me out on a number of occasions.

Checked, but it wasn‘t due to solo (all turned off).

It must be something with the routing of the sound. Midi tracks work fine, only plug ins remain silent.

Share this post


Link to post
Share on other sites

I presume that GSM piano is TTS-1. You get sound, so that is encouraging.

You have to be doing something wrong when you add an instrument.

Do a screenshot of the track containing the instrument. A close up so we can see what it says.

With that track selected open Inspector and do a closeup screenshot so we can see what it says.

Here is what I get if I insert Cakewalk's True Pianos.

The instrument track.

2035376145_TruePianosInstrument.jpg.cf2ca90f1c0e8c146e6624aff153d792.jpg

 

Inspector. 
Track 3 shows Input, I, is TrPns.... Obviously True Pianos.
And Output, O, is Master, the Master fader in the console.
And Master Output, O, is going to my speakers.

586174170_InspectorforTruePianos.jpg.c1adc1aa91a5f8738730cf270f784038.jpg

Open the Piano Roll View, click on the keyboard, you should get sound.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

OK here are the Screenshots

RMT25V10 is my Midi Keyboard

RLTKDORHD is the Soundcard of my PC

 

image.jpeg

image.jpeg

I only hear sound on Track 2 Midi, not Track 3 SI Piano ... 🙁

Edited by Goodsound
Typos

Share this post


Link to post
Share on other sites
8 minutes ago, Goodsound said:

image.jpeg

I only hear sound on Track 2 Midi, not Track 3 SI Piano ... 🙁

Track 2 is a midi track. Are you routing Track 2 to a software synthesizer or an external sound module?

Share this post


Link to post
Share on other sites
Posted (edited)

I do not intentionally route the signal in any way. As a complete beginner I opened just a basic empty project and open a Midi track and open another track for the available plug-in instruments to test.

So  the only midi sound we hear is from the PC itself. No external sound module. The only external thing is my Novation Remote25  keyboard (and speakers).

Edited by Goodsound
Typos

Share this post


Link to post
Share on other sites
Posted (edited)
15 minutes ago, Goodsound said:

I do not intentionally route the signal in any way. As a complete beginner I opened just a basic empty project and open a Midi track and open another track for the available plug-in instruments to test.

So  the only midi sound we hear is from the PC itself. No external sound module. The only external thing is my Novation Remote25  keyboard (and speakers).

I asked because I have never had a midi track generate sound unless the midi data was routed to a sound source that plays midi data.  Maybe by default it is pointed to the MS sound source.  Can you post a screen shot that shows the midi widgets for each track? [I, O, C, B, P]

image.thumb.png.c6081bd82386b918baa965b99e7f3e17.png

Edited by User 905133
to add an image I hope helps show the types of tracks and the routing for each I have used here.

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry I couldn‘t find Info about how to open the „Midi Widget“.

The documentation pages do not help me as a beginner. 🤷🏻

This is als close as I could get:

image.jpeg.d0268a11571a9bcb0749a96201762046.jpeg

Edited by Goodsound
Added image

Share this post


Link to post
Share on other sites
Posted (edited)

In your first post with screenshots: Track 3 is the instrument audio. The I dropdown must be changed to the SI Piano output, not your MIDI keyboard.

In the MIDI track, track 2,  you select RMT25V10 as Input. Output is the SI Piano.
Track 3 is the instrument audio. The Input is the output of the SI Piano. (It should have been that automatically, but never mind.) The Ouput is Master.

So, keyboard goes to MIDI track (2), MIDI track goes to instrument, instrument audio (3) goes to Master.

Put the other way round:
     MIDI track (2): input is keyboard, output is instrument.
    Instrument audio track (3): input is output of instrument. output is master.

 

Edited by Nigel Mackay
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for posting new screen shot. It confirms what I thought--that the audio you heard came from the Microsoft Synth which was serving as the default midi device to play the audio.

image.png.f644107836f1989def9f9a91b8177ea5.png 

Track two shows the Output [O] Track Control Widget is routing the midi data to "1McrsftG..." which is the Microsoft GS Wavetable Synth.

As Nigel pointed out, to have the midi data sent to the SI-Electric Piano software synth, you need to route the output of that track to the SI-Electric Piano.  There are a number of ways to do that.

 

-----------------------------------------------

P[references]:  image.png.a68c3132764cf81112eca5429b224fd5.png

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

The simplest way to start out with synth tracks is to insert  them as a simple instrument track.

One way (and there are several) is to simply go to the Cakewalk  top menu bar and select Insert> Soft Synth > choose any synth from the pulldown menu. Then when greeted by the "Insert Soft Synth Options" panel, simply select "Simple Instrument Track" and click OK.

The simple instrument track automatically sets up your MIDI & audio track as one combined instrument track, with all the MIDI & audio routing taken care of.

Eventually you may want them as separate tracks , but for starters I do  recommend this method first! A synth requires both tracks if used separately.

Edited by abacab
  • Great Idea 1

Share this post


Link to post
Share on other sites

Hey folks I had finally time to test this again and it wasn’t successful. ☹️

I tried also the way abacab suggested, but no sound output.

There still must be one wrong configuration but I have no clue.

Thank you for help.

 

 

C3242FC5-A32A-4F54-854B-5E27D7F8D31D.jpeg

10ED7B41-DCF7-4A13-8120-C35561EFC635.jpeg

Share this post


Link to post
Share on other sites

There is audio visible on the meter in a few of your screenshots. Routed to Master.

 

1297592745_2020-09-1214_08_21-Window.jpg.73b6df18cb3300cb561f5637bab43afa.jpg

In this screen shot There is a broad strip above Modules Strips Track ....
Above that is a thin strip. Click and drag that up, so you see this:

1534151941_2020-09-1214_10_41-Window.jpg.ad764966fd7ee454938ac3645fcc2b3e.jpg

Then just below the meter on the Master strip click and drag it downwards to make it bigger.

535767969_2020-09-1214_12_52-Window.jpg.867463e0e093f5d0a862c6e0b71c3032.jpg

When you play notes and the meter shows activity on the track , do you see meter movement on the Master strip? What is it routed to? O. Mine says SpkrRHD...

On the control bar at the top, to the right of the time display, are a play button, a record button, and a metronome button. Click the record dot. This makes the metronome sound when recording.
Arm any one of the tracks for recording - click the red button.
At the top, click Record - the red button with funny squiggles on it.
You should hear the metronome.
 

 

 

Share this post


Link to post
Share on other sites

I'm having the exact same issue, and I'm completely at a loss for what's wrong.

As you can see... I'm generating signal from the VST's virtual keyboard. It's showing that things are working. We're seeing life on all the meters... but no sound is coming out.

Screenshot 2020-09-16 113221.png

Share this post


Link to post
Share on other sites

...oh, nevermind. After a day and a half of struggling with this, I finally found:

Edit->Preferences->Devices/Driver Settings

Among other things, running the Wave Profiler and mucking with the checkboxes next to the available outputs seems to have done the magic trick.

¯\_(ツ)_/¯

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...