Jump to content
Kenrout

audio interface issues

Recommended Posts

Hi, hope someone can point me in the right direction.  I am brand new to the worlds of DAWs, have installed cakewalk & want to record guitar & vocals.  My PC has win 10, 64 bit, my soundcard is Soundblaster ZXR & io have a focusrite scarlet 2i2.  I am having problems setting the audio devices (do i need to set input 
& output drivers to focusrite or soundblaster) when i set to focusrite it seems to record but i can't hear anything, when i set to SB i don't know if it is performing properly.  I realise that for many of you this question may be ridiculously easy, apologies but i don't know the answer and i am keen to learn.  A lot of the tutorials go at 100mph and assume you have prior knowledge.... not the case with me.  Any help you can offer will be greatly appreciated, TIA

cakewalk.JPG

Share this post


Link to post
Share on other sites

Kenrout welcome to the forum

 

under-device setting select ASIO has driver mode,then on [device]-select focusrite un-check creative SBZ

Edited by martsave martin s
  • Like 1

Share this post


Link to post
Share on other sites

Hi Martin, thanks for the reply.  so i have input drivers & output drivers, are you suggesting that i need to set input drivers to focusrite (i have to uncheck all other options before doing this) and then set output drivers to the focusrite also?? incidentally when i select focusrite for input the only option i can select for output is also focusrite, i cannot select any other option, (or i can leave that section unchecked) which of these are correct?? many thanks.

Share this post


Link to post
Share on other sites

Yes. Both the input and output to focusrite. Then cw doesn't feed anything into creative sb. Just remember to hook your phones/speakers to focusrite to hear the music.

Share this post


Link to post
Share on other sites

ok, thanks.  i currently have my phones connected to the front monitor port (and can hear only when recording) but not playback - silence!! there are left & right outputs (1/4") on the back, should i wire these into my speakers or should the front monitor provide sound for playback??

Share this post


Link to post
Share on other sites

I'm not sure if you mentioned it.. but you need to install the Focusrite Scarlet driver. That can be found on Focusrite's website.

 Once you install that, you will want to uncheck your soundblaster sound card from this preference menu. You will want to select ASIO as your driver mode and then check mark next to your Focusrite input/ouput.

Share this post


Link to post
Share on other sites

Great advice here from everyone.

Go into your Windows Sounds and see if the Focusrite is the default playback and record device. I've had DAWs in the past that struggle with having more than one audio interface. Making sure my pro device was the default helped me.

You also want to make sure the correct Focusrite channels are selected in CbB as the master outs, since Focusrite will have more than one channel to choose from.

Edited by razor7music
  • Great Idea 1

Share this post


Link to post
Share on other sites

I don't think it's been mentioned yet, but using the ASIO driver, arguably the best driver for audio recording, limits you to only one device. You will have to record and monitor from the Focusrite.

Share this post


Link to post
Share on other sites
5 minutes ago, 57Gregy said:

I don't think it's been mentioned yet, but using the ASIO driver, arguably the best driver for audio recording, limits you to only one device driver. You will have to record and monitor from the Focusrite.

Fixed. A few manufacturers support multiple devices sharing the same driver.

Share this post


Link to post
Share on other sites

Hi guys, thanks for all the info so far, have adjusted everything according to your advice.  when i select focusrite usb asio input 1 as my input driver i can only select the same on the output side (or nothing at all) this seems to stop my speakers producing sound as the creative SB cannot be selected, therefore i cannot hear anything from playback not even via headphones plugged into monitor port on focusrite.  Is there a way round this or i am missing something really basic???

Share this post


Link to post
Share on other sites

If your input in CbB and your master outs in CbB are both correct, then make sure the track you're inputting/ plugged into has the input monitoring button enabled.

I also see this setting, but that's probably already done. Might not hurt to check it too.

Share this post


Link to post
Share on other sites

It looks like there is a 'direct monitor' button on the front and a  monitor knob to adjust how much input and output you hear. There may also be a software mixer to set your ins and outs.

Share this post


Link to post
Share on other sites
13 hours ago, 57Gregy said:

It looks like there is a 'direct monitor' button on the front and a  monitor knob to adjust how much input and output you hear. There may also be a software mixer to set your ins and outs.

I thought about the software mixer solution too, but I didn't find any for the Scarlett.

Share this post


Link to post
Share on other sites
14 hours ago, Kenrout said:

Hi guys, thanks for all the info so far, have adjusted everything according to your advice.  when i select focusrite usb asio input 1 as my input driver i can only select the same on the output side (or nothing at all) this seems to stop my speakers producing sound as the creative SB cannot be selected, therefore i cannot hear anything from playback not even via headphones plugged into monitor port on focusrite.  Is there a way round this or i am missing something really basic???

Personally I'd recommend you keep your Windows sounds and your DAW sounds separate. Avoids sample-rate and exclusivity issues when you're running CW and Windows decides it needs to beep for some reason. Just plug a cheap set of PC speakers into the Soundblaster, and hook your nice speakers/headphones to the Scarlett.

If for some reason you want the Soundblaster to go to your good speakers (e.g. gaming, videos, etc.) I'd get a cheap Behringer mixer or whatever, plug the outputs of both the SB and the Focusrite into it, and send the output of the mixer to your speakers.

  • Like 1

Share this post


Link to post
Share on other sites

Hi, thanks for all the advice.  I have hooked up a small mixer with both inputs in to the mixer & output to my main speakers.  I can now hear audio live & recording through speakers & phones.  I still cannot hear playback through any source, it feels like i have got a setting wrong.  The strange thing is when i playback stuff that i created and imported from bandlab it plays back fine?? any ideas please.

Share this post


Link to post
Share on other sites

In the past Scarlett 2i2 and solo's didn't use the mix control software, not clear about the 3rd gen. 

But I have the 6i6 and they work the same. I have also set a friend up with a Solo. This example we will use a guitar and vocal set up. 

Make sure you have the very latest driver.

Use ASIO only do not use any other driver mode for overdub recording or timing will be off. 

You need to plug the 1/2 outputs into your studio monitor system. If you don't have studio monitors get some.  Computer speakers will not give you accurate mixes.

In a pinch you can plug computer speakers into the headphone jack using an adaptor. 

Use the direct monitoring option other wise you will hear a small delay due to system latency.

Plug in a guitar to input 1 set it for instrument ( depending on guitars system) . Set the input gain below where it peaks. You don't want to ever see it peaking. This is the level for your recordings. Your DAW's level and volume controls have no bearing on recorded levels. 

First plug in some headphones and adjust the level to hear guitar.

Open Cakewalk and from start screen select New project and the 4 track option. 

Set track 1 input to LEFT input 1

Set DAW to record standby and observe meter to check it is not peaking, record a few minutes or a song. 

Playback what you have the sound will automatically go to your 1/2 outputs and your headphones when you use this template and you have selected the Scarlett as you only in/out in preferences.  

Now plug a mike into input 2 and set levels as above. 

Set track 2 input for RIGHT input 1 set in record standby check meters while sing loudly. 

Now  play the song  while practicing your singing. You should hear the playback in either the headphones or the monitors ( 1/2 out)  as well as your voice. If the playback is too loud with the 2i2 your stuck with turning down the master buss or the guitar track ( or creating a headphone buss) . Most interfaces have a input/computer adjustment control but the 2i2 is lacking this important feature. 

This should have everything working properly. 

You can make up for it's short comings by using a mixer but the mixer needs to be configured so you can monitor playback without it be re directed back into the recording output. Tell me which mixer your using and I could help with that too. 

 

Edited by John Vere

Share this post


Link to post
Share on other sites

Hi John Vere, thanks for the reply.  I have Focusrite control supplied with the scarlet 2i2 (not quite sure how it should be used??) or what it is for.  I have an old Behringer Eurorack UB802 (not sure if i have plugged the inputs & outputs in correctly)?? any further assistance would be great.  I will try to follow your setup & see if it makes a difference.  I have tried setting as you said but when i set input to right input 1 (using focusrite) and attempt recording it does not pick any sound up.  Any tips greatly appreciated....... i just want to get going!!!!

Share this post


Link to post
Share on other sites

Sorry I made a error which I will correct,  I said Right input for input 1 when it is the opposite. The way most interface show as inputs is using this as example.

Left - name of interface- mic input 1 =  Input 1

Right - name of interface-mic input 1 = Input 2 

Stereo - Name of interface - mic input 1 = Stereo both inputs used, this also automatically creates a stereo recording in your track. 

If you have more than 2 inputs it would carry on using only odd numbers 1, 3, 5, 7 etc. 

So 1 is for inputs 1 and 2,   3 is for inputs 3 and 4 and so on.  

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...