Jump to content
Eric Weinstein

MIDI Notes Recording Early

Recommended Posts

Hello fellow Cakewalk friends!

I have an issue where Cakewalk will place notes input via MIDI a split second before they were originally recorded. Even if I play precisely on a beat (using a clock setting of 120 ticks/quarter), it ultimately places them about 10-12 ticks before the beat. This was not an issue with any version of Cakewalk or SONAR previously (I've used Cakewalk since the early 90's). This is in a completely clean project - no plugs, VSTs, or anything else in the way. Basic MIDI from my keyboard via USB to the DAW.

Cakewalk seems to be overcompensating latency for the USB MIDI input, but I can't find any setting to correct it.

Thank you in advance for your expert assistance!

-Eric

Windows 10 64-bit, i5-4440 @ 3.10GHz, 32G RAM, SSD for system and data drives.

Share this post


Link to post
Share on other sites

I was recently going crazy about something similar, messing with all the latency and sync  options to try to fix it, until I found out that my problem got something to do with having the audio metronome set with a count in. Worth a try.

 

Share this post


Link to post
Share on other sites
6 hours ago, JoseC said:

I was recently going crazy about something similar, messing with all the latency and sync  options to try to fix it, until I found out that my problem got something to do with having the audio metronome set with a count in. Worth a try.

 

Has that been ever resolved?

Share this post


Link to post
Share on other sites
On 6/24/2020 at 1:44 PM, John Vere said:

Are you using ASIO driver? 

I am - the ASIO drivers that came with the AudioVox 1818VSL.

I've tried this via MIDI through the USB to the computer using the Yamaha USB driver (extremely old) and MIDI cables connected to the AudioVox 1818VSL itself. There is no appreciable difference in the latency.

 

Share this post


Link to post
Share on other sites

Under Preferences -> Audio -> Sync and Caching -> Record Latency Adjustment (samples), the only option in the drop-down is the AudioBox ASIO Driver.

I've tried various options on the Manual Offset (after unchecking 'Use ASIO Reported Latency', which is reporting at 4978) and it doesn't seem to have any effect. I've tried using positive and negative values across the -5000 to 5000 allowable range. I play simple quarter notes spot-on with the metronome, and it places them ~10 frames ahead of the beat.

I'm hoping there is just something silly that I am overlooking.

Thank you for your help!

-Eric

Share this post


Link to post
Share on other sites
Posted (edited)

If your ASIO driver report 4978 latency something is really f***d here.

Usually control panel for driver is having a setting, like 128 samples or whatever.

 

Preferences Project Clock what settings are you using there. You said 120 tpqn, but what else, like sync?

 

Further there are a number of things like ttsseq.ini settings which timestamp to use

"IgnoreMidiInTimeStamps=<0 or 1> Boolean 0 (disable) This line determines whether or not Cakewalk ignores any MIDI time 
stamping that a MIDI driver does. If you’re experiencing increasing 
delays between the time you play a MIDI note on a controller and the 
time you hear Cakewalk echo it, setting this line to 1 may help. Also, 
if you find that Cakewalk is recording MIDI data at a different time 
from when the data was played, setting this line to 1 may help. If the 
MIDI driver is using a different clock from Cakewalk, the time 
discrepancy increases the longer that the MIDI driver is open, so you 
need to tell Cakewalk to ignore the timestamp that the MIDI driver 
adds to the data (set the value to 1)."

 

Further, did you try and turn off latency compensation PDC button on toolbar

"The Live Input PDC Override toggle lets you disable delay compensation on live tracks, thereby removing the latency during 
playback and recording of such tracks. Since it's a toggle, you can quickly turn it on to complete your tracking at low latency, and turn 
it off when finished to hear the track compensated as normal."

Seemingly affecting if audio out is delay or not, worth a test if it makes a difference.

Some claim to have pdc off due to compensating for a delay heard so starting to play early. I usually am fine having it on, and just minimizing whatever causing delays.

 

But I would look at the basics like asio reported latency first, that is really off if saying thousands of samples.

 

Using mostly external midi gear I use Time Offset on midi tracks to adjust to delay in external devices to respond, so their audio will fall on the grid etc. Every synth has different delays, some respond on 128 samples, others on 400 samples.

Edited by LarsF

Share this post


Link to post
Share on other sites

I'd bet that the ASIO drivers for the PreSonus AudioBox 1818VSL are also an issue, although I am able to export a ton of tracks with lots of effects across the board without any problems. PreSonus pulled it off the market (which happens), but they also updated to the universal driver that doesn't entirely support the 1818VSL. This horked it up pretty good, and I had to overlay the old drivers and set everything back again.

When I disable all of the effects, use the PDC button (which I'm convinced is a placebo), remove the metronome count-in (as suggested by an earlier poster), and nudge the midi notes - it's tolerable.

Guess it's time to invest in a new external device...

Thanks to everybody for your patience and excellent advice. I've been with Cakewalk since 1992, so old habits are hard to break.

Thanks again!

-Eric

 

 

Share this post


Link to post
Share on other sites

If your ASIO driver report 4978 latency something is really f***d here.

Usually control panel for driver is having a setting, like 128 samples or whatever.

Not necessarily. That might be normal for that interface at a higher buffer setting.  That is the sum total of samples. 128 is a medium low setting,  I run my system at 256 and my total reported roundtrip is 1042 samples. 

My Tascam set at 256 buffer=  input  324  + output 1087 total reported RTL 

if set to 512 buffer it almost doubles = input 580 + output 1625 = 2205 reported RTL 

  On many low end interfaces there can also be hidden buffers. 

But none of that matters because if the driver is reporting the RTL correctly then Cakewalk adjust playback so that what you hear is put down in the correct place on the timeline. You can perform a loopback test to check your system is reporting correctly. use this tool  https://oblique-audio.com/rtl-utility.php

That said midi does not use your ASIO driver, It uses MME. There is no adjustment for midi timing offset as far as I know. The audio is involved with overdubs because your playing along with audio. 

 

Share this post


Link to post
Share on other sites
4 hours ago, John Vere said:

But none of that matters because if the driver is reporting the RTL correctly then Cakewalk adjust playback so that what you hear is put down in the correct place on the timeline. You can perform a loopback test to check your system is reporting correctly. use this tool  https://oblique-audio.com/rtl-utility.php

That said midi does not use your ASIO driver, It uses MME. There is no adjustment for midi timing offset as far as I know. The audio is involved with overdubs because your playing along with audio. 

 

And when you record do you monitor through Cakewalk - this would mean that your own performance is delayed according to RTL.

Many compensate by starting to play early intuitively, not hearing your own performance as it's played.

And if doing midi recording - the audio heard will also have the same delay if monitored. Latency for midi can probably be ignored.

So this is why I feel why OP midi arrive early - but a theory of course.

 

PDC, the added delay by plugins can be turned off - but not the ASIO buffers. So using external zero latency monitoring is a way to go, not monitor through Cakewalk.

I have 253 samples RTL(including AD/DA converters, 64 samples ASIO buffers) which I find acceptable for anything, doing audio in or midi in.

On former daw I used a RME Hammerfall with only optical ins/outs - which tricked me a bit, since coverters latency were not reported by ASIO at all. You had to calibrate this and set an offset also for audio clips to end up in the right spot. So that's an idea to look at if things do not turn up where expected.

 

Rambling a bit, all in the spirit to help OP...

Share this post


Link to post
Share on other sites
On 6/26/2020 at 11:38 PM, Eric Weinstein said:

I've tried various options on the Manual Offset (after unchecking 'Use ASIO Reported Latency', which is reporting at 4978) and it doesn't seem to have any effect

Wrong offset.  At the top of that page under synchronization there is a MIDI Timing offset. It is under the Full Chase Lock (which must be selected). Just be aware that the offset is applied to midi out ports also. So if you have any hardware synths you can end up chasing your tail.

I eventually reset the offset to 0.00 and went back to using nudge.

Share this post


Link to post
Share on other sites

I also experimented with the MIDI Timing offset with no luck. I'm also just going to deal with this via nudge. This seems to get progressively worse as time goes on and my projects get more complicated.

Thanks to everybody for your advice!

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hey Lars.. I never monitor at the back end of Cakewalk as for me that is a good 20ms or so. I have always used direct monitoring via my interface and have no issues with timing.  My Yamaha digital drums tend to put notes a bit ahead of the beat but I generally will be quantize anything midi so it is not an issue.  

Only time I don't quantize is a piano part played by a real piano player. And with the drums I sometimes like the way the snare sounds just a hair ahead like that, so I leave it alone. 

I'm all about music having a groove and a feel so am very picky about timing. I play the parts pretty dang close to where they belong and if my software messes with that I'm not happy. 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...