Jump to content
Adam Kinzel

Problems with recording e-drums using Cakewalk

Recommended Posts

Hey everybody!

I've downloaded Cakewalk by BandLab a few days ago, and have encountered an unpleasant surprise.

For the past 6 months, I've been using the Alesis Nitro Mesh Kit as my e-drum kit. I wanted to try and record my drumming and have found Cakewalk as a free DAW with good reviews, so I gave it a go. As my drum software, I use MT Power Drum Kit. The problem is that I record a song, which is originally 3:38 long and even though I start the recording the very moment I play the song (so it is the same length) when I'm done and I export the audio into wave, the file is just 3:30 long and when I import the sound into Sony Vegas and try to synchronize it with the original song, it does this weird thing where the longer the song goes, the more out of synch it gets. At the very beginning the snaps and everything is fairly on-point, however, a few dozen seconds into the track, the drums are severy out of synch with the song. I was thinking that maybe it had something to do with me not using an external audio interface, but then again, the track in Cakewalk is as long as it should be (it shortens only after export).

Do any of you have any advice as to why this is happening or how could I possibly fix it?

Very grateful

Adam

Share this post


Link to post
Share on other sites

Let's take it one step at a time:

What is your sample rate and bit depth in the Cakewalk Project?

Does the exported audio sound as expected, or is it raised or lowered in pitch (sample rate conversion issue?)

Are you recording MIDI data into a Cakwalk MIDI track, and driving an instance of MT Power Drum Kit VST as a separate Audio Track? Or did you create an "Instrument" track which is combined VST + MIDI data in one track?

It should matter either way but sometimes it is easier to debug if the MIDI and AUDIO are separate tracks. No matter.

Can you bounce the MIDI/Instrument to a new audio track, and verify that the audio, when SOLO'd, sounds as you'd expect? (Select the two tracks MIDI+VST or just the instrument track, and chose "Bounce To Track(s)" from the "Tracks" dropdown menu in the Track Pane

Having reviewed the audio, you can then chose File->Export -> Audio and select the new audio track as the source.

It would help to know what settings you used to perform the Export.

The length of the exported WAV could be different depending on what you have selected in the Track view, but that wouldn't explain the sync'ing problem.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...