Jump to content
John Bradley

Recording Automation generated by HoRNet AutoGain Pro VST

Recommended Posts

I recently picked up HoRNet's AutoGain Pro and AutoGain Pro Mk 2 plugins, which are automated volume-riders. Stick them on a track and they will monitor the difference between the track's volume and something else (another track, or a constant reference level). There'a a Gain parameter that is constantly moving up or down so as to keep the track output at the desired level regardless of the input signal level.

So far so good. But all attempts at recording that parameter have failed. I set the plugin to 'write automation' mode, and in CbB I set the automation write mode to 'overwrite' ('touch' or 'latch' do not work) for that track, create an automation lane for the Gain parameter, and set it to write.

If I hit play on the sequence, automation data is recorded by CbB. Unfortunately, it's all a constant "0.0db" value, even though the parameter in the VST is moving around. I know I'm recording the correct parameter, because if I set the VST to 'read automation', turn off write mode on the automation lane, and draw an automation envelope of some sort in the lane, the VST's Gain parameter (and track audio) responds accordingly to the drawn envelope.

---

The HoRNet guy responded to my support request with this:

thanks for contacting the hornet support-team;

I must admit I am not an expert of cakewalk but few DAWs (even cubase) have some kind of threshold level that removes automation below it.
Can you check in the settings and see if you spot it and deactivate it?

 

I can't find anything like that in the CbB docs. Any ideas?

Anyone out there using this plugin and gotten it to work?

Any other volume-rider VSTs out there that do work, in the sub $30 category?

Thanks!

 

Share this post


Link to post
Share on other sites

Just tested AutoGainPro v1.2.3 using the process described above.

The VST3 does not record automation

The VST2 does.

I am not aware of a threshold setting in CbB.

 

 

Share this post


Link to post
Share on other sites

I year later, I've come across this post as I was searching about how to make Hornet AutoGain Pro Mk2 work in Cakewalk.  Do you mind sharing with me how you got the VST2 to work?  I can get it to work intermittently, but I have to fiddle with the track automation selection in Cakewalk and then it just stops working.  Curious if you might have some insight.  Thanks in advance for any help you can give!

Share this post


Link to post
Share on other sites

Using v1.2.3 of Hornet AutoGain Pro Mk2 VST2 

  1. Add the plug-in into the FX rack of the track needing the effect
  2. Enable write In the plug-in UI
  3. Write enable an automation lane for the plug-in's Gain
  4. On the track used to control the level create a send to the plug-in

Start the transport

I did notice, the plug-in UI must be open in order to send data to the automation lane.

Share this post


Link to post
Share on other sites

Scook, Thank you!  This was very helpful.  I think my issue of it working intermittently was because I didn't consistently have the plugin window open.  Thank you so much!

Share this post


Link to post
Share on other sites

One more question - once it's written the automation and I change the plugin back to "read", I notice I can manipulate those gain envelopes and they have no affect on the actual audio.  I tried to copy the plugin gain automation and paste it in as volume automation, but that did not work.  Is there a trick to getting that gain envelope that is written to actually be reflected in the audio?

Share this post


Link to post
Share on other sites

The amount of the effect depends on the Processor section settings.

For maximum effect try

Min Gain = -12

Max Gain = +12

Gain Scaler = 100

Could also play with the Main attack and release values to exaggerate the effect.

Share this post


Link to post
Share on other sites

FWIW, I played around with the VST2 versions of both the regular and Mk2 versions and decided they were somewhat 'iffy' and unpredictable in their behavior. Stopped trying and wrote it off as a learning experience. But that was a year ago. Don't know if they've been updated since then, but CbB certainly has been, so maybe they work better these days.

 

Share this post


Link to post
Share on other sites

Although not the same plugins, I had something along the same line of thought happen the other day..

  But, as I look at the picture I posted of the situation, I don’t think it’s actually doing what I though it did.. because the automation should have started dead even with the track that’s suppling the send...

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...