Jump to content
Barry Seymour

Can't get keyboard input to SI String Section

Recommended Posts

I seem to be unable to set up SI String to accept input from my computer keyboard. I did it last month for a song I recorded, but now I'm trying to do it again and bless me but I can't get it to work! I even went back to my previous project and it's not working there either.

Here are the steps I take:

  • Right-Click and select "Insert Instrument"
  • Select "SI String Section" and click "Create"
  • VST appears. I can hear sounds when I click the keys with my mouse
  • I click the keyboard button at top right ("Give all keystrokes to plug-in")
  • I press computer keys. No sound.

What am I missing?

Thanks in advance for any help you can give.

Barry

 

Share this post


Link to post
Share on other sites

Okay, I found the Virtual Controller (thanks anyway, scook) but now when I hit keys it plays both the strings and the drum kit! I was able to freeze the audio from the drum kit to prevent that, but might there not be a better way?

Share this post


Link to post
Share on other sites

Turn off Always Echo Current MIDI Track and assume manual control of input echo then double check all the instrument and MIDI track input assignments.

Keep in mind when an instrument or MIDI track has input echo enabled and the input is set to None, CbB changes the input to "All Inputs - Omni" so the track has some input to echo.

 

  • Great Idea 1

Share this post


Link to post
Share on other sites
On 6/5/2020 at 9:08 PM, scook said:

Turn off Always Echo Current MIDI Track and assume manual control of input echo then double check all the instrument and MIDI track input assignments.

Keep in mind when an instrument or MIDI track has input echo enabled and the input is set to None, CbB changes the input to "All Inputs - Omni" so the track has some input to echo.

 

Sorry, I'm Mr. Analog Instrument, never knew much about MIDI. I am unsure of what you mean by 'check all the instrument and MIDI Track Input Assignments.'

But I created a new empty project with an eye toward learning; Just Drums and Strings. Here's what I understand so far...

  •  I have to set input to each track to Mini OMNI for the virtual controller to work
  • If I select a track, then the virtual controller records that track.
  • If I shift+Click the track NUMBERS, both are selected and VC input is routed to both. Gotta make sure I avoid that.
  • If I start recording, manually entering notes, the first few beats / notes are not captured / recorded. Any suggestions on that?

I tried setting the MIDI input to separate channels for each of the instruments, but then the VC didn't work. I suspect that's by design. I don't think the VC has a 'MIDI channel,' per se.

Am I barking up the right tree so far?

Thanks for your help so far....

Barry

 


 

Share this post


Link to post
Share on other sites

 

 

1 hour ago, Barry Seymour said:

I have to set input to each track to Mini OMNI for the virtual controller to work

Using the Virtual controller the following inputs work for both synths.

  • All Inputs - MIDI Omni 
  • All Inputs - MIDI Ch, 1
  • Virtual Controller - MIDI Omni
  • Virtual Controller - MIDI Ch. 1

The difference between these 4 input settings are

All Inputs accepts data from from all MIDI devices including the virtual controller

Virtual Controller accepts data from the Virtual Controller only

MIDI Omni accepts data from all channels from the specified device

MIDI Ch.1 accepts data from channel 1 only from the specified device

AFAIK, the Virtual Controller only transmits on channel 1.

FYI, SI plug-ins play all notes in the instrument's range regardless of their channel assignment.

1 hour ago, Barry Seymour said:
  • If I select a track, then the virtual controller records that track.
  • If I shift+Click the track NUMBERS, both are selected and VC input is routed to both. Gotta make sure I avoid that.

Just like recording audio, there is no need to select a track to record just click the record button. Also like audio, to hear the track while recording, input echo must be enabled. Again like audio if two tracks are set to record from the same input (in this case the four inputs identified above are effectively the same) they both will record the same data. Finally, if both are set to input echo they both will play whatever data is at the track input just like audio tracks.

 

1 hour ago, Barry Seymour said:

If I start recording, manually entering notes, the first few beats / notes are not captured / recorded. Any suggestions on that?

They should but it is common practice to leave an empty measure or two at the beginning of a project to allow virtual instruments time to prepare for data. SI series should not be that sensitive.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, scook said:

 

 

Using the Virtual controller the following inputs work for both synths.

  • All Inputs - MIDI Omni 
  • All Inputs - MIDI Ch, 1
  • Virtual Controller - MIDI Omni
  • Virtual Controller - MIDI Ch. 1

The difference between these 4 input settings are

All Inputs accepts data from from all MIDI devices including the virtual controller

Virtual Controller accepts data from the Virtual Controller only

MIDI Omni accepts data from all channels from the specified device

MIDI Ch.1 accepts data from channel 1 only from the specified device

AFAIK, the Virtual Controller only transmits on channel 1.

FYI, SI plug-ins play all notes in the instrument's range regardless of their channel assignment.

Just like recording audio, there is no need to select a track to record just click the record button. Also like audio, to hear the track while recording, input echo must be enabled. Again like audio if two tracks are set to record from the same input (in this case the four inputs identified above are effectively the same) they both will record the same data. Finally, if both are set to input echo they both will play whatever data is at the track input just like audio tracks.

 

They should but it is common practice to leave an empty measure or two at the beginning of a project to allow virtual instruments time to prepare for data. SI series should not be that sensitive.

Thanks for all the information. The pieces are slowly coming together in my fevered brain.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...