Jump to content
tdehan

How do I hear the FX effects in headphones?

Recommended Posts

I am using the Behringer UMC404HD digital audio interface into Calkwalk.  I am working on recording some acoustic guitar tracks.  I am adding reverb to a guitar track but do not hear it in my headphones connected to the UMC404HD when I am previewing prior to recording.  If I have the computer speakers turned up, I can hear the affects through them.  Shouldn't I be able to hear affects in my headphone mix prior to actually recording the track?

Edited by tdehan

Share this post


Link to post
Share on other sites

In the specs it says it has direct monitoring and the phones have source select. Make sure you're not direct monitoring and that the phones are set to the same source as the speakers.

Share this post


Link to post
Share on other sites

Yeah, it's a bit confusing.  I have no outputs from the UMC404HD to speakers.  The headphones is all that is plugged in to monitor.  I've played with the MIX knob.  When turned all the way to the left it is monitoring the INPUT (I believe).  When the knob is turned all the way to the right it is monitoring the PLAYBACK (again, I believe).  However, when turned all the way to the right there is no sound in the headphones.  When it is turned to the left or even to 12 o'clock I am hearing the guitar input, no affects from Cakewalk.

Share this post


Link to post
Share on other sites

If the speakers are not connected to the interface and the audio is playing through the speakers the DAW is set up with the UMC404HD as the input device and the output device is whatever is connected to the speakers (possibly the PC sound chip).

If you wish to use the headphones on the UMC404HD while recording or pratcicing, CbB must be set up so that the UMC404HD is both the input and output device.

In this case, it may be easier to connect the speakers to the UMC404HD and set it up as the default Windows audio device. This will permit using headphones, speakers or both in Windows and CbB.

 

 

Share this post


Link to post
Share on other sites

Correct, there are no speakers plugged into the interface.  The speakers are connected to my computer sound card.  If am understanding correctly, I need to setup within Cakewalk to use the interface for input and output.  Is that correct?

Also, what does CbB stand for?

Share this post


Link to post
Share on other sites

The speakers should be connected to the interface. The interface should be configured as the default Windows audio device.

If you do not wish to run everything through the interface then it will be necessary to set up Cakewalk by Bandlab (CbB) to either route to both devices all the time or switch routings depending on which device needs to play audio.

 

Share this post


Link to post
Share on other sites

I don't have studio monitor speakers, just computer speakers connected to the computer.

I will play with the interface and the input/output settings in Cakewalk.

Thanks

Share this post


Link to post
Share on other sites

If I enable a reverb affect (or not), set the Cakewalk Output to the UMC404HD and enable INPUT ECHO on (all tracks) I can hear the reverb in the headphones.  However, there is a severe delay in what I play and what I hear back.    If I don't set it this way, I get nothing back through the head phones when the interface is set to monitor PLAYBACK.

I'm missing something here...
 

Share this post


Link to post
Share on other sites

Monitoring through the DAW will always add some time between the signal origin and return. The amount of time mostly depends on the interface driver buffer settings and plug-in delay compensation.

 

The ability to alter the driver buffer settings and where the settings may be changed depend on the driver manufacturer and driver mode in CbB.

WASAPI Exclusive, WDM and MME use the buffer size slider in preferences.

Depending on manufacturer some ASIO drivers may use the slider too. Others need to use software supplied by the manufacturer.

WASAPI Shared cannot be adjusted.

 

To see if plug-ins are adding delay, use the FX button in the Mix Module to bypass all effects, "E" in the image below.

ControlBar.07.02.png

 

Share this post


Link to post
Share on other sites

Is it not normal to monitor affects on tracks during recording?  Or, is the norm to monitor all dry?

Share this post


Link to post
Share on other sites

If one wants to use DAW hosted effects on tracks being recorded an interface capable of running a small buffer is important. This usually means an interface with a factory supplied ASIO driver running with 128 samples or less and avoiding plug-ins designed for mixing/mastering while recording.

 

Share this post


Link to post
Share on other sites

oiYou will not easily be able to use the DAW's effects while recording, To do that you need a top class interface with low Round trip latency. RTL needs to be around 4 to 6 ms so as to not be that noticable. Most budget interface run at around 12- 30 ms at a safe buffer setting. Too low a buffer and you might get drop outs. 

There are a few work arounds but best practice is to always use ASIO mode and your direct monitoring so that your tracks will sync up properly.  If you use any other driver mode other that ASIO you will need to adjust your timing offset manually-- a real pita. 

The work around is to use your direct monitoring mixed with the computer playback/ input mix at about halfway. 

Now use input echo so the recorded sound ( effects)  can pass through to the headphones. You don't want speakers on will recording. 

Now crank up the effect but then turn the tracks level way down until you get the right blend. That delay caused by latency will still be there but in the background now.  Note, the tracks level and gain controls have no bearing on the recorded level. Only your interface controls input level. 

And you should avoid using your computers sound card and stick with the interface only. To use your computer speakers simply plug them into the headphone jack of the interface. You might need one of those 1/8" to 1/4" adapters that come with many headphones. 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...