Jump to content
xxxtank@comcast.net

Audio will not record correctly from MIDI source

Recommended Posts

Hi all,

i have not had any issues, with over 50 songs, recording audio with a MIDI instrument as my source.  All of a sudden, about 2 weeks ago, the audio would not record correctly.  I have a video sample attached.  When I select the Instrument as my recording source, I have always selected the Stereo input of the Instrument.  Youll see in the first part of the vid that all the sound works, the preview is correct, and even when i am actually recording, it shows the wave form as a stereo track.  When I stop the recording, however, CbB renders it to a Mono file.  AND the sound is complete crap (also in the video).  If I select a MONO input, its the opposite - it records mono, then renders it Stereo, and again, crap sound.

I have uninstalled and reinstalled all of my sound drivers including my USB MIDI driver.  I have uninstalled and reinstalled CbB.  Ive searched the forums high and wide for an answer.  Please help!

Windows 10, I-7 3.4, 32gb RAM

No new hardware or audio software installed or in last 2 weeks.

Share this post


Link to post
Share on other sites

The only thing I noticed is  that your record to track it set to mono. It is the little button just past the record button. It you click it,  it  will change shape to look like 2 wave forms instead of one.

Let us know if that helps.

 

Max Arwood

Share this post


Link to post
Share on other sites

It is a tiny triangle right past the red dot record button on the track. 
 

Max Arwood

Share this post


Link to post
Share on other sites
11 hours ago, Max Arwood said:

The only thing I noticed is  that your record to track it set to mono. It is the little button just past the record button. It you click it,  it  will change shape to look like 2 wave forms instead of one.

Let us know if that helps.

 

Max Arwood

do you mean this button?  it is a waveform preview button for me?

image.png.fb617521c05db92d0f14c53dd873c826.png

Share this post


Link to post
Share on other sites
Posted (edited)

No. @Max Arwood has made a mistake.

Your workspace is set to Custom.

2142701533_2020-05-3106_01_47-Window.jpg.2f1724e7dcfa464282f7ce451daff74f.jpg

Click on Custom, then select Track Control Manager. For Audio Strips, switch on Interleave/Phase.

581779908_2020-05-3106_05_43-Window.jpg.9f87a5c937eb0a445fe3439d0d006a0a.jpg

Make sure that Interleave (just to the right of O Master here) is the same as the mono/stereo input you select (here it is stereo) and also that the phase invert button is also not selected. You might have to make the track height bigger to see them.

Not saying that anything is wrong there, but just check. And it is kinda important to have them visible when recording.

Edited by Nigel Mackay
  • Like 1

Share this post


Link to post
Share on other sites

Nigel is right!  It is just past the master in his photo.  My question is - did that fix it?

 

Max Arwood

Share this post


Link to post
Share on other sites

Hi, this did not work.  I went in and turned on all options to view on the track and everything appears correct.  It is definitely a CbB issue because I have Reaper as well and the MIDI recording works perfectly.  I dont like Reaper as much though because their MIDI response has about a .5 sec delay, meaning its hard to line up the audio when playing live, and I really liked CbB because it didnt have that native latency.

I hope someone has the answer...

Share this post


Link to post
Share on other sites

Eureka, I figured it out.  My Driver Mode was set to WASAPI Shared.  I change it to MME and low and behold, it works.  Thanks for taking the time to help me guys.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...