Jump to content

Recommended Posts

Hi folks,

I'm having a weird problem with Cakewalk since the March update and I thought I would see if anyone has any ideas about why this is happening. I was hoping the latest update might have fixed my problem but no dice.

I have noticed that my CPU is running crazy hot, much hotter than normal, when using CbB. There is no temp rise when I use any other program. In a typical project I am running at less than 50% usage and the audio engine never gets above  65% and no late buffers. When I kill the audio engine the temp goes dramatically down.

My system is liquid-cooled and usually runs in the low 30s C under normal and even moderate to heavy usage never gets above the low 40s.. As soon as I start CbB the temp starts to go up well into the 40s with no project loaded.

I also have noted that I have to keep switching between different thread scheduling modes. When I open a project I find in almost all instances the first thread maxes out which facilitates a mode switch. Afterward, the threads seem to re-balance out.

The temp also seems to go up when more tracks are visible in the console view. If I hide the meters it saves a few degrees, temp-wise.

All this is making mixing a real pain. I have to constantly monitor the temps and stop frequently to let the heat dissipate. It  auto shut down from thermal protection this morning, which I have never had happen before.

Thanks for any insight you may have. I am completely vexed by this!!

Cheers,

Tommy

Share this post


Link to post
Share on other sites
Posted (edited)

First of all, 40 degrees is totally not "crazy hot". Look at your CPU's specification on the manufacturer's website and find what maximum operational temperature is allowed. Most likely it will be more than 70 degrees.

Second of all, what you see as CPU usage shows only CPU time usage, but not how it's blocks are used and how. Applications that make a lot of computations (like DAWs) typically use vector instructions like AVX and SSE. They process data much faster due to parallelism, but also consume more power per instruction. Most of the non compute intensive applications don't create this type of workload for CPU, therefore for them CPU consumes less power.

And the third. Cooling system must handle worst case scenario. But in many many situations CPU is underused, even it is 100% busy. That means you have to stress-test it by using some benchmark application, that can create worst-case workload for CPU in terms of power consumption.

Edited by Oleg Karavan

Share this post


Link to post
Share on other sites

I realize 40 isn't that hot-but my CPU thermal threshold is 61 as per the AMD specs for my processor. CbB will push it well into the mid-60s. That's where it starts to get dicey. The system shuts down at 70.  It scared the hell out of me this morning when it did that.

Good point about the stress test, although I've never had this problem before and my rig is in good shape.

Share this post


Link to post
Share on other sites

Are you running overclocked?

What type of cooling are you using?

Are all fans running?

You can also adjust your max CPU state, in Advanced Power Plan options, though I always have mine set to 100%.  I have a liquid CPU cooler, and a liquid graphics cooler, and my case has 21 fans in total (it is a monster PC with 128 GB of memory and 7 hard drives (2 PCIe M.2 2280 NVME, 1 2TB HDD, and 4 2TB SSD), but do not overclock, and everything runs nice and cool, no matter what I am doing.

Bob Bone

Share this post


Link to post
Share on other sites

Bob, I am not overclocked, as I said, my system is liquid-cooled and my system is fine tuned. No park control, highest power plan, etc. The issue is not with the temps under normal usage. It's a problem I have with CbB. I'm pretty computer-savvy and I've troubleshot as many things as I can. 

  • Thanks 1

Share this post


Link to post
Share on other sites
17 minutes ago, Tommy Byrnes said:

Bob, I am not overclocked, as I said, my system is liquid-cooled and my system is fine tuned. No park control, highest power plan, etc. The issue is not with the temps under normal usage. It's a problem I have with CbB. I'm pretty computer-savvy and I've troubleshot as many things as I can. 

Of course we have no idea how much your other programs stress the CPU. It would not be surprising that Cakewalk provides an exceptional load compared to normal usage. It is also not clear what the significance of your computer being liquid cooled is, in a case where you are concerned that it is overheating. A liquid cooler can fail just like an air driving fan, but it is simpler to detect fan failure than other issues. Have you dismantled the system to see if it has coolant left, or run it outside the computer with a fluid source to check that it is pumping, or checked the thermal connection to the cpu and adequacy of the thermal paste? If you are having a cooling problem it is probably best to start with troubleshooting the cooling system rather than imagining that some update in a program is producing a large demand change.

Share this post


Link to post
Share on other sites
2 hours ago, Tommy Byrnes said:

Good point about the stress test, although I've never had this problem before and my rig is in good shape.

Use Ryzen master to run a stress test.  According to mine the the temp limit on my AMD CPU is 95 degrees C

Stress test took it to 76.  Normal heavy Cakewalk project temp is  hovering around the mid 50's ..that's with the stock air cooler and no o/c

CBB doesn't cause the temps to ramp up especially

Share this post


Link to post
Share on other sites

This is a new problem and has nothing to do with my rig. The computer only does this with Cakewalk. No problems in Mixbus, no abnormal temps when doing graphics work or any other program. I get a safety shutdown at 71C. Done it twice today so I'm dead in the water until I find out why only Cakewalk is doing this.

Share this post


Link to post
Share on other sites
Posted (edited)

Scook, I started noticing this after the March update. I'm running the May Early Release because I hoped it would fix this. Nope. As I said in the OP since then the thread scheduling needs to be changed just about every time I open CbB. 

Edited by Tommy Byrnes

Share this post


Link to post
Share on other sites

By thread scheduling do you mean the ThreadScheduleModel setting in Aud.ini? If so you may want to check out the 2020.05 EA release.

 

Share this post


Link to post
Share on other sites

Yes, that's what I mean. I have to go into the config and change the model. I'm on the 2020.05 EA release

Share this post


Link to post
Share on other sites

Aud.ini should not spontaneously change.

The thread in my post above is dedicated to the 2020.05 EA release and is actively scanned by the devs.

 

Share this post


Link to post
Share on other sites

Is that happens with or without plug-ins? Can it be you had some changes in plug-ins you use (updates or simply changing settings)? As correctly was mentioned by Oleg, CPU consumes different power based on activity. In my case (i9), "100%" CPU tests can consume from around 90 up to 250W (if not limited...), depending from what these tests do.

Since you mention some interference with graphics, check/update your graphic card driver. F.e.  graphics can switch into "software" mode with bad drivers.

In any case, if your system can hit thermal limit something is designed/set/assembled incorrectly or broken. No software activity should be able to overheat correctly build system.

  • Great Idea 1

Share this post


Link to post
Share on other sites
14 minutes ago, Tommy Byrnes said:

Yes, that's what I mean. I have to go into the config and change the model. I'm on the 2020.05 EA release

Avoid using ThreadSchedulingModel 3, per Noel, because it is experimental and not working properly.  Usually, setting it to 2 is best for multi-core processors.

Share this post


Link to post
Share on other sites
1 hour ago, azslow3 said:

Is that happens with or without plug-ins? Can it be you had some changes in plug-ins you use (updates or simply changing settings)? As correctly was mentioned by Oleg, CPU consumes different power based on activity. In my case (i9), "100%" CPU tests can consume from around 90 up to 250W (if not limited...), depending from what these tests do.

Since you mention some interference with graphics, check/update your graphic card driver. F.e.  graphics can switch into "software" mode with bad drivers.

In any case, if your system can hit thermal limit something is designed/set/assembled incorrectly or broken. No software activity should be able to overheat correctly build system.

Thanks, Azlow. I don't think I"ve had any major plugin changes. A few new ones from Plugin Alliance and one from FabFilter, neither of which have caused issues in the past.  The temp starts to spike as soon as I open CbB.

Share this post


Link to post
Share on other sites

Do you have a copy of SPlat? Or a way to roll back your version of CbB.  

I find myself opening problem child files in Splat just to see what happens. I had TTS-1 crashing CbB yesterday. Couldn't load any file that used TTS-1 and even a new project would crash CbB. No problem with Splat??  TTs-1 worked fine there. 

The big mystery is the issue went away when I tried CbB again. 

It's almost sounding like a runaway. I heard of people having projects that the software just keeps building and building. It's often a plug in. 

Share this post


Link to post
Share on other sites
11 hours ago, Tommy Byrnes said:

Thanks, Azlow. I don't think I"ve had any major plugin changes. A few new ones from Plugin Alliance and one from FabFilter, neither of which have caused issues in the past.  The temp starts to spike as soon as I open CbB.

"Open CbB" is too complex operation for computer, to get reasonable advise you need to localize the source:

  1. Open CbB with EMPTY project. Turn off audio engine. Minimize it to the tray. Any CPU use from it?
  2. Step by step, checking significant CPU load increase:
    1. Maximize CbB
    2. Add several audio tracks without plug-ins, up to your usual number of tracks in the project
    3. Start audio engine (if not started by tracks)
    4. Add some audio clips
    5. Start playback
    6. Add plug-ins
    7. Load your usual project

Once you notice CPU load, independent on which step, try minimize CbB and then change audio device to build-in.

That should point which part of the system/CbB triggers high temperature: plug-in(s), graphics, audio interface.

Sorry for repeat, but from all your previous observations it seems like your system is "fine tuned" for low multi-core load only. I mean if full powered single core overheat, full powered all cores will switch your system off instantly. Can you run PRIME95 for a half an hour? I guess not, and that is looking for troubles.

FX-8350 is an "old world" AMD CPU. Every surface micrometer has to carry the heat out from TDP 125W to keep "max temp" under 61C. May be it is time to re-mount the cooling head. For comparison: modern AMD CPUs have TDP 105W (real ~150W) and "max temp" 95C. That is obviously way simpler to keep under control.

My own system is Intel based, ~40C idle. It runs ~70C when "test loaded" under TDP (95W), I can keep it under 85C with power limit 170W. Without limits it can consume up to 250W and my "small" air cooler is unable to deal with that (I have only one case fan). All that without any "manual overclocking", modern CPUs overclock themselves by default...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...