Jump to content
Peter C

That pesky realtek driver.......

Recommended Posts

....which Cakewalk insists on defaulting to (Preferences > sync and caching > record latency adjustment) instead of my Steinberg UR44. When I select the UR44 option and hit apply it doesn't - just defaults back to realtek.

Clean install of CW. I've looked at previous posts about this and no-one really seemed to solve it. The on-board realtek audio has been disabled in the bios. The realtek driver has been uninstalled (and hasn't magically been reinstalled while I've not been looking). I have edited the AUD.ini file in appdata/roaming/cakewalk/cakewalkcore and deleted all references to the realtek audio. So it appears Cakewalk is referencing something which isn't there. Audio performance appears fine with usual latency when recording. I have thrown every softsynth I could lay my hands on in a test project and CW stood up well. I should also add I am using the ASIO driver for the UR44. And when realtek shows up that is also shown as realtek asio.

Interestingly when I go back to the AUD.ini file the reference to realtek has reappeared. In Device Manager the on-board realtek audio is not shown at all.

Any ideas?????? Anyone?????

 

 

 

Share this post


Link to post
Share on other sites

Well, that is pretty weird, I have to agree - I have a Yamaha/Steinberg UR22 hooked up at the moment, as my larger interface is being borrowed by a friend, at the moment, and here is what is there for my system:

 

image.thumb.png.c08dc7dbe0c4cfd7b870d5037d1f1aa6.png

Share this post


Link to post
Share on other sites

Aside from the UR44 are there any other entries in HKEY_LOCAL_MACHINE\SOFTWARE\ASIO
 

 

Share this post


Link to post
Share on other sites
15 minutes ago, seadude said:

....which Cakewalk insists on defaulting to (Preferences > sync and caching > record latency adjustment) instead of my Steinberg UR44. When I select the UR44 option and hit apply it doesn't - just defaults back to realtek.

Clean install of CW. I've looked at previous posts about this and no-one really seemed to solve it. The on-board realtek audio has been disabled in the bios. The realtek driver has been uninstalled (and hasn't magically been reinstalled while I've not been looking). I have edited the AUD.ini file in appdata/roaming/cakewalk/cakewalkcore and deleted all references to the realtek audio. So it appears Cakewalk is referencing something which isn't there. Audio performance appears fine with usual latency when recording. I have thrown every softsynth I could lay my hands on in a test project and CW stood up well. I should also add I am using the ASIO driver for the UR44. And when realtek shows up that is also shown as realtek asio.

Interestingly when I go back to the AUD.ini file the reference to realtek has reappeared. In Device Manager the on-board realtek audio is not shown at all.

Any ideas?????? Anyone?????

 

 

 

Are you using ASIO driver mode?  I don;t even show any other option in that Record Latency Adjustment paramter's drop-down, than my audio interface..., UNLESS I am using like WASAPI Shared 

 

Edited by Robert Bone
Added a little text

Share this post


Link to post
Share on other sites

Well I can see that driver (Yamaha Steinberg USB ASIO (3 in, 3 out) and I can select it but it doesn't stick.

Share this post


Link to post
Share on other sites
1 minute ago, seadude said:

Well I can see that driver (Yamaha Steinberg USB ASIO (3 in, 3 out) and I can select it but it doesn't stick.

Understood - but again - the only time I even SEE any other options in the drop-down for Record Latency Adjustment, is if I am using a driver mode other than ASIO.  I would think that using a driver mode of ASIO would likely give you the best performance/quality for that audio interface you have.

Please go to Preferences > Audio > Playback and Recording, and tell me what Driver Mode is shown there.  If it is not showing ASIO there, I suggest you try using ASIO, and then click Apply, and it should change other parameters for you, in support of that Driver Mode.  That would include the Timing Master paramters, and the Record Latency Adjustment, as well.

 

Share this post


Link to post
Share on other sites

Aside from the UR44 are there any other entries in HKEY_LOCAL_MACHINE\SOFTWARE\ASIO

Oh yes, the darne thing is there. I guess I should delete it

Share this post


Link to post
Share on other sites
3 minutes ago, seadude said:

Aside from the UR44 are there any other entries in HKEY_LOCAL_MACHINE\SOFTWARE\ASIO

Oh yes, the darne thing is there. I guess I should delete it

Yes

If the UR44 is the only record in the HKEY_LOCAL_MACHINE\SOFTWARE\ASIO, that is all Cakewalk will see when running in ASIO driver mode.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, seadude said:

Robert, yes it's showing ASIO

OK - so I guess deleting the registry entry for the Realtek makes sense to try - I only show the single entry for my UR22 in my registry for ASIO. :)

Share this post


Link to post
Share on other sites

Thanks Scook, that's done it. And thanks Robert for your inpout as well. How could I have missed that........

  • Like 1

Share this post


Link to post
Share on other sites
43 minutes ago, seadude said:

Thanks Scook, that's done it. And thanks Robert for your inpout as well. How could I have missed that........

Just glad you are all squared away.  :)

Share this post


Link to post
Share on other sites
Posted (edited)

The nature of late Realtek sound regulator and sound drivers has experienced a plunge as of late, and the naturally introduced drivers on Windows 10 have presented a critical deferral in the time it removes for sound to come from the speakers after it is started by the PC. There's no disadvantage to this, then again, actually you should physically introduce them now and after any Windows update that reinstalls the default Realtek sound drivers. The directions underneath will walk you through the cycle. 

  1. Dispatch the gadget administrator via looking for "Gadget Manager" in the beginning menu 
  2. Extend the "Sound, video, and game regulators" hub to find the "Realtek Audio" gadget, at that point right-click it and pick "Properties" 
  3. In the subsequent exchange, change to the "Driver" tab at that point select "Update Driver" 
  4. Pick the "Peruse my PC for driver programming" alternative 
  5. Pick "Let me pick from a rundown of accessible drivers on my PC" 
  6. Uncheck the "Show viable equipment" alternative to compel the presentation to incorporate drivers not composed by Realtek (all renditions of which are influenced by this issue) 
  7. Select "Microsoft" in the first listbox on the left (the rundown of makers) at that point select "Top notch sound gadget" from the subsequent rundown in the listbox on the left (the gadgets), at that point click "Next" 
  8. An admonition exchange will show up, endeavoring to prevent you from choosing a driver not composed by Realtek and explicitly planned for the sound card in your PC. That is OK, we are utilizing Microsoft's own drivers and they're ensured to work, so squeeze "Yes" to proceed 
  9. Windows will start refreshing the driver and introducing the one you chose. Contingent upon the speed of your PC, this may require a little while, yet it should finish all alone with no mediation, and afterward you'll see an "Sound Drivers Installed" exchange affirming the update has finished 
  10. Now, close the driver discourse and the gadget administrator, and afterward restart your PC to finish the interaction 
  11. Restart your PC to finish the interaction. You might see a brief requesting that you do as such, yet you ought to restart in all cases
Edited by Wiliam

Share this post


Link to post
Share on other sites

I switch between my Focusrite ASIO interface and my Real tech on board audio all the time. Never have issues what so ever.  I think there just might be a dozen or more different versions if not more which is why the different experiences.   The ticket is to not use ASIO when using the Realtech driver. WASAPI mode gives me performance that is more or less identical to the performance I get with Focusrite ASIO drivers. I just don't do any recording in that mode. But playback and editing work perfectly fine. 

Share this post


Link to post
Share on other sites

I use my Focusrite or RME in ASIO mode, and leave my Realtek device as the Windows sound device. Both are connected to my Mackie Big Knob Passive which I use to switch between the two if I need to watch something on Groove3 or YouTube.

Luckily no ASIO drivers came with my Realtek device, so CbB doesn't even try to use it. 

 

Share this post


Link to post
Share on other sites
Posted (edited)

This is why it’s a good idea to go look in the register as scook  has pointed out. He had pointed this out to me a few months ago and sure enough I had the real tech ASIO driver there so I deleted it. Therefore no issues. 
If you have any Steinberg software you need to go there and make sure you don’t have that driver as well. Not sure if it is installed with their interfaces. It’s call Steinberg generic ASIO driver 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...