Jump to content
Sign in to follow this  
spiffo

Ctrlr - SysEx and VSTs

Recommended Posts

OK so I have a Ctrlr Panel running as a VST inside Cakewalk and I've got issues.

I have tried just about every combination of MIDI Routing inside Cakewalk and every option on Ctrlr but I cannot seem to route any SysEx through Cakewalk. The Panel is a Synth Editor that spits out a lot of SysEx in order to edit the Synth's parameters.

The only way I can get it to work is to deselect the MIDI Ouput Interface in Edit - Preferences - MIDI Devices and then point Ctrlr's MIDI Output directly at the MIDI Interface, of course now I cannot use that MIDI Interface inside Cakewalk for anything else!

After a bit of googling it seems that this is NOT a Cakewalk only 'feature' many other DAWs are not capable of passing SysEx to and from VSTs?

Can anyone confirm or deny, and has anyone else any experience of using Ctrlr inside Cakewalk as a VST?

Share this post


Link to post
Share on other sites

Bump, does anyone know whether Real-time SysEx messages are routable In Cakewalk at all, in and out of VSTs or whatever?

Share this post


Link to post
Share on other sites

I am not quite sure about your specific problem and about VST plugins and Sysex, but I am pretty sure that Cakewalk can route  sysex in realtime. As a matter of fact, Studioware panels are still supported, and they could use sysex to control external hardware in real time. Not sure about the possible limitations with VST plugins.

Share this post


Link to post
Share on other sites

There is a setting in Cakewalk Preferences whether sysex goes into sysex manager and not to tracks.

Try if that might fix your problem. That is the default setting.

Share this post


Link to post
Share on other sites

Don't have Ctrlr.

If the plug-in has it's own MIDI routing feature and is not using the regular "Enable MIDI Output" option built into CbB for VSTs, I would try using a virtual MIDI cable (LoopBe1) to send the data to a MIDI track and point the track to the MIDI interface.

If that did not work, I would try connecting the virtual MIDI cable to MIDIOX.

 

Share this post


Link to post
Share on other sites
On 5/19/2020 at 7:03 AM, LarsF said:

There is a setting in Cakewalk Preferences whether sysex goes into sysex manager and not to tracks.

Try if that might fix your problem. That is the default setting.

Is that in the Edit - Preferences somewhere or does it need to be added to an .ini file like the ttseq.ini ?

Share this post


Link to post
Share on other sites

Pretty sure this is reference to opening MIDI files

On 5/19/2020 at 6:03 AM, LarsF said:

There is a setting in Cakewalk Preferences whether sysex goes into sysex manager and not to tracks.

Try if that might fix your problem. That is the default setting.

See Always use Sysx Banks for MIDI Files (Instead of Sysx Data) in http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=0x22B0A

There are several sysex related parameters in TTSSEQ.ini but nothing caught my eye.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...