Jump to content
  • 0
Laszlo Mayer

Focusrite 18i20 - multiple input setup

Question

Hello,

Would anybody know the solution how to setup Focusrite 18i20 in Bandlab to see all the inputs and not just the stereo 1/2 channels?  I believe the drivers are installed correctly (re-installed it multiple times). All of my (8) microphones are generating signals and I can record correctly in Bandlab but only on two channels.  I did tons of research but I cannot find the solution anywhere.  Also contacted Focusrite support but they did not get back to me yet.   I saw some posts where people recommend to use the ASIO driver but this crashes my laptop and Focusrite is not recommending it either.  I'm using the generic MME driver with Win 10.

Any help is appreciated

Thanks,

Laszlo

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
9 hours ago, Laszlo Mayer said:

Hello,

Would anybody know the solution how to setup Focusrite 18i20 in Bandlab to see all the inputs and not just the stereo 1/2 channels?  I believe the drivers are installed correctly (re-installed it multiple times). All of my (8) microphones are generating signals and I can record correctly in Bandlab but only on two channels.  I did tons of research but I cannot find the solution anywhere.  Also contacted Focusrite support but they did not get back to me yet.   I saw some posts where people recommend to use the ASIO driver but this crashes my laptop and Focusrite is not recommending it either.  I'm using the generic MME driver with Win 10.

Any help is appreciated

Thanks,

Laszlo

If you can't use ASIO use WASAPI.  You'll get terrible latency with MME - this should only be used as a last resort.

Then go into Preferences -> Audio -> Devices and make sure "Show Mono Outputs" is checked.

Out of interest, what version of the ASIO driver are you using?  I'm using v4.64.15 without issue.
 

Share this post


Link to post
Share on other sites
  • 0

Hi Mark,

 

Thank you for your reply.  I'll try to setup WASAPI but yes, I did go to Preferences and checked "Show Mono Outputs".   The ASIO driver I tried to use is the latest version from their website 2.14.  Anytime I tried to switch to it, I receive a "blue screen of death" on my Dell XPS laptop.  

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Laszlo Mayer said:

Brand new, I just got the interface couple of weeks ago: 3rd generation.

I think you're best approach is to keep trying with Focusrite. I'm surprised at your comment that they're not recommending using ASIO - was this directly from Focusrite themselves?

They did have quite a few BSOD issues with their driver, which they fixed in a beta version  ( you can see the beta releases at http://beta.focusrite.com ) .

For the 1st gen at least, they combined the latest firmware, MixControl and 4.64.15 USB driver in that beta. The official release for the 1st gen includes the previous version (4.63.24.564) of the USB driver. However installing the official 1st gen 2i2 ASIO USB driver brings it up to the latest - so essentially the same as the beta.

For the 3rd gen though, the drivers are different.

You said in an earlier post, you're using the v2.14 driver- the latest for the 3rd gen should be Focusrite Control v3.5.0:

https://customer.focusrite.com/en/support/downloads?brand=Focusrite&product_by_range=1359&download_type=software

I'd recommend giving the v3.5.0 a go, and if this doesn't solve your issue use WASAPI in the meantime.
 

Share this post


Link to post
Share on other sites
  • 0

Thanks.  I'm waiting for Focusrite response.  Sorry, I meant that I'm using the ASAPI4ALL version 2.14.  I'm using the latest Focusrite driver and I will try WASAPI later today.

Look at this post:

https://support.focusrite.com/hc/en-gb/articles/115002006329-Can-I-use-ASIO4all-with-my-Focusrite-Interface-

Extract from the post;

"Can I use ASIO4all with my Focusrite Interface?

3 years ago

Updated

We do not recommend using ASIO4all in your DAW for your Focusrite Interface.

The Focusrite Interfaces all come with a native device specific driver that includes both ASIO and WDM driver types."

 

Share this post


Link to post
Share on other sites
  • 0
37 minutes ago, Laszlo Mayer said:

Thanks.  I'm waiting for Focusrite response.  Sorry, I meant that I'm using the ASAPI4ALL version 2.14.  I'm using the latest Focusrite driver and I will try WASAPI later today.

Look at this post:

https://support.focusrite.com/hc/en-gb/articles/115002006329-Can-I-use-ASIO4all-with-my-Focusrite-Interface-

Extract from the post;

"Can I use ASIO4all with my Focusrite Interface?

3 years ago

Updated

We do not recommend using ASIO4all in your DAW for your Focusrite Interface.

The Focusrite Interfaces all come with a native device specific driver that includes both ASIO and WDM driver types."

 

There should be absolutely no reason to run ASIO4ALL with the 18i20.

ASIO4ALL is a "fake" ASIO driver for use with audio interfaces that don't have a native ASIO driver. The 18i20 has it's own ASIO driver specifically written for it.

My recomendations:
1. Uninstall ASIO4ALL completely
2. Install the latest Focusrite Control 3.5.0
3. Switch to ASIO mode in Cakewalk

Share this post


Link to post
Share on other sites
  • 0

Okay, finally I figured it out.  Since I'm a "newbie", I missed a couple of things:

1. You don't need to install a new ASIO4ALL driver.  It comes with 3rd generation of Focusrite. (I uninstalled it. This was the one that crashed my computer.)
2. After if I select ASIO driver in setup, I have the option to pick ASIO Focusrite USB.  Suddenly, everything falls into place.  Now I can select multiple inputs.

This post also helped me to setup inputs:

https://support.focusrite.com/hc/en-gb/articles/206849199-How-to-select-outputs-in-Cakewalk-Sonar

I'm still running into issues but at least I can record on all channels.  I cannot pan kick to the middle after recording.  Same with the snare: it is always on the right and cannot be panned to the middle after recording....but I'll figure it out.   I guess that's called the learning curve 🙂

 

Thanks for the help again,

Laszlo

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...