Jump to content
winkpain

MIDI keyboard suddenly no longer works in CW

Recommended Posts

This is now a consistent problem for me.

Every time I instantiate CW, whatever MIDI keyboard/controller I have connected and setup in Preferences (and was working previously) does not get "read" by CW (except in the little MIDI input activity blinks); does not function. I have to clear the device from Pref/MIDI/Devices, exit program, start-up again, and re-establish device in Prefs. in order to function.

Why, oh why?

Share this post


Link to post
Share on other sites

I'd love some advice on this. I'm really in the dark here.

No MIDI device will function, either with USB connection or MIDI cable through audio interface without first disabling (un-checking) it in Preferences, exiting CW with no devices enabled, re-opening CW and then re-enabling the device in Preferences. I must repeat this process every time I start CW.

Deleting/renaming TTSSEQ does not help.

I see in my MIDI devices window in Preferences that every MIDI connection I have ever made is in the list whether enabled or not. Is there a way to clear this ? Maybe this would help CW start with a "clean slate" so as to re-establish the MIDI settings for these devices somehow? 

Really flummoxed as to how this came about all of a sudden....

Share this post


Link to post
Share on other sites
31 minutes ago, scook said:

Thanks scook!

That looked promising, and it did get me to get rid of some undesired, previously installed MIDI devices in my Device Manager. But I didn't have anywhere near 10 devices installed, nor were there any hidden devices. I even uninstalled my desired devices and re-installed them and their drivers.

In any case, the problem persists. Perhaps it is worth re-iterating that I have no issues with other applications (stand alone synths, other DAW, etc.) with any of my MIDI devices. Only CW has this issue and it only began a week and a half ago, first intermittently and then consistently...

ūüėē

 

Share this post


Link to post
Share on other sites

I have recently started having the exact  same issue.  Has anyone found a solution to this problem?

Every time Cakewalk is started the  Midi controller does not work.  I have to unselect the controller in preferences, exit Cakewalk, restart Cakewalk and then  select the controller again.  Basically  if  Cakewalk is  started with the controller selected it does not work which is  getting annoying. I do not have any issues with the controller in any other application.

 

 

Share this post


Link to post
Share on other sites
17 hours ago, Alastair Cardwell said:

I have recently started having the exact  same issue.  Has anyone found a solution to this problem?

Every time Cakewalk is started the  Midi controller does not work.  I have to unselect the controller in preferences, exit Cakewalk, restart Cakewalk and then  select the controller again.  Basically  if  Cakewalk is  started with the controller selected it does not work which is  getting annoying. I do not have any issues with the controller in any other application.

 

 

Yup. this is exactly my issue.

Still no answers here.

Share this post


Link to post
Share on other sites

I have the same M - Audio keyboard for many years. Every once in the while my keyboard does not respond at all.

You have to reset to its factory default settings.

1) power off the keyboard

2) hold down the buttons AVANCED, OCT + AND OCT - simultaneously

3 power on the keyboard

4) release the trhee buttons

Now you have the factory default settings

 

 

Share this post


Link to post
Share on other sites

With Cakewalk, the MIDI controllers must be powered on before Cakewalk is launched.

Some  other  DAWs do not require that.

So if the PC has power saving enabled, it may be powering down the USB ports, even with the controller plugged in. Then Cakewalk wouldn't see them at  launch time.

Share this post


Link to post
Share on other sites
15 hours ago, abacab said:

With Cakewalk, the MIDI controllers must be powered on before Cakewalk is launched.

Not necessarily the case for all controllers. I've got an Akai MPK-49, which is bus powered. There's a power switch on the back, but it's inconvenient to get to in my setup. Left to it's own devices, the keyboard would be on (and glowing blue) whenever the computer is turned on, which is 24/7... so I have the MPK on one leg of a usb A/B switch, which let's me turn it on and off (and connect/disconnect it from the PC) via a more convenient location.

Point being, I can turn the keyboard on while Cakewalk is running, and CW will pop up a dialog to the effect of "MPK-49 detected, use it?" It'll similarly complain when I disconnect it, but it's all good.

 

But never ever disconnect a Focusrite Scarlett while CW is running. That is, assuming you're not a big fan of BSODs.

Share this post


Link to post
Share on other sites
21 hours ago, abacab said:

With Cakewalk, the MIDI controllers must be powered on before Cakewalk is launched.

Some  other  DAWs do not require that.

So if the PC has power saving enabled, it may be powering down the USB ports, even with the controller plugged in. Then Cakewalk wouldn't see them at  launch time.

 

6 hours ago, John Bradley said:

Not necessarily the case for all controllers. I've got an Akai MPK-49, which is bus powered. There's a power switch on the back, but it's inconvenient to get to in my setup. Left to it's own devices, the keyboard would be on (and glowing blue) whenever the computer is turned on, which is 24/7... so I have the MPK on one leg of a usb A/B switch, which let's me turn it on and off (and connect/disconnect it from the PC) via a more convenient location.

Point being, I can turn the keyboard on while Cakewalk is running, and CW will pop up a dialog to the effect of "MPK-49 detected, use it?" It'll similarly complain when I disconnect it, but it's all good.

 

But never ever disconnect a Focusrite Scarlett while CW is running. That is, assuming you're not a big fan of BSODs.

My experience is the same as John I  can plug a midi  keyboard in (Novation 49SL MkII) after Cakewalk is  started and a dialog is displayed  asking if I want Cakewalk to add this device now. 

Even when the  controller is not responding , if I unplug the USB cable Cakewalk displays a message to say that it was disconnected , then when plugged back in the dialog asking if I want Cakewalk to add this device now displayed but it still does not respond after clicking Yes. The only way to get it to work is to unselect it in settings close Cakewalk, open Cakewalk and then select it again. 

 

Share this post


Link to post
Share on other sites
5 hours ago, Alastair Cardwell said:

 

My experience is the same as John I  can plug a midi  keyboard in (Novation 49SL MkII) after Cakewalk is  started and a dialog is displayed  asking if I want Cakewalk to add this device now. 

Even when the  controller is not responding , if I unplug the USB cable Cakewalk displays a message to say that it was disconnected , then when plugged back in the dialog asking if I want Cakewalk to add this device now displayed but it still does not respond after clicking Yes. The only way to get it to work is to unselect it in settings close Cakewalk, open Cakewalk and then select it again. 

 

This is the same with me with both my Novation and M-Audio keyboards, both continuing to work fine in all other, non-Cakewalk instances.

Share this post


Link to post
Share on other sites

Oh, the Cakewalk MIDI gods. Just when we men of science think we have it figured out, they go and start demanding the sacrifice of chickens again.

These must be dark times indeed, dark times indeed.

  • Haha 1

Share this post


Link to post
Share on other sites
On 6/7/2020 at 11:43 PM, Starship Krupa said:

Oh, the Cakewalk MIDI gods. Just when we men of science think we have it figured out, they go and start demanding the sacrifice of chickens again.

These must be dark times indeed, dark times indeed.

I would sacrifice a chicken at this point to get this fixed! Is there a post about the proper procedure you can point us to?? I wouldn't want to mess up the juju!¬† ūüėČ

Share this post


Link to post
Share on other sites

Delete TTSSEQ.ini, start Cakewalk, enable your Midi device...good to go :) I've had to do this every time I open Cakewalk or Sonar for ages now! Just deleting TTSSEQ.ini only does a reset, you still have to enable your Midi device before it will communicate.

Bill

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Cookie Jarvis said:

Delete TTSSEQ.ini, start Cakewalk, enable your Midi device...good to go :) I've had to do this every time I open Cakewalk or Sonar for ages now! Just deleting TTSSEQ.ini only does a reset, you still have to enable your Midi device before it will communicate.

Bill

Are you suggesting that deleting TTSSEQ.ini and re-enabling the MIDI device every time you open Cakewalk is just the way it is?

Surely that indicates, as does mine and all the other instances of the problem here in this thread, that something is wrong.  I, too, can get it working with that procedure and have done so, or by disabling the device, re-opening CW and re-enabling the device, which I guess in effect is the same thing. Either method being necessary every time I open CW surely is not the way it should be.

Share this post


Link to post
Share on other sites

We're currently looking into these issues.

From what I've noticed so far there's a few issues:

  1. Cakewalk isn't always getting connection/disconnection notifications from Windows. Interestingly though, if Windows Device Manager is running at the time, the notifications are received instantly. Not all users are seeing this issue though.
  2. If you re-connect a MIDI devices while Cakewalk is running (and Cakewalk does actually get notified about it). Cakewalk doesn't enable it- it leaves it unchecked.
  3. Related to (2) - if you go into preferences and change anything. in any page, the MIDI preferences are overwritten meaning that your unchecked devices are saved as unchecked.

Until we sort the issues out, there are a few things you can do in the meantime:

  1. Always use the same USB ports for MIDI devices, and always plug in your devices before you start Cakewalk
  2. If possible, make sure they're plugged in before starting your PC so they're always assigned same device ID by Windows.
  3. If you have a stable MIDI setup you want to keep, consider making TTSSEQ.INI read-only. This will prevent Cakewalk from overwriting it.
  4. Make sure USB sleep is disabled in your power options.
  • Thanks 1

Share this post


Link to post
Share on other sites

My Midi is Midi...Midi In and Out, not USB ;)

I've compared the TTSSEQ.ini before and after doing my "mojo" and they're exactly the same so something else is happening under the hood! Regardless I can get it to open :)

Bill

Share this post


Link to post
Share on other sites
18 hours ago, msmcleod said:

We're currently looking into these issues.

From what I've noticed so far there's a few issues:

  1. Cakewalk isn't always getting connection/disconnection notifications from Windows. Interestingly though, if Windows Device Manager is running at the time, the notifications are received instantly. Not all users are seeing this issue though.
  2. If you re-connect a MIDI devices while Cakewalk is running (and Cakewalk does actually get notified about it). Cakewalk doesn't enable it- it leaves it unchecked.
  3. Related to (2) - if you go into preferences and change anything. in any page, the MIDI preferences are overwritten meaning that your unchecked devices are saved as unchecked.

Until we sort the issues out, there are a few things you can do in the meantime:

  1. Always use the same USB ports for MIDI devices, and always plug in your devices before you start Cakewalk
  2. If possible, make sure they're plugged in before starting your PC so they're always assigned same device ID by Windows.
  3. If you have a stable MIDI setup you want to keep, consider making TTSSEQ.INI read-only. This will prevent Cakewalk from overwriting it.
  4. Make sure USB sleep is disabled in your power options.

Nice to know this is in your sights. Strange, tho, that it should be an "all of a sudden" issue, no? Does this mean it's crept in with these latest updates?

Share this post


Link to post
Share on other sites
Just now, winkpain said:

Nice to know this is in your sights. Strange, tho, that it should be an "all of a sudden" issue, no? Does this mean it's crept in with these latest updates?

No, I think it's been like this for a while.

We've been looking at some control surface issues which has put more focus on it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

√ó
√ó
  • Create New...