Jump to content
winkpain

"Duplicate" not honoring envelope and Ripple settings

Recommended Posts

I am sorry to harp on these issues that I've mentioned before, but I've had no response either confirming or denying these issues, so I just don't know whether the problems are mine alone or to be fixed in a later update.

There are two issues with the Duplicate command (my favorite of the "recent" additions!) that continue to frustrate my flow, man!

In brief:

  • With "Select track envelopes with clip" checked "On", selecting a clip and choosing "Duplicate" with the clip context menu or its shortcut CTRL-D does not copy the envelopes with the clip. 😕  However, choosing the Section (in Arranger) containing the clip(s), right-clicking and choosing "Duplicate" from the Section context menu,  OR CTRL-clicking the clip and CTRL-dragging to copy does copy the envelope along with clips, as they both should do. 🙂

AND

  • With Ripple Edit on, choosing MIDI notes in the full PRV and then choosing Duplicate will not ripple edit the following material (it will just overlay it) 😕 However, choosing the exact same notes in the inline PRV of the track and choosing Duplicate will ripple edit the material as is the desired and called for behavior.

The Duplicate command and its CTRL-D shortcut have come to be very oft-used and second nature in my editing and these two issues above seriously impede the flow that its use is obviously supposed to improve.

 

Am I alone, or can these issues be replicated by anyone else and be deemed buggy?

Share this post


Link to post
Share on other sites

Here are the issues being clearly shown as described with 1 showing the envelope problem and 2 showing the Ripple Edit problem...

Share this post


Link to post
Share on other sites

The envelope issue has been fixed for the next release.

The PRV issue will need further investigation.
 

  • Thanks 2

Share this post


Link to post
Share on other sites
5 hours ago, msmcleod said:

The envelope issue has been fixed for the next release.

The PRV issue will need further investigation.
 

Thanks for the response!

So it's not just me. I'm glad it's on your radar!

Odd, to some of us on the front end, that the Inline PRV and full PRV behave differently enough to make this an issue, but I hope the fix isn't too difficult.

AND, if it really is on the radar, the (full) PRV smooth zoom/honoring mouse wheel zoom settings issue would be a good fix as well. Perhaps it is related(?) given the odd differentiation between here and the Inline PRV (which does honor those settings).

Edited by winkpain

Share this post


Link to post
Share on other sites

...AND still speaking of PRV issues:

I mentioned this in the Feedback Loop, but

When editing MIDI notes and having the track solo'd for focused work, selecting and editing chosen notes with any of the Process commands, the track goes silent when playing after editing.  This is most commonly encountered, for me, when quantizing the selected notes, then playing to hear the change. But it happens with all the Process commands (Slide, Nudge, etc.)

After editing, if Exclusive Solo is on, there is suddenly no sound when playing the solo'd track. If Dim solo, everything plays at the dimmed level. Toggling the solo button will cure this. This happens every time with the above conditions.

 

@msmcleod, I'm happy to be schooled on the proper protocol for bringing up these issues through the proper channels! I'm sorry to cross/multiple-post, but I'm never sure which area of the forum here is exactly the right place for certain posts.

Q&A  is clear enough - ask a single point question , get answer (you hope!). But mainly the difference between issues like "I'm having a problem that is likely because I'm not sure how to do something. Advice, please."  as opposed to "CW isn't behaving the way it theoretically should be behaving. Tell the bakers" has me not certain how to proceed.   Is there a clear protocol?

 

As always, thanks so much for your time!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...